[Stable Update] 2020-12-30 - Kernels, KDE, Cinnamon, LibreOffice, Python 3.9, Mesa 20.3.1

@philm it was the kernel 5.9.16 that caused the problem.
So I use 5.10 for now :slight_smile:

I have the same problem.

This did the trick, thanks!:pray:

1 Like

You may want to check the logs: /var/log/lightdm Especially those of Xorg.

Normally utils and nvidia packages should replace those others. Let me see if I missed 455xx to replace with nvidia somehow …

Na, should be fine:

conflicts=("$_linuxprefix-nvidia-340xx" "$_linuxprefix-nvidia-390xx" "$_linuxprefix-nvidia-418xx"
           "$_linuxprefix-nvidia-430xx" "$_linuxprefix-nvidia-435xx" "$_linuxprefix-nvidia-440xx"
           "$_linuxprefix-nvidia-450xx" "$_linuxprefix-nvidia-455xx")
replaces=("$_linuxprefix-nvidia-418xx" "$_linuxprefix-nvidia-430xx" "$_linuxprefix-nvidia-435xx"
          "$_linuxprefix-nvidia-440xx" "$_linuxprefix-nvidia-450xx" "$_linuxprefix-nvidia-455xx")

You may want to remove them via sudo -Rdd linux419-nvidia-455xx linux54-nvidia-455xx nvidia-455xx-utils and install the nvidia ones: sudo -S linux419-nvidia linux54-nvidia nvidia-utils

If anyone got the same problem with shutdown delay (about 2min) on gnome, here is a workaround:

Add Slice=-.slice in /usr/lib/systemd/user/gnome-session-restart-dbus.service

ExecStart=/usr/lib/gnome-session-ctl --restart-dbus

See also:

root:~/ # cat /var/log/lightdm/lightdm.log.old
[+0.00s] DEBUG: Logging to /var/log/lightdm/lightdm.log
[+0.00s] DEBUG: Starting Light Display Manager 1.30.0, UID=0 PID=2560
[+0.00s] DEBUG: Loading configuration dirs from /usr/share/lightdm/lightdm.conf.d
[+0.00s] DEBUG: Loading configuration dirs from /usr/local/share/lightdm/lightdm.conf.d
[+0.00s] DEBUG: Loading configuration dirs from /etc/xdg/lightdm/lightdm.conf.d
[+0.00s] DEBUG: Loading configuration from /etc/lightdm/lightdm.conf
[+0.00s] DEBUG: Registered seat module local
[+0.00s] DEBUG: Registered seat module xremote
[+0.00s] DEBUG: Using D-Bus name org.freedesktop.DisplayManager
[+0.00s] DEBUG: _g_io_module_get_default: Found default implementation local (GLocalVfs) for ‘gio-vfs’
[+0.00s] DEBUG: Monitoring logind for seats
[+0.00s] DEBUG: New seat added from logind: seat0
[+0.00s] DEBUG: Seat seat0: Loading properties from config section Seat:*
[+0.00s] DEBUG: Seat seat0 has property CanMultiSession=no
[+0.00s] DEBUG: Seat seat0: Starting
[+0.00s] DEBUG: Seat seat0: Creating greeter session
[+0.00s] DEBUG: Seat seat0: Creating display server of type x
[+0.00s] DEBUG: Could not run plymouth --ping: Failed to execute child process “plymouth” (No such file or directory)
[+0.00s] DEBUG: Using VT 7
[+0.00s] DEBUG: Seat seat0: Starting local X display on VT 7
[+0.00s] DEBUG: XServer 0: Logging to /var/log/lightdm/x-0.log
[+0.00s] DEBUG: XServer 0: Writing X server authority to /run/lightdm/root/:0
[+0.00s] DEBUG: XServer 0: Launching X Server
[+0.00s] DEBUG: Launching process 2566: /usr/bin/X :0 -seat seat0 -auth /run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch
[+0.00s] DEBUG: XServer 0: Waiting for ready signal from X server :0
[+0.00s] DEBUG: Acquired bus name org.freedesktop.DisplayManager
[+0.00s] DEBUG: Registering seat with bus path /org/freedesktop/DisplayManager/Seat0
[+0.00s] DEBUG: Loading users from org.freedesktop.Accounts
[+0.00s] DEBUG: User /org/freedesktop/Accounts/User1000 added
[+0.26s] DEBUG: Process 2566 exited with return value 1
[+0.26s] DEBUG: XServer 0: X server stopped
[+0.26s] DEBUG: Releasing VT 7
[+0.26s] DEBUG: XServer 0: Removing X server authority /run/lightdm/root/:0
[+0.26s] DEBUG: Seat seat0: Display server stopped
[+0.26s] DEBUG: Seat seat0: Stopping session
[+0.26s] DEBUG: Seat seat0: Session stopped
[+0.26s] DEBUG: Seat seat0: Stopping display server, no sessions require it
[+0.26s] DEBUG: Seat seat0: Stopping; greeter display server failed to start
[+0.26s] DEBUG: Seat seat0: Stopping
[+0.26s] DEBUG: Seat seat0: Stopped
[+0.26s] DEBUG: Required seat has stopped
[+0.26s] DEBUG: Stopping display manager
[+0.26s] DEBUG: Display manager stopped
[+0.26s] DEBUG: Stopping daemon
[+0.26s] DEBUG: Exiting with return value 1

5.9 is EOL anyway. You can check the X.log to see what is going on there, or call it a day by removing that kernel …

have done this use 5.10 now, thank you very much @philm :+1:
It worked also on 5.4 without issues, but since I use newer Hardware for now I think its better to use the stable Kernel series
Hope to hear you at tux tage 2021 :smiley: :wink: or someone from the Manjaro team would be very cool :slight_smile:

This is how I do it: I recommend to install meld, then select both files (.pacnew and the actual one) in Dolphin, right click, administrator actions, open with, type meld, enter password. Then meld opens both files side by side, you can check what the difference is, edit if applicable and save the config file there after.

[2020-12-30T22:20:30+0100] [ALPM] warning: directory permissions differ on /root/
filesystem: 750  package: 755


exactly THAT I can’t, because the folder in question is /root, which I can only open with root privileges.

can be ignored, it makes no difference if you change the permissions to 755 the error will come again


terminator not working anymore, I had to download and install the Arch package (2.0.1-1 version).

Hi, I uninstalled the driver and then reinstalled it using the following commands:

sudo pacman -Rdd linux54-nvidia-455xx nvidia-455xx-utils
sudo pacman -S linux54-nvidia nvidia-utils

Everything worked too. :slight_smile:

But now there is a warning message in Manjaro-Settings-Manager about MHWDCONFIG. I initiated this as a test and that’s when I noticed it.
Do i have to change it for future updates? And if so, how? Or can i ignore the message?

That’s under “show details”:

Warning: config ‘/var/lib/mhwd/local/pci/video-nvidia-455xx/MHWDCONFIG’ is invalid!
Skipping already installed config ‘video-nvidia’ for device: 0000:01:00.0 (0300:10de:13c2) Display controller nVidia Corporation GM204 [GeForce GTX 970]

Thanks for the update. :slight_smile:
A couple of pacnew files (grub & systemd/homed.conf)


please run /usr/bin/cups-genppdupdate
No Gutenprint PPD files to update.

warning: directory permissions differ on /root/
filesystem: 750 package: 755

So all good.
Thanks again!

KDE Plasma, kernel 5.4.85. This update was a biggie for the last one in 2020! :astonished:

Smooth reboot on my side, and everything is running like a well-oiled wrist-watch.

Many thanks to all for for a job well done, and a Happy New Year 2021.

Stay safe! :v:

1 Like

The update just won’t work at all, all dependencies seems to not cohab together…

And Pamac broke itself real bad…

Everything fine, thank you for all this work.

Is it just me or is the system much faster with kernel 5.10 ?

The AMDGPU and Intel open source drivers are blacklisted by Blender. I can not do GPU rendering with either on Linux, but if I boot into Windows, both my AMD discreet card and my Intel iGPU show up to assist rendering in Blender.

Then there is CUDA, which a lot of frameworks use. I have not used it personally, but people do not seem like the OpenCL implementations.