[Stable Update] 2020-12-30 - Kernels, KDE, Cinnamon, LibreOffice, Python 3.9, Mesa 20.3.1

Everything is fine but i got lots of warning about Manjaro/kernel/sound/soc files

Managed to fix the warning message. Edited the grub config file /etc/default/grub and added rw to the following line so it now looks like this:

GRUB_CMDLINE_LINUX_DEFAULT=“quiet rw udev.log_priority=3”

Then ran the following line in the terminal:

sudo grub-mkconfig -o /boot/grub/grub.cfg

This fixed the warning message.

1 Like

Hmm, I’m getting the following error:

Failed to prepare transaction

could not satisfy dependencies:

  • removing mhwd-db breaks dependency ‘mhwd-db’ required by mhwd,
  • if possible, remove mhwd and retry

Edit: nevermind, worked ok after reboot.

Had literally the same problem. Try this here, it worked for me:

I guess it just became incompatible with the new grub version. :man_shrugging: I used it for years without problems, but in the end I don’t care how the GRUB screen looks like as long as it boots my favourite OS(es) :slight_smile: .

Installation went fine, on a reboot got a message to say install the latest kernel, so I installed 5.10.2-2 from the System Settings - Kernel dialogue. That all seemed to go fine, and so I rebooted, selected the advanced Grub options and selected the 5.10 kernel that I had just installed. However, the system hangs immediately thereafter. Anyone have any suggestions? Have I missed anything out or should I have done something differently?

Hi, usually I edit the taskbar size back and forth to have “unbehaving” icons re-adjust themselves.

This update was the biggest mess for me during all the years with Manjaro KDE. Spent 2 hours fixing it.

Update itself was fine, but after reboot I noticed ugly font and lots of wlan errors during startup, and WiFi (ASUS adapter with BCM4360 chipset) was not available. Multiple reboots and re-installation of Broadcom drivers didn’t help, so decided to switch from Kernel 5.4 to 5.10.

Couldn’t even boot to GUI on 5.10 because of TLP error - Stuck boot at "Finished TLP system startup/shutdown" new kernel Removing TLP didn’t help, still no GUI.

Back to kernel 5.4, noticed that Nvidia drivers (GeForce 1030) were marked as not installed after update (worked fine before). Trying to install them always resulted in error

nvidia-utils and nvidia-455xx-utils are in conflict

After multiple attempts I manually removed nvidia-455xx-utils and GUI instantly crashed. Reboot, no GUI again. Thankfully, I was able to re-install nvidia-utils via CLI. Right after that, GUI was live again, and drivers were marked as installed this time. Except this error:

Warning: config ‘/var/lib/mhwd/local/pci/video-nvidia-455xx/MHWDCONFIG’ is invalid!

As per @philm suggestion, removed MHWDCONFIG file and rebooted. Everything was fine, except no WiFi still. Re-installed kernel 5.10, rebooted into it, and - finally graphics and WiFI work fine (but only on 5.10, still no WiFi on 5.4).

The only remaining issue with both kernels is extremely big and blur font now - https://i.postimg.cc/NF6Ztb1b/4032-2268-max.jpg (screen size is “32”, and as you see, a short message uses alsmost all the screen space).

1 Like

I tried to change the size back and forth and it didn’t work, however setting the size to 47 instead of 45 restored the old icons size.
Thank you


Hello ! Since the update, I have a problem with my Grub menu (my computer is in dual-boot with Windows): a second Manjaro entry appeared, and I don’t know how to remove it (I checked /etc/grub.d/, I didn’t see anything unusual).

I also updated the kernel to 5.10, and since then, my computer takes a very long time to shut down.

Does anyone have an idea how to solve these problems?
PS: Happy new year !

Well, nvidia drivers have to be removed before installation, otherwise, system cannot run DE, though TTY works.

As posted in another thread before finding this one:

An excerpt from the bottom of my sudo pacman -Syu --debug output:

debug: started resolving dependencies
debug: checkdeps: package zfs-dkms-2.0.0-1
debug: checkdeps: missing dependency 'zfs-utils=2.0.0' for package 'zfs-dkms'
debug: checkdeps: missing dependency 'dkms' for package 'zfs-dkms'
debug: finished resolving dependencies
looking for conflicting packages...
debug: looking for conflicts
debug: check targets vs targets
debug: check targets vs targets
debug: package zfs-dkms conflicts with linux59-zfs (by zfs)
debug: conflicting packages in the sync list: 'zfs-dkms' <-> 'linux59-zfs'
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: zfs-dkms and linux59-zfs are in conflict

Any ideas? Should I try to upgrade zfs-utils first? Should I first upgrade to kernel 5.10?

Normally I’d try and navigate this myself but I am very reluctant to take extra risks on a home server. Advice is appreciated.

1 Like

That is how I understand it: If you comment it out the warring will go away and the systemd-fsck will not work. You can verify it by running:

systemctl status systemd-fsck-root.service

I am reading more on the subject and as it looks like it all goes to the “Systemd does it all” , I am trying out the systemd-fsck, so I left the grub line, removed the fsck from the HOOKS line in the /etc/mkinitcpio.conf and run:

sudo mkinitcpio -P && sudo update-grub

The systemd detected my filesystems, created services for them and runs the scan on boot.


As usual with my AMD based Toshiba netbook after upgrading to a newer kernel, 5.10 in this case, it hangs early in the boot process and I have to do a forced power-off. It will boot if I select an earlier kernel from the grub boot menu.

This has been the pattern since early 5.X kernels, I have to wait for three or four kernel updates before the system will boot with the newer kernel. I don’t know the cause of the problem or if there is any fix other than waiting for updates.

Other than that the system updates went smoothly and the netbook boots fine with the 5.9 kernel.

Nice update on Gnome with linux54.

Thanks for the tip for the problem with shutdown delay, it’s work.


No problem to update Manjaro. But since I switched to the “simplified” nvidia configuration, I have no more mouse cursor in wine applications.

*Solved : I just recreated the nvidia.conf in /etc/X11/mhwd.d

A scarily big upgrade, but almost 100% OK on my KDE system.

The only problem was due to the Python upgrade, which meant I needed to rebuild AUR packages that depend on Python, as ever when it’s upgraded.
I really must work out a method of automatically getting a list of these packages rather than having to look through my package manager.

I can’t update:

conflicting dependencies:
- conflict between catfish and zeitgeist
1 Like

For the python rebuild you can use rebuild detector (available in Manjaro repo)as suggested in the first post, after every update it will list the AUR packages that need rebuild in the pacman output.
You can also manually trigger it by running checkrebuild.

1 Like