[Stable Update] 2020-11-04 - Kernels, Nvidia 455.38, LibreOffice, Plasma5, Frameworks, Apps, Gnome 3.38, Deepin

Got this when using nmcli to bring up a VPN:
/usr/lib/nm-openvpn-auth-dialog: error while loading shared libraries: libnma.so.0: cannot open shared object file: No such file or directory

I Installed libnma to get rid of the message (and likely fix the VPN). I am not sure why it is only optional for networkmanager-openvpn.

1 Like

Hello Oliver,

where can I get an older version of pykeepass? Before Manjaro-Upate: python-pykeepass 3.2.0-1.

I’m new to Manjaro. Use Gnome-Passwordsafe often and don’t want to wait until the next update of Gnome-Passwordsafe. This is not user friendly.

Regards
Oliver from Germany

Desktop-Intel i7-8700 cpu , KDE Plasma Stable Edition , 2 screens , Linux 5.4 LTS kernel
updated with TTY = ctrl+alt+f2 = All good …

Nearly one year on this install no problems except for “problem between chair and keyboard occasionally over tweaking KDE”
Timeshift and Backintime my go to .
To all the manjaro team putting all this together and all those in the team doing the testing = Thank You

  • Appreciated

Thank you for your reply.
Downgrading using your command worked fine, but didn’t solve the issue for me. On startup the audio reverts to hdmi output. However, I can select the line out from the audio icon and for the rest of the day it will work through that output. Until next boot. So I updated the packages again, same result.
It seems it won’t create a profile for that audio output.

After upgrading my KDE desktop “still works”.

Fixing that mkinitcpio.conf.new was annoying, since my old config also had the “resume” and “keymap” hooks which required me a dig through the docs. While things could be made simpler when mkinitcpio migrated its config to the new layout with the ()-array annotation by itself IMHO.
Its interpreting its own config, so why not writing its own config?

After the upgrade, my default audio output (Line Out) gets automagically quieted (presumably by pulseaudio) per application. Any way to keep it to max volume?

Those which are the ones of KDE Plasma? Those are broken by ages.

Left alone the analog clock widget, I stopped using KDE’s default buildin widgets because I lost faith in that the KDE developers maintained them.

Well those are one of the main reasons i chose KDE :confused:
Which widget system do you use then?

I’m facing a problem with audio after this update, whenever I connect my earphone and if my laptop suspends for some time then automatically audio gets muted and I’m not able to hear any sound from laptop even after I reconnect my earphone. I don’t know it’s a bug or not but it freaks me out everytime. How to resolve it @philm???

Just KDE’s widget system.

But I’m using only KDE’s buildin analog clock widget. I removed the other monitoring widgets from my desktop.

“I have this problem too!”

After the upgrade, my default audio output (Line Out) gets automagically quieted (presumably by pulseaudio) per application. Any way to keep it to max volume?

Addition:
I fired up alsamixer -c 0 and turned “Auto-Mute Mode” to “Disabled”. Time will tell if it helps. Nope, didn’t help immediately. Maybe after a reboot which I won’t do now yet. Nope, didn’t work at all.

I suspect it is due the installation of alsa-card-profiles and the upgrade of alsa-utils (1.2.3-2 -> 1.2.4-2).

However the documentation is available about it is veeeeery scarce. At least I expect within its code repo a description of what value it adds, how to config it and the pitfalls when implementing it within a system.

1 Like

I think that is some problem with name apps. I solved it manually with dconf editor, replacing in /org/gnome/shell/favorite-apps, “pamac-manager.desktop” with “org.manjaro.pamac.manager.desktop”.

Actually this will lead to double pamac’s on every open. Just edit pamac-manager.desktop and change NoDisplay=true to false, and now you have one as before.

I am on Manjaro Gnome. The update went fine but after the update, several applications have keyboard lag. I.e. when I use gedit, evolution (writing plain text emails), etc some output keystrokes freeze until 1 second. It is very annoying writing text. Anothers applications like terminal, libreoffice have not problems.

I dont know how to find the cause. Any idea? Anyone with the same problem?

1 Like

just start in one terminal journalctl -f and look what’s the problem wile typing

I also ran into multiple pulseaudio issues,
I tried to downgrade but that wasn’t working.

Interestingly, I compared my /etc/pulse/default.pa to the new /etc/pulse/default.pa.pacnew and adjusted my default.pa to match the pacnew version and pulseaudio is now working for me.

It must have been invalid configs in my default.pa file.

I would suggest trying this if downgrading is not an option for anyone!

1 Like

Yeah downgrading definitely didn’t turn out to be a magic fix. Even after downgrading I still have to mess around with restarting pulseaudio for it to work, and for instance when starting JACK the pulseaudio-jack bridge just completely kills PA with the downgraded version. I think I only changed the default sampling rates in daemon.conf, so I’ll try to see if adding that to the updated version also fixes it for me, thanks!

EDIT: The new version of PulseAudio still fails to connect to my audio interface:

nov 12 16:43:51 desktop pulseaudio[30122]: Failed to load module "module-alsa-card" (argument: "device_id="3" name="usb-Focusrite_Scarlett_18i8_USB_10002F54-00" card_name="alsa_card.usb-Focusrite_Scarlett_18i8_USB_10002F54-00" namereg_fail=false tsched=yes fixed_latency_range=no ignore_dB=no deferred_volume=yes use_ucm=yes avoid_resampling=no card_properties="module-udev-detect.discovered=1""): initialization failed.
1 Like

I had this problem and it turned out to be the gtk3 theme i was using, Changing the GTK3 Theme to a newer theme worked for me, I no longer have keyboard lag on some apps.

But i am having very long shut down time, i would say 2 mins + with just a blank black screen with a white flashing cursor.

At Manjaro Forums, i’m not a new member but my old log-in would not work and send an email option did not work either, so had to make a new Log-in.

1 Like

Will there be stable ISOs on Friday?

Downgrade mesa to 20.1.8

1 Like

@oberon

tnx for today update to the latest version of freeoffice :ok_hand:

2 Likes