[Stable Update] 2020-11-04 - Kernels, Nvidia 455.38, LibreOffice, Plasma5, Frameworks, Apps, Gnome 3.38, Deepin

Hi, I’ve figured out, that problem was caused by “ fwupd ” Also it takes about 5 seconds at boot. So I uninstalled it, because it seems to me useless anyway.

1 Like

I think now Vivaldi browser may be pushed to Stable too, is giving no problems in Testing and Unstable

Installing xcursor-breeze via TTY also solved my problems from above:

2 Likes

Updated on Gnome and everything went fine. However, I have a minor issue with my Electron applications showing a light colored titlebar. Before the update my Electron apps matched my theme.


 ██████████████████  ████████     mick@laptop
 ██████████████████  ████████     OS: Manjaro 20.2 Nibia
 ██████████████████  ████████     Kernel: x86_64 Linux 5.9.3-1-MANJARO
 ██████████████████  ████████     Uptime: 23h 46m
 ████████            ████████     Packages: 1402
 ████████  ████████  ████████     Shell: bash 5.0.18
 ████████  ████████  ████████     Resolution: 1920x1080
 ████████  ████████  ████████     DE: GNOME 3.38.1
 ████████  ████████  ████████     WM: Mutter
 ████████  ████████  ████████     WM Theme: Matcha-dark-azul
 ████████  ████████  ████████     GTK Theme: Matcha-dark-azul [GTK2/3]
 ████████  ████████  ████████     Icon Theme: Papirus-Dark
 ████████  ████████  ████████     Font: Noto Sans 11
 ████████  ████████  ████████     Disk: 115G / 234G (52%)
                                  CPU: Intel Core i5-7200U @ 4x 3.1GHz [50.0°C]
                                  GPU: Intel Corporation HD Graphics 620 (rev 02)
                                  RAM: 4812MiB / 7870MiB
2 Likes

Looks like a theme issue. Can you reproduce it with Adwaita or Matcha? I can’t.

2 posts were merged into an existing topic: [Unstable Update] 2020-11-08 - KDE-git, Deepin, Firefox, Wine, Python, Haskell

Update:

  • Desktop gadget: Network speed is non functional.
    Network Speed
1 Like

On kernel 5.9.3 when I mount iso by gnome disk utility I see GDbus.Error:org.freedesktop.UDisk2.Error.Failed:Error waiting for loop object after creating 'dev/loop2: Timed out waiting for object (udisk-error-quark, 0) On kernel 5.4xx it works good.

1 Like

None of the suggestions for getting MPD to work have proved successful for me, so in case anyone else is in this situation, here’s a workaround.

  • Add MPD to the list of packages that shouldn’t be upgraded
  • Save the following files somewhere: /usr/lib/libupnp.so.6* /usr/lib/libixml.so.2* /usr/lib/libthreadutil.so.6*
  • Upgrade
  • Restore the saved files
    If you haven’t got any other packages dependent on libupnp and libixml, you might be safe marking those to be excluded from updates, though I wouldn’t like to say for certain; I have VLC dependent on them so that’s not a safe option for me.
1 Like

Got this when using nmcli to bring up a VPN:
/usr/lib/nm-openvpn-auth-dialog: error while loading shared libraries: libnma.so.0: cannot open shared object file: No such file or directory

I Installed libnma to get rid of the message (and likely fix the VPN). I am not sure why it is only optional for networkmanager-openvpn.

1 Like

Hello Oliver,

where can I get an older version of pykeepass? Before Manjaro-Upate: python-pykeepass 3.2.0-1.

I’m new to Manjaro. Use Gnome-Passwordsafe often and don’t want to wait until the next update of Gnome-Passwordsafe. This is not user friendly.

Regards
Oliver from Germany

Desktop-Intel i7-8700 cpu , KDE Plasma Stable Edition , 2 screens , Linux 5.4 LTS kernel
updated with TTY = ctrl+alt+f2 = All good …

Nearly one year on this install no problems except for “problem between chair and keyboard occasionally over tweaking KDE”
Timeshift and Backintime my go to .
To all the manjaro team putting all this together and all those in the team doing the testing = Thank You

  • Appreciated

Thank you for your reply.
Downgrading using your command worked fine, but didn’t solve the issue for me. On startup the audio reverts to hdmi output. However, I can select the line out from the audio icon and for the rest of the day it will work through that output. Until next boot. So I updated the packages again, same result.
It seems it won’t create a profile for that audio output.

After upgrading my KDE desktop “still works”.

Fixing that mkinitcpio.conf.new was annoying, since my old config also had the “resume” and “keymap” hooks which required me a dig through the docs. While things could be made simpler when mkinitcpio migrated its config to the new layout with the ()-array annotation by itself IMHO.
Its interpreting its own config, so why not writing its own config?

After the upgrade, my default audio output (Line Out) gets automagically quieted (presumably by pulseaudio) per application. Any way to keep it to max volume?

Those which are the ones of KDE Plasma? Those are broken by ages.

Left alone the analog clock widget, I stopped using KDE’s default buildin widgets because I lost faith in that the KDE developers maintained them.

Well those are one of the main reasons i chose KDE :confused:
Which widget system do you use then?

I’m facing a problem with audio after this update, whenever I connect my earphone and if my laptop suspends for some time then automatically audio gets muted and I’m not able to hear any sound from laptop even after I reconnect my earphone. I don’t know it’s a bug or not but it freaks me out everytime. How to resolve it @philm???

Just KDE’s widget system.

But I’m using only KDE’s buildin analog clock widget. I removed the other monitoring widgets from my desktop.

“I have this problem too!”

After the upgrade, my default audio output (Line Out) gets automagically quieted (presumably by pulseaudio) per application. Any way to keep it to max volume?

Addition:
I fired up alsamixer -c 0 and turned “Auto-Mute Mode” to “Disabled”. Time will tell if it helps. Nope, didn’t help immediately. Maybe after a reboot which I won’t do now yet. Nope, didn’t work at all.

I suspect it is due the installation of alsa-card-profiles and the upgrade of alsa-utils (1.2.3-2 -> 1.2.4-2).

However the documentation is available about it is veeeeery scarce. At least I expect within its code repo a description of what value it adds, how to config it and the pitfalls when implementing it within a system.

1 Like

I think that is some problem with name apps. I solved it manually with dconf editor, replacing in /org/gnome/shell/favorite-apps, “pamac-manager.desktop” with “org.manjaro.pamac.manager.desktop”.