[Stable Update] 2020-10-19 - Kernels, Nvidia 455, Browsers,

Oh, my bad I made a typo in my specs. 4790k obviously :slight_smile:

I’m suggesting (if possible) to ship also latest libreoffice-fresh package with stable branch (like what happens with Firefox) because even those minor updated versions brings some important fixes.
For now libreoffice-fresh package for stable branch is still on 7.0.1 but the official latest stable fresh version is 7.0.2 which brings a fix to font menu that was unusable in 7.0.1.

No package is tied to any particular branch. 7.0.2 of libreoffice-fresh is currently in testing and will move to stable when it has been tested. The following link allows you to see where any given software package is in the testing process on it’s way to stable. The only package updates that get “fast tracked” are important security related issues which is why you’ll frequently see browsers like firefox get fast tracked to stable as browsers tend to be one of the larger attack surfaces for security vulnerabilities.

This link let’s you see where packages are in the process (just type in the package in search to narrow the list down).
Manjaro - Branch Compare

This link explains how packages move through Manjaro’s development workflow and how a package ends up in “Stable” Branch.

1 Like

Added this to the wiki post…

4 Likes

I thought Libreoffice has its own testing cycle before being released to public. Thanks for the link I didn’t know Manjaro has it (I used to browser only Arch packages website).

It does, but each distribution that packages it needs to test that the packaging and installation works correctly.

1 Like

Is there anything that needs to be changed in Settings to activate besides running the command in the Terminal? I run Manjaro using KDE.

I thought my fonts were looking OK beforehand but I figured it is good to stay current when using a rolling release.

Hey guys,
I am still on kernel 5.8,
Since the update my wifi no longer connects on boot, I’ve had to enable/disable the WiFi or forget the network and connect to it again. Obviously it could be anything, not related to the update. I’ll try a few things and report back.

Since I updated my KDE takes several minutes just to reach the login screen and after I log in other programs such as Yukuake and Steam work fine but it takes a few minutes before the KDE interfaces start showing. Each time I reboot as well it does not keep my display settings and KDE starts on my secondary monitor and I have to set my main monitor as Primary again. Does anyone know the best way to approach this?
IN the past I had a similar issue and all I had to do was the two below commands to clear the KDE cache but that does not fix this issue. The below commands I ran previously were as below.
$ rm ~/.config/Trolltech.conf
$ kbuildsycoca5 --noincremental

So my question is how would I go about fixing this issue now, is my kernel and Nvidia drivers too out of date?
Kernel: 5.4.72-1-MANJARO x86_64
Nvidia 440

Looks like the new kernel update for 5.8 fixed my issues with it not reconginizng my keyboard and touchpad. That’s fantastic. Everything seems to be working fine so far. No signs of breakage. Great Job!

Nope, just reboot. Some DE’s offer this setting in their own “font config programs” (look for an option lcd filter) which write the config into the user folder. Those take precende over the system-wide settings… Can add that to the wiki later today.

1 Like

10-23 update

/usr/bin/grub-probe: warning: unknown device type nvme0n1.

It looks like this is an issue with GRUB updating memtest. Disabling the memtest line will get rid of the NVME warning.

That’s “normal”, many get that message including me. Nothing to worry about.

Redshift stopped working after this update, after a few restarts it started working again with no action on my part. Unknown if update related, I only mention it because it’s been working flawlessly for so long. In case anyone else has this happen restarting a few times might fix it.

“waiting for…” would load then it would just sit there. Internet was active, I was able to visit sites.

redshift -t 3333:2222 Trying location provider geoclue2’…
Using provider geoclue2'. Using method randr’.
Waiting for initial location to become available…`

linux 58 rocks yo. Anyone if you fee your computer running slightly hotter than windows, you should give 5.8 a try! It’s cooler than 5.4. That’s my observation! Thanks Manjaro!!!

2 Likes

Issues with Nvidia 450xx packages got solved a while ago. Sorry that I missed some packages to be uploaded.

Kernel 5.9.1 seems to be working fine here. Have you tried this one and if so, how does it compare?

I have Manjaro running on various hardware devices (Cinnamon) in the stable branch. I repeatedly read posts that criticize the delays in certain programs before they end up in the stable branch.

Experience has taught me that Manjaro is still up-to-date overall and one thing above all: stable.

Certain browsers take a little longer to upload and I think that with the good selection of up-to-date browsers it is then a few days wiser to use them until the favorite is updated.

I think the team and the community are doing an excellent job. From my point of view, enterprise quality for flexible companies (probably smaller ones).

6 Likes

I have to agree! I think Manjaro stable is a great balance between up to date software and stability. In my time running it, I have had zero update issues and zero issues with things not working. All I do is update the way the devs advise (TTY) and read the announcements first, it works. I also thank the team for their excellent work.

3 Likes

just for people getting the nvidia deps errors:

sudo pacman -R <pkgs-with-nvidia-deps> --nodeps --nodeps
sudo mhwd -r pci video-nvidia-<version-to-remove>
sudo mhwd -i pci video-nvidia-<version-to-install> 
sudo pacman -S <pkgs-with-nvidia-deps> 
sudo reboot

EDIT: to find pkgs-with-nvidia-deps:

sudo pacman -Qi nvidia-<version-to-remove>-utils | grep 'Required By' | cut -d ":" -f2