[Stable Update] 2020-10-19 - Kernels, Nvidia 455, Browsers,

That’s “normal”, many get that message including me. Nothing to worry about.

Redshift stopped working after this update, after a few restarts it started working again with no action on my part. Unknown if update related, I only mention it because it’s been working flawlessly for so long. In case anyone else has this happen restarting a few times might fix it.

“waiting for…” would load then it would just sit there. Internet was active, I was able to visit sites.

redshift -t 3333:2222 Trying location provider geoclue2’…
Using provider geoclue2'. Using method randr’.
Waiting for initial location to become available…`

linux 58 rocks yo. Anyone if you fee your computer running slightly hotter than windows, you should give 5.8 a try! It’s cooler than 5.4. That’s my observation! Thanks Manjaro!!!


Issues with Nvidia 450xx packages got solved a while ago. Sorry that I missed some packages to be uploaded.

Kernel 5.9.1 seems to be working fine here. Have you tried this one and if so, how does it compare?

I have Manjaro running on various hardware devices (Cinnamon) in the stable branch. I repeatedly read posts that criticize the delays in certain programs before they end up in the stable branch.

Experience has taught me that Manjaro is still up-to-date overall and one thing above all: stable.

Certain browsers take a little longer to upload and I think that with the good selection of up-to-date browsers it is then a few days wiser to use them until the favorite is updated.

I think the team and the community are doing an excellent job. From my point of view, enterprise quality for flexible companies (probably smaller ones).


I have to agree! I think Manjaro stable is a great balance between up to date software and stability. In my time running it, I have had zero update issues and zero issues with things not working. All I do is update the way the devs advise (TTY) and read the announcements first, it works. I also thank the team for their excellent work.


just for people getting the nvidia deps errors:

sudo pacman -R <pkgs-with-nvidia-deps> --nodeps --nodeps
sudo mhwd -r pci video-nvidia-<version-to-remove>
sudo mhwd -i pci video-nvidia-<version-to-install> 
sudo pacman -S <pkgs-with-nvidia-deps> 
sudo reboot

EDIT: to find pkgs-with-nvidia-deps:

sudo pacman -Qi nvidia-<version-to-remove>-utils | grep 'Required By' | cut -d ":" -f2

KDE Emoji select has square icons, before this update it was working perfectly. I have both noto-fonts and noto-fonts-emoji packages installed.


This has been in GRUB forever, and people report it every update. This is not a Manjaro update issue.

Hi, I just installed manjaro (gnome) mikah and I’m using 5.8 kernel.
I’ve Nvidia 9200MX GPU,
And the driver was set to video-hybrid-intel-nvidia-455xx-prime, so I switched it to video-nvidia-455xx.
Then after a system reboot, OS failed to boot. It was in bootloop state.
So, i disabled Dedicated Nvidia GPU from BIOS and it booted, then I removed 455xx and installed the hybrid version which was installed first.
Then I rebooted and enabled nvidia card from BIOS and it booted.
So, any compatability issue with 455xx driver and my nvidia 920mx?
Or, am i doing anything wrong?

Now it really works thanks :wink:

1 Like

Most likely regular Nvidia driver is not meant for your graphics card. Your laptop has two GPU’s, so it needs a proper driver to manage hybrid setups. The one you have already installed is the proper one.

A post was split to a new topic: Nvidia proprietary driver flickering screen

In addition to the font aliasing problem , I discovered, my laptop clock was 4 minutes late.

ntp was there, but I had to:

    sudo timedatectl set-ntp true

and to restart to get back to correct time.


I tried to fix it in KDE settings but it didn’t stick.
Thanks for the timedatectl tip.

Hey Guys,

Dumb question around kernels. As I’m switching to the 5.9.x kernel, what is the difference between the linux59-rt (real-time) and standard linux59? Either way, I ended up going with the standard linux-59 and installed the 5.9.3-1 kernel on my system.

Any help would be greatly appreciated. Thanks!

the *-rt kernels are real-time kernels.

I like this description of the real time kernel:
Realtime kernel patchset - ArchWiki?

In other words: you only need a real time kernel if a deterministic latency is important.
This doesn’t necessarily mean a low latency, but a latency which less jitter.