[Stable Update] 2020-10-01 - Kernels, Mesa, KDE-Framework, Deepin, Systemd, Pamac, Xorg-Server, Qt


is not a bug in the dhcpcd package?


after the update I still have the system without sound, and now when starting with the 5.8.11-1 kernel o after a few minutes the system freezes completely being forced to restart by the button

KDE Plasma Version: 5.19.5
KDE Frameworks Version: 5.74.0
Qt Version: 5.15.1
Kernel Version: 5.8.11-1-MANJARO

All good here, so far.
I don’t use any extra KDE Widgets - so I suspect that helps.

Ic þancie þē

The update worked very well in all areas: Gnome 3.36, Kernel 5.8.11-1.
Thank you and have a nice weekend.

1 Like

I am having the same problem with a black screen after login however in my case it was the Archlinux AUR plasma5-applets-plasma-pstate package plasma widget that was causing problems.

Interestingly I have this installed on 2 laptops, one with only an Intel GPU (integrated with the CPU) and another that is using optimus hybrid nvidia blob, i.e.

<~>-> mhwd -li
> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
video-hybrid-intel-nvidia-440xx-prime            2019.10.25               false            PCI
Warning: No installed USB configs!

If the package plasma5-applets-plasma-pstate is installed then I have the black screen after login problem. Seems like there is an issue with certain plasma widgets on the newest KDE release, reported upstream at plasma-pstate widget causing plasmashell to crash in latest manjaro stable · Issue #63 · jsalatas/plasma-pstate · GitHub.

Everything went well but i am receiving a few inotify_add_watch permission denied errors in my log after journalctl -b -p err..alert.
I notice that 40-max_user_watches.conf no longer exists but 50-max_user_watches.conf is set at 16384.

I’m wondering if the 16384 not being 524288 is the cause of the errors (i am a newb tho).
As far as i can tell it is only log spam :slight_smile:

5.8/440 KDE

At 4am local time, I updated my machines. I run KDE with three database servers running at all times. No problems. I started the download from Pamac, let Pamac deal with the download, made my coffee, walked the dog, rebooted, and all is fine.

Thank you to philm and crew!

Got that dhcpcd warning in Testing update [2020-09-10] and Stable update [2020-09-11].

Even if we set the permissions to 755, it will revert back to 700 after the next reboot. So it’s probably a bug as you mentioned.


Cinnamon 5.4, update went well as usual. Thanks again for a great OS and great maintenance.

Hi, I have KDE Plasma and I have problem with “smart” window placement. Now every window of e.g. Doplhin stacks over old window. And also it starts remember windows position, which I do not want. Do anyone know solution please?

Earlier I said I have no issues after the update, BUT I have just noticed that due to the update I have lost the Nvidia display port audio output so my display HAS NO sound or even volume slider (chanell) since the update… so I have audio now only on my headset but not on the display… :frowning: So this is what ROLLING type distro means in real life, now I can see in this forum, all the issues, random unexpected things happen. I am new to Linux and it was a good lesson about rolling vs LTE. I dont think I will can stand such 1-2 times every month. :frowning:
:face_with_symbols_over_mouth: :rage: :scream: :confounded: :astonished: :flushed: :broken_heart: :broken_heart:

Guys, if I switch to LTE kernel in Manjaro than I will not receive updates so frequently? How frequently I would receive updates on LTE and how likely they break something vs on this rolling? If you are on LTE Mannjaro than the updates you get are slower and widely, well tested? Maby I better reinstall the PC with LTE Manjaro or some #buntu is for me like Mint or Debian testing (stable does not install on my power PC with nvme and Nvidia RTX only on my older PCs)…?

See the volume panel in the screenshot, there was an NVIDIA HDMI or what slider there before the update and I had sound on my monitor but not anymore…

[x@x1 ~]$ inxi -Fxza 
  Kernel: 5.8.11-1-MANJARO x86_64 bits: 64 compiler: N/A 
  parameters: BOOT_IMAGE=/@/boot/vmlinuz-5.8-x86_64 
  root=UUID=cf4c01eb-7117-4d41-ba2a-6d4e44ba60a4 rw rootflags=subvol=@ quiet 
  apparmor=1 security=apparmor udev.log_priority=3 
  Desktop: KDE Plasma 5.19.5 tk: Qt 5.15.1 wm: kwin_x11 dm: SDDM 
  Distro: Manjaro Linux 
  Type: Desktop System: Gigabyte product: Z370M D3H v: N/A serial: <filter> 
  Mobo: Gigabyte model: Z370M D3H-CF v: x.x serial: <filter> 
  UEFI: American Megatrends v: F13 date: 08/13/2019 
  Topology: 6-Core model: Intel Core i7-8700K bits: 64 type: MT MCP arch: Kaby Lake 
  family: 6 model-id: 9E (158) stepping: A (10) microcode: D6 L2 cache: 12.0 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 88824 
  Speed: 800 MHz min/max: 800/4700 MHz Core speeds (MHz): 1: 800 2: 801 3: 800 
  4: 800 5: 800 6: 800 7: 800 8: 800 9: 800 10: 800 11: 800 12: 800 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, 
  STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort mitigation: Clear CPU buffers; SMT vulnerable 
  Device-1: NVIDIA TU106 [GeForce RTX 2070] vendor: Micro-Star MSI driver: nvidia 
  v: 450.66 alternate: nouveau,nvidia_drm bus ID: 01:00.0 chip ID: 10de:1f02 
  Display: x11 server: X.Org 1.20.9 compositor: kwin_x11 driver: nvidia 
  display ID: :0 screens: 1 
  Screen-1: 0 s-res: 3840x2160 s-dpi: 110 s-size: 887x494mm (34.9x19.4") 
  s-diag: 1015mm (40") 
  Monitor-1: DP-2 res: 3840x2160 hz: 60 dpi: 111 size: 878x485mm (34.6x19.1") 
  diag: 1003mm (39.5") 
  OpenGL: renderer: GeForce RTX 2070/PCIe/SSE2 v: 4.6.0 NVIDIA 450.66 
  direct render: Yes 
  Device-1: Intel 200 Series PCH HD Audio vendor: Gigabyte driver: snd_hda_intel 
  v: kernel bus ID: 00:1f.3 chip ID: 8086:a2f0 
  Device-2: NVIDIA TU106 High Definition Audio vendor: Micro-Star MSI 
  driver: snd_hda_intel v: kernel bus ID: 01:00.1 chip ID: 10de:10f9 
  Device-3: Microsoft LifeCam Cinema type: USB driver: snd-usb-audio bus ID: 1-1:2 
  chip ID: 045e:075d 
  Sound Server: ALSA v: k5.8.11-1-MANJARO 
  Device-1: Intel Ethernet I219-V vendor: Gigabyte driver: e1000e v: 3.2.6-k 
  port: f000 bus ID: 00:1f.6 chip ID: 8086:15b8 
  IF: eno1 state: up speed: 100 Mbps duplex: full mac: <filter> 
  Local Storage: total: 1.14 TiB used: 39.71 GiB (3.4%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/nvme0n1 vendor: Samsung model: MZVPW256HEGL-000H1 size: 238.47 GiB 
  block size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 
  serial: <filter> rev: CXZ73H0Q scheme: GPT 
  ID-2: /dev/sda vendor: Western Digital model: WD10EFRX-68FYTN0 size: 931.51 GiB 
  block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s rotation: 5400 rpm 
  serial: <filter> rev: 0A82 scheme: GPT 
  ID-1: / raw size: 237.97 GiB size: 237.97 GiB (100.00%) used: 24.12 GiB (10.1%) 
  fs: btrfs dev: /dev/nvme0n1p2 
  ID-2: /home raw size: 237.97 GiB size: 237.97 GiB (100.00%) 
  used: 24.12 GiB (10.1%) fs: btrfs dev: /dev/nvme0n1p2 
  Alert: No Swap data was found. 
  System Temperatures: cpu: 27.8 C mobo: 16.8 C gpu: nvidia temp: 32 C 
  Fan Speeds (RPM): N/A gpu: nvidia fan: 46% 
  Processes: 337 Uptime: 1h 15m Memory: 15.58 GiB used: 2.57 GiB (16.5%) 
  Init: systemd v: 246 Compilers: gcc: 10.2.0 Packages: 1212 pacman: 1203 lib: 321 
  flatpak: 9 Shell: Bash v: 5.0.18 running in: yakuake inxi: 3.1.05 


Since I updated this PC yesterday night I didnt make any changes, it was mainly off. Now when I booted up and noticed this audio issue and left this post, so after that I rebooted and now the audio issue is just gone, the HDMI output slider is back! Just so, randomly! But at the same time I feel like the PC automatically or randomly or so returned to some earlier state…? Becaue I had like 5+ open tabs in Firedox before reboot but after reboot it opened with just 2 tabs an ddifferent ones than I had open before reboot…

What the heck is going on on this PC…? It is like I have zero control on it.

1 Like

To get Plasma to stop remembering window placements by default:

Edit the file: ~⁄.config⁄kdeglobals

Under the [General] heading, add the following line:


Save. I think you’ll have to logout for it to take effect.


LTS only relates to the kernel updates.
The branches (testing/stable etc) relate to the software updates and generally stable releases every week or two (maybe slower if major updates are coming).
The beauty of rolling distros over things like ubuntu is that bug fixes also happen quicker.
I’d suggest opening a thread with any major issues you have (that are not shown in the update threads) as there are a lot of wise users here.

Glad the slider is back.
I cant explain the tabs though firefox did just get a version update from 80 to 81…

1 Like

Did you reboot between your system update and your first issue post?

Yes I did. I ran the update yesterday night and it went smoothly, than first thing I did reboot straight after the install has finished (to make sure all fine). Than used the PC night time here to talk on forum and than did shut it down normally. Booted in the morning for 20mi use and did shut it down again normally. And here we are after my today evening boot I noticed this audio issue. I have not used Timeshift after or until the update.

Everything seems fine after upgrade, but I’ve noticed following:

  UNIT             LOAD   ACTIVE SUB    DESCRIPTION             
● user@120.service loaded failed failed User Manager for UID 120

Any ideas?

How do I revert back? It’s breaking some applications for me, to be specific optimus-manager-qt. PLease help!

I have the same issue (have had it for a few months now but I haven’t found the exact cause yet. What I have found is that if I manually restart the service after my system is up is starts up just fine. I didn’t get any response last time I posted about it though here on the forums and google went all kinds of directions with it that none led me to an actual solution more just people asking about it.

sytemctl start user@120.service

will start it up without any issues for me but why it is failing initially I have no idea.
I’ve found that it is a special service and it sounds like it might be important but everything has worked fine with it failing for months now.


Searches for my specific error in the log only came up with this from a couple years ago and had no solution.

1 Like

Thx! This solution works! But I think, that this must be some bug, because before it works fine.

1 Like