[Stable Update] 2020-10-01 - Kernels, Mesa, KDE-Framework, Deepin, Systemd, Pamac, Xorg-Server, Qt

Many thanks for the suggestion deleting eventcalendar from the plasmoids subdirectory worked for me too along with not using the arc-ICONS icon set which also caused plasmashell not to load

1 Like

After the update Kde plasmashell crashing
tried deleting the plasma and plasmashell folder but did not help.
I get these error in plasmashell :

Hello, thank you for continuous updating the system. The update it selves ran smooth without any error. BUT the system is very slow in execution - especially running virtualbox feels like on a i386 in former days… :wink:
Any suggestions for speeding up the machine to the level of Wednesday?
Thanks again. Keep up the brilliant system!

Just finished updating my production machine here. Using KDE Plasma on Manjaro Mikah 20.1 with linux58 kernel. Same issue; plasmashell crashed upon reboot after updating. Followed the suggestion to remove eventcalendar and did systemctl reboot. Voila, plasmashell is working back as it should be. Loosing the Event Calendar is a bit of a bummer though. I used it quite frequently. I sure hope it’ll get fixed verily soon.

Still unable to scan or print using Canon all-in-one printer, regardless of series. And sometimes unable to print using HP Laserjets too. But, it’s not a big issue for the time being. Still had hopes though, that more printers and scanners will work with Manjaro straight out of the box, regardless of make.

Other than that, everything else seems to be working normal as usual. Thanks for the hard work @philm and team.

1 Like

Upgraded successfully :slight_smile:

If anyone stumbles across upgrade errors with already existing python modules, in my case python-dateutil, just remove the old version from the system installation with sudo pip uninstall python-dateutil.

If you don’t have any problems, you don’t have to run any of those commands. They really are only fixes for those particular issues and not something to run anyway after an update. In fact, running commands from fixes for problems you don’t have, could cause problems. Just a heads up :grinning:


That did it! Thanks!

@philm I edited the announcement post to better reflect the context of these commands. It’s better than let them there hanging with no explanation.


So… I guess no USB 3.0 for now then? Unless I downgrade kernels.

Thanks. This works. Although it feels more like a workaround than a solution. I still have some visual glitches in other programmes, such as Firefox. Peculiar bug… what was the cause?

Updated my laptop with kernel 5.8, Ryzen 2700U, Vega graphics and KDE Plasma.

No issues to report so far.

1 Like

As its developer informs, you can use eventcalendar v.69 from AUR packages. It works.

1 Like

On it. Thanks heaps.

1 Like


Uh… But I did run that one chown command after the update… I had zero issues but I interpreted that fix as in this particular case it’s a preventive measure too to avoid future security issues.

Love it :heart:

You need to try first, it’s possible that it’s working (USB 3). Users also recommend installing extra packages from AUR Renesas uPD720201 / uPD720202 USB 3.0 chipsets firmware (it was this one, but I’m not sure). Or wait if it’s not an issue for you, fix should be here soon :slight_smile:

No worries! :grinning: Since you mentioned being fairly new to Linux/Manjaro, I thought I’d give you a heads up about not needing to run any of the fixes from the wiki-post as long as you’re not experiencing the corresponding problem or if the update post explicitly instructs you to manually run some commands.

Did you also see the warning about the permissions when updating? In my experience, and although I have been running Linux for a long time I am not an expert, if your system is running fine, you generally don’t need to change any file/directory permissions… unless you experience a problem. I usually trust the permissions set on my system while installing it, unless there is a particular reason to change it.

You can check the permissions on a file or directory by running stat -c %a /path/to/file

My /var/lib/dhcpcd directory has permissions set to 700. Setting it to 750 or 755 is pretty much granting everyone all rights to that file/directory. I doubt that is really necessary, but someone more knowledgable will surely be able comment on that. My system is running fine with those more strict permissions. YMMV.


Thanks for the details, good to know for the future! When I get home I’ll try to revert this permission change to the original because I had no any error during update.

my system

stat -c %a /var/lib/dhcpcd/

after applying the solution and rebooted again I get

stat -c %a /var/lib/dhcpcd/

Yeah… I always find this a weird warning. Why does that package have 755 as the default permissions for /root?

1 Like