[Stable Update] 2020-10-01 - Kernels, Mesa, KDE-Framework, Deepin, Systemd, Pamac, Xorg-Server, Qt

Went just fine on KDE (intel/nvidia desktop) and XFCE (dell laptop)

Hi all,
What do I do with this?

mhwd --install pci Your450Family

where `Your450Family` is obviously one of `video-hybrid-amd-nvidia-440xx-prime` **OR** `video-nvidia-440xx` that you noted above

just how do I know what “family” I have?
By the way, none of the utils are on my system…is that normal?

[melissa@Avalon ~]$ pacman -Q nvidia-450xx-utils
error: package 'nvidia-450xx-utils' was not found
[melissa@Avalon ~]$ pacman -Q nvidia-440xx-utils
error: package 'nvidia-440xx-utils' was not found


Great, have a shovel handy? I may need to dig her up. :frowning_face:
I asked how to do it the Linux way…without having to consult a medium…but thanks anyway…


mhwd -l will give you available configs for your system.

1 Like

Thank ou so much :smile_cat:
:rose: Melissa :rose:

1 Like

Does me sorry, I knew that not…
I do not want to dig my parents up, too

(Corectrl is a handy tool btw…)

1 Like

Thanks :slight_smile:
There was no way you had to know. Was just a…“weird” answer :wink:

Metoo (I am a old white male german leftist)

Has mbb solved your question?? corectrl is similar to cpu-x - but give more details of your system,
its a graphical tool, most puritans like inxi on the command-line…

Same here, xfce, autologin stopped working since the last update. Did you manage to fix it?

I followed all the steps here from the archlinux wiki (I am not allowed to post links) but to no avail.
I even did a fresh install in a Virtual Machine and compared /etc/lightdm/lightdm.conf and /etc/pam.d/lightdm between the VM installation and my installation and they were exactly the same.

Any tipps here?

Big Problems with nvidia 450.
See here in german: Nvidia 450 Treiber installieren

hi, try to put in /etc/lightdm/lightdm.conf:


with this you avoid at least typing the password. It is the best I could find without being able to completely solve the autologin…

1 Like

A post was split to a new topic: Shortwave 1:1.1.1-6 does not build

Just got to this today. I’m in the US and a little distracted by where the clowncar might be headed today, tomorrow, November 3rd…

Openbox Community Ed upgrades without any problems. I only noticed that this is still happening:

[2020-10-18T01:22:22-0700] [ALPM] upgraded manjaro-release (20.1-1 -> 20.1.1-1)
[2020-10-18T01:22:22-0700] [ALPM] warning: directory permissions differ on /root/
filesystem: 750  package: 755

But I’m just gonna stay with 750.

Hi. I’m newly registered to this forum. Using manjaro from thee or four years now, had managed to setup ‘external user datas’ so upgrade are easy and reinstall also thank to link from home to data disk.
I regularly reinstall from scratch with no issue, especially when rounded stable versions are out, or when system need to fresh up following numerous software install for testing .

That’s what i just done from stable version 20.0 and I experience big trouble : impossible to proceed complete upgrade from first connection : packman displays several errors concerning its own uptade. Then if reboot : kernel can’t be found.

So I tried to download this new stable install, but USB boot creator has been removed from default install package. I am thus now blocked with no solution in a vicious circle… No update from packman and no software install possible.

Why can’t one choose to stay with given stable version, and install ‘old’ versions software from repository?

The whole point of a rolling-release distro such as Manjaro is to always be up-to-date. There is no need to reinstall in order to get the latest version of everything, since you are always at the latest version, granted you regularly update your system.

Regarding the broken pacman update, it is likely due to the change in packaging format since 20.0 was released – we’re at 20.1.1 now. See the notice in the announcement:

1 Like

Thanks for your reply.
Indeed I know what is the purpose of a rolling release, that is the theory…

Thus, in reality, sometimes (mainly every year after summer vacations), manjaro, and linux in a more extend, encounter some turbulence due to new protocols, formats and experiences, and maybe due to less assiduity from developers and users… In that cases, added to a personnal tendency to add much more softwares that i need on my machine, creating sometimes overload of dependencies or unbalanced settings, i like to reset all the three parallel systems installed (one main and two backup in case of crash, which sometimes happen, but not so much last months).

I hope you understand that being not connected to a permanent internet connection, i’d like to get some data friendly setup, especially if i have to experiment unknown functionnality.

You can try two things

  1. Keep /home on a separate partition/drive so that you data is safe even if things go south.
  2. Use BTRFS file system with auto-snapshot so you can easily switch to a snapshot before update if updates break something.
1 Like

Then, honestly I fear that Manjaro may not be the right choice. A better one may be a system with a stable base (for KDE Users Neon comes into my mind, as also Neon user I would say while Neon is more data friendly than Manjaro, exactly data friendly it is still not). I guess CentOS will provide data friendly computing very much.

The baseline is: if you like to experiment, this will not be data friendly and if you like it data friendly you will not get the latest hot new stuff.

A rolling release must be kept rolling. With KDE Neon you could skip an update from time to time (and then bork it up when you upgrade the base system …). My 2 ct.

1 Like

got some updates just before, anyone else?

[2020-10-19T19:23:34+0200] [ALPM] transaction completed
[2020-10-19T19:23:34+0200] [ALPM] running '30-systemd-update.hook'...
[2020-10-19T19:23:34+0200] [PACMAN] starting full system upgrade
[2020-10-19T19:33:11+0200] [ALPM] running '60-mkinitcpio-remove.hook'...
[2020-10-19T19:33:11+0200] [ALPM] transaction started
[2020-10-19T19:33:11+0200] [ALPM] upgraded firefox (81.0-2 -> 81.0.2-1)
[2020-10-19T19:33:11+0200] [ALPM] upgraded firefox-i18n-it (81.0-1 -> 81.0.2-1)
[2020-10-19T19:33:12+0200] [ALPM] upgraded linux-firmware (20200923.r1716.afbfb5f-1 -> 20201005.r1732.58d41d0-1)
[2020-10-19T19:33:13+0200] [ALPM] upgraded linux54 (5.4.67-1 -> 5.4.72-1)
[2020-10-19T19:33:14+0200] [ALPM] upgraded linux58 (5.8.11-1 -> 5.8.16-2)
[2020-10-19T19:33:14+0200] [ALPM] upgraded manjaro-release (20.1.1-1 -> 20.1.2-1)
[2020-10-19T19:33:14+0200] [ALPM] upgraded mhwd-nvidia-450xx (450.66-1 -> 450.80.02-1)
[2020-10-19T19:33:14+0200] [ALPM] installed mhwd-nvidia-455xx (455.28-2)
[2020-10-19T19:33:14+0200] [ALPM] upgraded mhwd-db (0.6.4-12 -> 0.6.5-4)
[2020-10-19T19:33:14+0200] [ALPM] upgraded octopi (0.9.0-24 -> 0.10.0-1)
[2020-10-19T19:33:14+0200] [ALPM] upgraded octopi-notifier-qt5 (0.9.0-24 -> 0.10.0-1)
[2020-10-19T19:33:14+0200] [ALPM] upgraded palemoon-bin (28.13.0-1 -> 28.14.2-1)
[2020-10-19T19:33:14+0200] [ALPM] transaction completed

octopi works as expected

1 Like