[Stable Update] 2020-08-28 - Kernels, Systemd, PAM, PAMBASE, KDE-git, Deepin, Pamac, Nvidia 450.66, LibreOffice 7.0

Any idea when we’re going to see Cura 4.7?

It was released four days ago. (I know, I’m being as impatient as a kid on Christmas morning ^___^ )

No issues on my end

The system became so unstable that continued operation become impossible so I could not test, I braced for recovering the system and restarted but it came up and everything seems to be working fine! To be sure I reinstalled systemd, pam and pambase in order for them to be able to do whatever things they were not able to do during install.

Disabling error reporting isn’t a fix. It’s just blindfolding yourself.

It’s an arch package and not even available in arch yet but flagged out of date: Arch Linux - cura 4.6.2-1 (any)

Got a problem where libreoffice calc kept crashing, squashing all previous settings made it work again.

mv ~/.config/libreoffice ~/.config/libreoffice_bak

Hello! i have found a small bug in Manjaro KDE. After booting Manjaro KDE and logging in ( i tried it in the live session), Search doesn’t work either in Application Menu, or Application Dashboard or Application Launcher. If i attempt to type somethig in Search field, sddm crashes for five seconds. This issue is caused by Firefox. I spent 2 hours trying, retrying and rebooting system many times, to find out the origin of this bug. I tried it with other applications (opening and closing), the problem still persists. Search still doesn’t work in Plasma menus. When i opened Firefox for the first time, Search in Plasma Menus got unblocked.

The PAM update got me. I had to put the system-login.pacnew file in place to be able to log in.

Same thing with Writer. Maybe it has something to do with User Interface layout, my was set Tabbed Compact.

I have the same issue. While updating, the progress was really slow for a good while. I heard the HD working, but no progress was made. After the update, no network, but network works as normal on the Windows 10 install.

I tried the same things as you, minus the kernel reversions.
Going through the devices, I found that my RealTek Ethernet’s driver had been uninstalled. I connected my phone with USB and shared it’s internet connection. Worked fine. Installed the driver.

After I removed the phone, I got limited connectivity on the wired and I could ping my router, but not further. I don’t exactly remember what I did next, I think I restarted the networking service IIRC and then I still couldn’t get any page to load on my browser, but I noticed I could succesfully ping my ISP’s DNS servers. After pinging them I got full network. Today, when I logged back in the network didn’t work again.

I’ll try to get it to work again in a while, and I’ll document what I do more carefully.

Minor issue due to new kernel, trackpad froze on resume from suspend.
Easily fixed by issuing:

sudo modprobe -r psmouse && sudo modprobe -a psmouse

Not sure the -a is necessary but works anyway. Will report back if this fix doesn’t hold this time.

ETA: KDE Plasma on Lenovo T440.

This update kills my installation - after the update (wether I do it via TTY or GUI) my screens go into standbye after the boot splash. I tried to login via ctrl+alt+F3 username password startx, but without success. I checked the login-method and chaged from auto to manual login, but without success. Only solution is to recover from backup and try again. I used a live-USB to chroot into the system, but neither the journalctl nor the xserver show any signs for the reason of the issue. Any ideas?

Right, so here we go again: scary update.
Do I use diffuse to merge pacnew? What is comming at me? What do I do to restore the system if it breaks?
Lucky I have backups. But do I need to reinstall the system now?
What do I do if I cannot log in anymore?
Edit - the wiki posts (or…something) mention downgrading pam…would that work? What if I blacklist pam?

That’s what I’m on about…I need this system, my PC is not a toy. I can accept that there has to be more than a click of the mouse to update. But I need to have a recovery plan before I update…


Can you list the steps? It would really help me, thanks :slight_smile:

Please read this:


You’d better open your own thread for that as this thread is focused on the stable update…



after updating, before rebooting do a:

DIFFPROG=nano pacdiff

(or vim, … whatever) and post the output. 84% chance you don’t need to do anything, 11% chance you’ll have to do something simple, 5% chance not so simple…



I had the same issue! I had to manually edit the libreoffice config files to get it back.

Sure. Unfortunately I hadn’t read the post closely as I mentioned so when I rebooted I couldn’t log in, either via the login manager or from a TTY like Ctrl+Alt+F4. Luckily I dual boot another copy of Manjaro so I was able to just boot into that environment and change the files from the broken one. If you already updated and can’t log in I assume you’ll have to boot from a USB live image and use chroot. I saw that there was a system-login.pacnew file in /etc/pam.d so I compared it with the previous system-login to see what changed. I then made a backup of the existing system-login file and copied the pacnew file to just system-login. After rebooting I was able to log in. Hope that helps!