[Stable Update] 2020-08-28 - Kernels, Systemd, PAM, PAMBASE, KDE-git, Deepin, Pamac, Nvidia 450.66, LibreOffice 7.0

Smooth update, just had to do the mirrors thing with pacman before because it wasn’t showing with -Syyu. No big deal. Thanks Manjaro Team :smile:

Ditto what astinus said.

All good, but lua was orphaned. Removing it

[2020-08-28T07:25:52-0400] [PACMAN] Running 'pacman -Rsn lua'

caused no issues for me.

1 Like

Upgrading with the GUI give a lot of failures, so proceeded with the terminal. After successful upgrade I updated grub and no kernels were listed. I reinstalled kernels and grub update showed installed kernels. Hopefully this will work, I will reboot when I finished my work :crossed_fingers: .

Thanks @Manjaro team

1 Like

Some days ago i builded a custom kernel, 5.8.4-7, from tkg-git. With the latest update i noticed Manjaro dowloaded 5.8.3 from official repo by itself. Why it does that?

Because you had Manjaro’s kernel installed before. Remove all.

Hi all!

First of all thank you manjaro team for all your hard work and effort!
The new Nvidia 450 driver solved some issues I had in the past. For example:

  1. No more freezes (during startup or shutdown process)
  2. No more messages like:
sd-unmount[xxxx]: Failed to unmount /oldroot: Device or Resource busy
sd-unmount[xxxx]: Failed to unmount /oldroot/sys: Device or Resource busy

But after the latest stable update I experience an issue with cuda and cudnn. (I have install both, cuda and cudnn from manjaro repos…)
Specifically, I cannot run cuda with cudnn anymore. This was also an issue with the previous stable update, but I was hopping the new one would have fixed it.

For example when i run lc0 (a chess program that uses Neural Networks for its evaluation function) I get the following (cuda) error.

> ...
> go nodes 100
> Found pb network file: ./256x20-t40-1541.pb.gz
> Creating backend [cudnn-auto]...
> Switching to [cudnn]...
> CUDA Runtime version: 11.0.0
> Cudnn version: 8.0.2
> Latest version of CUDA supported by the driver: 11.0.0
> GPU: GeForce GTX 960M
> GPU memory: 3.95123 Gb
> GPU clock frequency: 1176 MHz
> GPU compute capability: 5.0
> error CUDA error: no kernel image is available for execution on the device (../../src/neural/cuda/winograd_helper.inc:363)

which is strange because cuda seems to be loaded ok

$nvcc --version
nvcc: NVIDIA (R) Cuda compiler driver
Copyright (c) 2005-2020 NVIDIA Corporation
Built on Thu_Jun_11_22:26:38_PDT_2020
Cuda compilation tools, release 11.0, V11.0.194
Build cuda_11.0_bu.TC445_37.28540450_0


Fri Aug 28 15:09:08 2020       
| NVIDIA-SMI 450.66       Driver Version: 450.66       CUDA Version: 11.0     |
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|                               |                      |               MIG M. |
|   0  GeForce GTX 960M    Off  | 00000000:01:00.0 Off |                  N/A |
| N/A   45C    P8    N/A /  N/A |      4MiB /  4046MiB |      0%      Default |
|                               |                      |                  N/A |
| Processes:                                                                  |
|  GPU   GI   CI        PID   Type   Process name                  GPU Memory |
|        ID   ID                                                   Usage      |
|    0   N/A  N/A       788      G   /usr/lib/Xorg                       3MiB |

Any Ideas, please ?

@vasmakk why would nvidia driver have something to do with unmounting? Would you mean the update in general fixed that issue?

I wanted to hold off on updating since around the 22nd because I had some problems with the update. Trying with this latest release, hope all is good. Will check back if there is an issue.

edit: @vasmakk cuda I think I’ve read before has not been transitioned to the new 450 driver. Maybe that’s what you’re asking about.


At first I thought it was a combination of nvidia driver and systemd. I have two laptops. One of them is an Optimus with nvidia. The other one has Intel HD integrated graphics. Both run the same stable Manjaro and have similar specs. But only the Optimus one (nvidia) had unmounting problems and freezes during startup or shutdown.

By the way… Thank you for the cuda info. I didn’t know. I guess this is the problem

I didn’t get any pacnew files in /etc/pam.d/ folder; however the only reference to pam_cracklib.so is present inside /etc/pam.d/passwd.
Should I remove the reference of pam_cracklib.so from this file?

KDE Menu at the lower left corner becomes very big in 200%, in Windows 200% is not so big.

Make KDE Greater!

I had also, but line is commented (line start by “#”), so is ignored by manjaro


I don’t feel safe to remove all official kernels, I need just one as a failsafe. :smile:
Maybe I should set to ignore linux 58 updates in pacman.conf?

Thanks to @bogdancovaciu’s recommendation to install rEFInd, I’ve had smooth sailing with this update.


Just don’t install the linux58 package and you won’t get it

(I finally installed 5.8 manually today as it jumped above 5.8.0)


Apart from OpenVPN up script, update-resolv-conf failing, it went fine.
Will open separate topic for that.

– Ok, now able to edit:


Well then I don’t see a problem with ‘failsafe’ updating. Better to have latest ‘failsafe’. :stuck_out_tongue:

No problem here. :wink:

Despite of my last update was on 13th June.
I updated grub too, to fix Boot-Hole issue.

I’m confused. As it’s written in the “Known issues”-section I’d assume that I’d need to keep an eye on or take special care about something. However, they way I read it it’s a completely normal requirement to merge the pacnew-files generated by the update into the existing ones. So what’s the difference here compared to, e.g. a newly written /etc/pacman.conf.pacnew?

sudo nvidia-modprobe