[Stable Update] 2020-08-28 - Kernels, Systemd, PAM, PAMBASE, KDE-git, Deepin, Pamac, Nvidia 450.66, LibreOffice 7.0

I had troubles with binutils package, specifically

error: binutils: la firma de «Bartlomiej Piotrowski b@bpiotrowski.pl» no es válida

to solve it i remove gcc package, but i need it…

  1. No more freezes (during startup or shutdown process)
  2. No more messages like:

both still there, didn’t notice anything new in 450 and my list of Nvidia issues includes:

  1. emptied Settings and Firefox windows on resume and then dropped framerate in Firefox
  2. blank screen on login
  3. slow and stuttering Kwin compositor
  4. total freeze in wayland session
  5. random total freeze Nvidia Xid 61
  6. boot messages "No irq handler for vector"
  7. nvidia hdmi errors: "snd_hda_intel 0000:07:00.1: spurious response 0x0:0x0"
  8. difficult sensors and error "nvidia-gpu 0000:07:00.3: i2c timeout error e0000000"
  9. qt spam: "qt.qpa.xcb: QXcbConnection: XCB error: 9"
  10. qt spam: "QML Connections: Implicitly defined onFoo properties in Connections are deprecated."

Maybe a tip I had from a “lil ol’ lady”…( :thinking: I dont know if she’s really that old, though)
after the update, open the console and try to log in. If that works, you’re int he clear, if you cant log in, you need to talk to Pam :wink:

1 Like

Welcome @boris_perez to the forum.
Did you manage to reinstall gcc afterwards?

Thanks @ButterflyMelissa for your welcome message!!! And, answering to your question: yes, i retry to install gcc again, but i still having the same problem with binutils

I got none of the messages 1 - 10 you reported here, with the newer or the previous 440 driver.
But if the unmount messages exist with the new 450 driver it might due to some leftover configuration from the previous driver. Have you checked with mhwd? (Or with the GUI version of mhwd) It happened to me. mhwd was showing both 440 and 450 intel-hybrid-nvidia. When I removed the 440 and rebooted, the messages were gone!

Maybe you need to update your package signing keys:

sudo pacman -Sy archlinux-keyring manjaro-keyring
sudo pacman-key --populate archlinux manjaro
sudo pacman-key --refresh-keys
sudo pacman -Syu

If it doesn’t work, please follow this thread from the old forum:

Some months ago, I myself solved a similar problem.
I hope this help you.

1 Like

Any console feedback you can grab-n-post? It would help us figure this out…


Hi folks @gan and @ButterflyMelissa, thanks for your answers… @gan, i try to do what you indicate to me, but it fails in the step of refresh-keys… i suspect that’s because i’m behind a proxy , i try to configure pacman to honor-http-proxy like here (i cant add links to the post) but nothing…

I can’t let you here the console feedback…i have a message from system that says i cannot upload media files to the forum
Any idea…i think the trouble still in the refresh-keys behind proxy…could you help me with that??? Thanks

I installed Manjaro 19.0.2 gnome…updated it…now it is version 20.1, which is not released yet!!

Heyyyy!!! Ready, its solved…thanks…i dont know what i did…but its solved

@gan Thanks again… do you wanna say me something else???

Hi everybody…recently i tried to add some images and links in my posts here but the system says i can not…any idea why?? Thanks by the way

is for all , links and images permission starts at level TL2 (member) - topics exist on forum on this subject

1 Like

Please post terminal output with preformatted text formatting, not images.

1 Like

Ahhh!!! Ok, thanks… :rofl:


Sorry, i didnt research about it, my bad… Thanks

Simply, I replied to you after you edited your previous post. So my reply didn’t need anymore.
And… if, in the future, you want to post terminal output, you can copy it from the terminal with CTRL+SHIFT + C

As @papajoke did, I have launched before the update:

grep -E "pam_tally|pam_cracklib" /etc/pam.d/*
/etc/pam.d/lightdm-autologin:auth        required    pam_tally.so file=/var/log/faillog onerr=succeed
/etc/pam.d/passwd:#password	required	pam_cracklib.so difok=2 minlen=8 dcredit=2 ocredit=2 retry=3
/etc/pam.d/system-login:auth       required   pam_tally2.so        onerr=succeed file=/var/log/tallylog
/etc/pam.d/system-login:account    required   pam_tally2.so

and before the update, I have uncommented them:

grep -E "pam_tally|pam_cracklib" /etc/pam.d/*
/etc/pam.d/lightdm-autologin:#auth        required    pam_tally.so file=/var/log/faillog onerr=succeed
/etc/pam.d/passwd:#password	required	pam_cracklib.so difok=2 minlen=8 dcredit=2 ocredit=2 retry=3
/etc/pam.d/system-login:#auth       required   pam_tally2.so        onerr=succeed file=/var/log/tallylog
/etc/pam.d/system-login:#account    required   pam_tally2.so

The update has been now made in TTY2 and reading:

I am wondering if I should only reimplace “pam_tally2.so [and pam_tally.so] by pam_faillock.so” or reimplace the whole new lines namely:

  1. in /etc/pam.d/lightdm-autologin, should I reimplace the whole line of the .pacnew file, which is the following:
auth        required    pam_faillock.so preauth

instead of this line in my actual file actual

#auth        required    pam_tally.so file=/var/log/faillog onerr=succeed

or should I keep merge them into one of these potential new lines?

auth        required    pam_faillock.so preauth file=/var/log/faillog onerr=succeed
auth        required    pam_faillock.so file=/var/log/faillog onerr=succeed
  1. in /etc/pam.d/system-login, I would uncomment the following lines and reimplace, as @papajoke wrot,e pam_tally2.so by pam_faillock.so:
#auth       required   pam_tally2.so        onerr=succeed file=/var/log/tallylog
#account    required   pam_tally2.so 
  1. in this same file, namely /etc/pam.d/system-login, I would add user_readenv=1 present in the .pacnew file to the line of my actual system-login file:
session    required   pam_env.so

Could someone please confirm me that I am right on these 3 different points?
Thanks a lot for this update and for the help!

1 Like