[Stable Update] 2020-08-22 - Kernels, Deepin, KDE-git, Firefox, Pamac, Nvidia 450, KDE Apps 20.08

Apparmor fails to start after the update. Dont currently have time to troubleshoot it, and had to perform a rollback for now.

When you do, please make sure to create a topic with your findings in this category:
https://forum.manjaro.org/c/support/snap-flatpak/115
Thank you!

Everything fine on GNOME. Thanks

The firejail version shipped with this update breaks apparmor. Fixed in version 0.9.62.4.

3 Likes

Not actually using any flatpacks that im aware of. Post it in this forum regardless?
(It will be next week before i have time to address this. Weekends packed already.)

/edit: nvm, just saw mangiaro’s post. Guess we gotta wait for the update to arrive in the repo.

PCSX2 from official repo and aur don’t launch. Any ideas?

Thx, the update went well.
I don’t have linux-latest installed hence I cloud also update the nvidia-drivers with the GUI tool.
But it deleted my custom 90-mhwd.conf which I created via this guide.
There is now a new nvidia.conf file in /etc/X11/mhwd.d/ which is softlinked to /etc/X11/xorg.conf.d/90-mhwd.conf.
I put my old 90-mhwd.conf from backup as the new /etc/X11/mhwd.d/nvidia.conf and softlinked it to /etc/X11/xorg.conf.d/90-mhwd.conf.
Everything works now :smiley:

Also this

==> If you run into trouble with CUDA not being available, run nvidia-modprobe first.

Indeed. This is unfortunate as the issue was already highlighted by @anon88624618 in the testing update but was not picked in time for the stable update…

The Chinese Characters are too large on the settings menu
[Files(F)] [Edit(E)] [View(V)] [Settings(S)] [Help(H)]
Especially on VS Code.(I mean that they are too large relative to the height of the settings bar. It cannot be solved by fixing DPI)

PS: Manjaro Forum Crashed Just Now

Is this still 20.1rc4?

Using kernel 5.8 make some games lagging with Wine/Proton. Maybe it’s related to this :thinking:
Meanwhile, i stay with 5.7.15

The update went without any problem on ASUS ROG integrated intel/nvidia GPU laptop.
But the issue of sound is still looming. The speakers and bluetooth headset are working, but the 3.5 jack headsets are not working on the gnome. If anyone else knows the fix, pls do share. I have tried killing pulseaudio and setting alsa-base.conf modprobe files.

inxi -Axza
Audio:
Device-1: Intel CM238 HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel
bus ID: 00:1f.3 chip ID: 8086:a171
Sound Server: ALSA v: k5.8.1-3-MANJARO
inxi -F | rg snd
Device-1: Intel CM238 HD Audio driver: snd_hda_intel

apologies if it looks like im hijacking the post. I think many other fellow asus rog users are having similar problems with the sound. :slightly_smiling_face:

New problem since this update. With my Dual Shock 3 I have this error :

[10247.850493] usb usb4-port1: Cannot enable. Maybe the USB cable is bad?

It worked fine before. For safety I tested with another cable, and I still have the same issue.

Update : The problem is not exactly the controller but the USB 3.0 hub. The error disables the controller though. Anyway this hub always worked before the update…

Still having problems building dkms modules for network interfaces:
Seems there is a struct sha256 defined twice in the dkms / rtl source codes. for Kernel 5.8.x

/var/lib/dkms/rtl8821ce/1.0.5.r95.g69765eb/build/make.log

DKMS make.log for rtl8821ce-1.0.5.r95.g69765eb for kernel 5.8.1-3-MANJARO (x86_64) Sa 22. Aug 18:24:22 CEST 2020 make ARCH=x86_64 CROSS_COMPILE= -C /lib/modules/5.8.1-3-MANJARO/build M=/var/lib/dkms/rtl8821ce/1.0.5.r95.g69765eb/build modules make[1]: Verzeichnis „/usr/lib/modules/5.8.1-3-MANJARO/build“ wird betreten CC [M] /var/lib/dkms/rtl8821ce/1.0.5.r95.g69765eb/build/core/rtw_security.o CC [M] /var/lib/dkms/rtl8821ce/1.0.5.r95.g69765eb/build/core/rtw_cmd.o CC [M] /var/lib/dkms/rtl8821ce/1.0.5.r95.g69765eb/build/core/rtw_io.o CC [M] /var/lib/dkms/rtl8821ce/1.0.5.r95.g69765eb/build/core/rtw_debug.o CC [M] /var/lib/dkms/rtl8821ce/1.0.5.r95.g69765eb/build/core/rtw_mlme.o CC [M] /var/lib/dkms/rtl8821ce/1.0.5.r95.g69765eb/build/core/rtw_ioctl_set.o CC [M] /var/lib/dkms/rtl8821ce/1.0.5.r95.g69765eb/build/core/rtw_ioctl_query.o CC [M] /var/lib/dkms/rtl8821ce/1.0.5.r95.g69765eb/build/core/rtw_ieee80211.o In Datei, eingebunden von /var/lib/dkms/rtl8821ce/1.0.5.r95.g69765eb/build/include/drv_types.h:79, von /var/lib/dkms/rtl8821ce/1.0.5.r95.g69765eb/build/core/rtw_security.c:17: /var/lib/dkms/rtl8821ce/1.0.5.r95.g69765eb/build/include/rtw_security.h:252:8: Fehler: Redefinition von »struct sha256_state« 252 | struct sha256_state { | ^~~~~~~~~~~~ In Datei, eingebunden von ./include/linux/filter.h:23, von ./include/net/sock.h:59, von ./include/linux/tcp.h:19, von ./include/linux/ipv6.h:88, von ./include/net/addrconf.h:50, von /var/lib/dkms/rtl8821ce/1.0.5.r95.g69765eb/build/include/osdep_service_linux.h:48, von /var/lib/dkms/rtl8821ce/1.0.5.r95.g69765eb/build/include/osdep_service.h:50, von /var/lib/dkms/rtl8821ce/1.0.5.r95.g69765eb/build/include/drv_types.h:27, von /var/lib/dkms/rtl8821ce/1.0.5.r95.g69765eb/build/core/rtw_security.c:17: ./include/crypto/sha.h:84:8: Anmerkung: ursprünglich hier definiert 84 | struct sha256_state { | ^~~~~~~~~~~~ In Datei, eingebunden von /var/lib/dkms/rtl8821ce/1.0.5.r95.g69765eb/build/include/drv_types.h:79, von /var/lib/dkms/rtl8821ce/1.0.5.r95.g69765eb/build/core/rtw_io.c:47: /var/lib/dkms/rtl8821ce/1.0.5.r95.g69765eb/build/include/rtw_security.h:252:8: Fehler: Redefinition von »struct sha256_state«

KDE Plasma kernel 5.4.58.

Update & reboot smooth on my end. I’m using an Intel HD-630 integrated graphics card so no problems with NVIDIA drivers… :slightly_smiling_face:

Already my second update!

On reboot, I lost my (wired) connection. New reboot, no change. I tried to change my kernel, without effect. I put back the 5.8 and then, miracle, I recovered my connection. More fear than harm, finally (I hope so, at least).

1 Like

Cuando se bloquea la sesión de usuario por inactividad luego de intentar ingresar el sistema no reconoce la clave del usuario, que puedo hacer en este caso ?

A post was merged into an existing topic: Toolbox icon colors and identification

ksystemlog is compiled against systemd 246 series. We didn’t update to that series yet. Let us see how far our tests went and if we can update systemd. Issue is only minimal.

Are the bluetooth issues fixed in this version of the 5.8 kernel? TIA.

A post was split to a new topic: Boot issues on an iMac 12,2