[Stable Update] 2020-08-22 - Kernels, Deepin, KDE-git, Firefox, Pamac, Nvidia 450, KDE Apps 20.08

Still having problems building dkms modules for network interfaces:
Seems there is a struct sha256 defined twice in the dkms / rtl source codes. for Kernel 5.8.x


DKMS make.log for rtl8821ce-1.0.5.r95.g69765eb for kernel 5.8.1-3-MANJARO (x86_64) Sa 22. Aug 18:24:22 CEST 2020 make ARCH=x86_64 CROSS_COMPILE= -C /lib/modules/5.8.1-3-MANJARO/build M=/var/lib/dkms/rtl8821ce/1.0.5.r95.g69765eb/build modules make[1]: Verzeichnis „/usr/lib/modules/5.8.1-3-MANJARO/build“ wird betreten CC [M] /var/lib/dkms/rtl8821ce/1.0.5.r95.g69765eb/build/core/rtw_security.o CC [M] /var/lib/dkms/rtl8821ce/1.0.5.r95.g69765eb/build/core/rtw_cmd.o CC [M] /var/lib/dkms/rtl8821ce/1.0.5.r95.g69765eb/build/core/rtw_io.o CC [M] /var/lib/dkms/rtl8821ce/1.0.5.r95.g69765eb/build/core/rtw_debug.o CC [M] /var/lib/dkms/rtl8821ce/1.0.5.r95.g69765eb/build/core/rtw_mlme.o CC [M] /var/lib/dkms/rtl8821ce/1.0.5.r95.g69765eb/build/core/rtw_ioctl_set.o CC [M] /var/lib/dkms/rtl8821ce/1.0.5.r95.g69765eb/build/core/rtw_ioctl_query.o CC [M] /var/lib/dkms/rtl8821ce/1.0.5.r95.g69765eb/build/core/rtw_ieee80211.o In Datei, eingebunden von /var/lib/dkms/rtl8821ce/1.0.5.r95.g69765eb/build/include/drv_types.h:79, von /var/lib/dkms/rtl8821ce/1.0.5.r95.g69765eb/build/core/rtw_security.c:17: /var/lib/dkms/rtl8821ce/1.0.5.r95.g69765eb/build/include/rtw_security.h:252:8: Fehler: Redefinition von »struct sha256_state« 252 | struct sha256_state { | ^~~~~~~~~~~~ In Datei, eingebunden von ./include/linux/filter.h:23, von ./include/net/sock.h:59, von ./include/linux/tcp.h:19, von ./include/linux/ipv6.h:88, von ./include/net/addrconf.h:50, von /var/lib/dkms/rtl8821ce/1.0.5.r95.g69765eb/build/include/osdep_service_linux.h:48, von /var/lib/dkms/rtl8821ce/1.0.5.r95.g69765eb/build/include/osdep_service.h:50, von /var/lib/dkms/rtl8821ce/1.0.5.r95.g69765eb/build/include/drv_types.h:27, von /var/lib/dkms/rtl8821ce/1.0.5.r95.g69765eb/build/core/rtw_security.c:17: ./include/crypto/sha.h:84:8: Anmerkung: ursprünglich hier definiert 84 | struct sha256_state { | ^~~~~~~~~~~~ In Datei, eingebunden von /var/lib/dkms/rtl8821ce/1.0.5.r95.g69765eb/build/include/drv_types.h:79, von /var/lib/dkms/rtl8821ce/1.0.5.r95.g69765eb/build/core/rtw_io.c:47: /var/lib/dkms/rtl8821ce/1.0.5.r95.g69765eb/build/include/rtw_security.h:252:8: Fehler: Redefinition von »struct sha256_state«

KDE Plasma kernel 5.4.58.

Update & reboot smooth on my end. I’m using an Intel HD-630 integrated graphics card so no problems with NVIDIA drivers… :slightly_smiling_face:

Already my second update!

On reboot, I lost my (wired) connection. New reboot, no change. I tried to change my kernel, without effect. I put back the 5.8 and then, miracle, I recovered my connection. More fear than harm, finally (I hope so, at least).

1 Like

Cuando se bloquea la sesión de usuario por inactividad luego de intentar ingresar el sistema no reconoce la clave del usuario, que puedo hacer en este caso ?

A post was merged into an existing topic: Toolbox icon colors and identification

ksystemlog is compiled against systemd 246 series. We didn’t update to that series yet. Let us see how far our tests went and if we can update systemd. Issue is only minimal.

Are the bluetooth issues fixed in this version of the 5.8 kernel? TIA.

A post was split to a new topic: Boot issues on an iMac 12,2

Thanks! I tried everything and this is the only way you can remove the 440xx (or even the 450xx) drivers.

I did try again and you could actually install the hybrid graphics once you install first video-modesetting, both via tty but the problem was even it says that it’s removing the 440xx or 450xx drivers, it really wasn’t and it was throwing a script error like some here. So yes, you need to manually remove the old drivers first via pacman or pamac. Weird behavior.

Does anyone know why GnuCash 4.1 has been left out of the last 2 stable updates? It was released on 7/26, almost a month ago, and was just a bug-fix release in the new 4.x series. Seems like it would be an easy send through.

Is there somewhere I can check to see status / get answers on package questions like this?

Same issue for me as reported here Sound from speakers no sound from 3.5mm jack-audio

inxi -Axza

  Device-1: Intel Cannon Lake PCH cAVS vendor: ASUSTeK driver: snd_hda_intel 
  v: kernel alternate: snd_soc_skl,snd_sof_pci bus ID: 00:1f.3 
  chip ID: 8086:a348 
  Sound Server: ALSA v: k5.8.1-3-MANJARO

inxi -F | rg snd


Device-1: Intel Cannon Lake PCH cAVS driver: snd_hda_intel


as i attempt to run this update it is prompting me to install mhwd-nvidia-450xx. i run a AMD system and have amdgpu running. i recently moved to AMDGPU…is mhwd-nvidia part of the default install and im just now noticing? i usually skim through what gets updated and have never seen this before… thoughts?

havent ran update yet…want to get this answered first

1 Like

Updating went smooth.

Faced some minor issues when upgrading to nvidia 450xx drivers

  • Un-installation of nvidia 440xx driver was not straightforward as it required removal of package ‘linux-latest-nvidia-440xx’ using pacman
  • After uninstall (of 440), the installation of 450xx was success but it was not loaded on reboot so had to reinstall 450xx driver & then added below config to /etc/X11/mhwd.d/nvidia.conf
    Option "RegistryDwords" "EnableBrightnessControl=1"
    Rebooted again & it worked

I had no issues during the update although it did pull in an additional Nvidia driver. This is odd because I don’t have an Nvidia GPU. I’m on a Syster76 Darter Pro, which has integrated graphics only.

Still having the problem described here:

i got the same…i use AMDGPU

Because Arch just updated it to 4.1 today. It’s now in the Manjaro unstable repo and will be in the next stable update.

After the update 2020-08-22 I cannot play Urban Terror anymore. When I start the game (should start in full screen) only a black window opens with sound of game and whole desktop freezes. Then I must kill the game from console and when return back to desktop my resolution is changed (becomes much smaller) and consequently all opened windows are resized with parts off the screen. The issue is present on kernels 4.19 and 5.8 and I use XFCE DE with Nvidia-430xx-bumblebee GPU driver. I have never had before an issue with Urban Terror on Manjaro. I haven’t tested much other things after the update. SM Player and Firefox seem to work fine.

I had little issues with nvidia 450.x drivers, but there is the solution.
I want to install new nvidia 450xx, but i can't remove 440x-prime drivers

Cinnamon 5.4 update went smooth, all is good. Thanks Manjaro team for yet another smooth update.