[Stable Update] 2020-08-16 - Kernels, Plasma, KDE Framework, Systemd, Pamac, VirtualBox, Firefox

Smooth & OK.

One question : why wasn’t the grub update procedure scripted ?

1 Like

A post was split to a new topic: Kernel 5.8.0-2 my system seems to be only running at it’s minimum clock of 800mhz

yes. 5.7 is now the only option in the grub menu, there are no other kernels installed. I would have tested the new kernel before removing the old one but I didn’t see any option for that and now since I can’t boot I can’t do anything.

No conky anymore after the upgrade in KDE . Changed a few kernels, always the same. I will check later what causes the issue.

Didn’t get updates for a while. Couldn’t get any now too.

sudo pacman -Syu

shows nothing to update. system up to date.

Edit: Updating mirrors fixed it.

A post was merged into an existing topic: MEGAsync QT segmentation fault

Updated (KDE) in TTY (using Topgrade).

Only one problem - old conky scripts wouldn’t work, fixed them and made a thread how to update old conky scripts.

Nice job :wink:


System does not boot…Get the following error message on boot up

error: file '/boot/vmlinuz not found

I have an encrypted drive and lvm.

@uniquename There were changes made. This could be the cause…


MEGAsync probably just needs a rebuild/reinstall (it isn’t one of our apps) and Conky maybe failed due to the new LUA update - so find my thread and update your scripts :wink:


I booted from an installer usb stick, did manjaro-chroot into my encrypted root and used pacman to install linux54. I then did grub-update.

Now things are worse and I don’t even get the grub menu when I boot. Grub asks for my password, says “slot 0 unlocked” and then goes straight to black screen rather than menu.

Broke my system for the moment, see (Newbie) Can't boot after today's update

For those who really need the new nvidia driver: you can switch to unstable branch, update your drivers and go back to the stable branch at your own risk, according to this wiki entry.

All good on the Lenovo T420s with Linux 5.7.x and i3wm.

Big thanks to the Manjaro Team.

P.S. New forum looks neat

All good for me. Laptop with linux54+xfs+xfce+intel UHD620

linux58 is good as well.

CoreCtrl refuse to work after todays update.

corectrl: error while loading shared libraries: libbotan-2.so.13: cannot open shared object file: No such file or directory

EDIT3: Just reinstall CoreCtrl from AUR. It fixes the error for me.
No more issues for me. :slight_smile:

Conky is also not working. But I don’t know yet if it’s due to my config (which hasn’t changed) or something due to conky itself.

conky: [string “…”]:159: attempt to call a nil value (global ‘loadstring’)

EDIT: conky is now working again, thanks to @nikgnomic

Everything else seems fine.

Updated and getting stuck on “load/save rf kill switch status.” Tried booting from the 20.1-rc4 live usb and just getting a black screen. This is on a mid-2014 MBP, no issues before update. Tried booting from 5.8 as well as 5.7 kernel, same result.

Conky-lua-nv is completely broken. It first said that conky didn’t exist. I tried uninstalling it and reinstalling, and now it refuses to install unless I install a rt kernel.
I could use the AUR version but for some reason it uses 15% of my CPU all the time so it’s a no go…

Green With Envy tray icon still bugged (like pacman) on KDE. emoji selector still broken.
Everything else works fine so far.

no problems on XFCE

update replaced riot-desktop + riot-web with element-desktop + element-web
all working as before with new name

and replaced non-session-manager with new-session-manager

old conky configuration files are probably not supported any more
see this page in wiki for how to convert conky.conf to new syntax
Configurations · brndnmtthws/conky Wiki · GitHub

conky/convert.lua at master · brndnmtthws/conky · GitHub