[Stable Update] 2020-08-16 - Kernels, Plasma, KDE Framework, Systemd, Pamac, VirtualBox, Firefox

Sound not working after update to Linux kernel 5.7.14+/5.8.0+

Laptop updated and switched to latest kernel without a hitch - forum won’t let me edit my original post - this is weird.

cant get into login page on startup, after fresh install with 5.8 kernel. tty is working. i supose something wrong with gdm and nvidia drivers. using gnome btw.

Did you downgrade all of these? 6.1.10-1

no i did not. i just wanted to try fresh install with new kernel. 5.7 kernel also not working for me, on old instalation got 5.6 but its already eol. wanted to have newer kernel.

Good call. I did the upgrade a few days ago, but just realized this morning that MEGAsync wasn’t running. I just rebuilt it with yay -S megasync (choosing clean build), and it works now. :partying_face:

EDIT: Added quote from @Ben.

Tried that. It fails with error:
alsactl: get_control:256: Cannot read control '3,0,0,Playback Channel Map,0': Invalid argument and no file is generated.

Updated smoothly via TTY.

Update removed my fallback kernel 56 and claimed to replace it with the same one that I was currently running 5.7.14, in reality i think it just removed 56.

Thanks for the update. <3

after full update, the kernel was changed, from 5.6 to 5.7. after that de not started, i was able to get into tty when enter startx command, and all de apears working. but i think until next reboot, how to fix this issue?

My audio is malfunctioning, a simple restart fixes the issue, but it keeps returning.
OS: Manjaro 20.1 Mikah
██████████████████ ████████ Kernel: x86_64 Linux 5.7.14-1-MANJARO
██████████████████ ████████ Uptime: 43m
████████ ████████ Packages: 1452
████████ ████████ ████████ Shell: bash 5.0.18
████████ ████████ ████████ Resolution: 1920x1080
████████ ████████ ████████ DE: KDE 5.73.0 / Plasma 5.19.4
████████ ████████ ████████ WM: KWin
████████ ████████ ████████ GTK Theme: Breath [GTK2/3]
████████ ████████ ████████ Icon Theme: Reversal
████████ ████████ ████████ Disk: 94G / 228G (44%)
████████ ████████ ████████ CPU: Intel Core i7-8565U @ 8x 4.6GHz [54.0°C]
████████ ████████ ████████ GPU: Mesa Intel® UHD Graphics 620 (WHL GT2)

these are my audio drivers:
Audio: Device-1: Intel Cannon Point-LP High Definition Audio driver: snd_hda_intel
Sound Server: ALSA v: k5.7.14-1-MANJARO

PipeWire caused some trouble for me: [Vfio] VM isn't booting anymore since updates on Sunday

Is PipeWire necessary to have?

the whell line can be disabled (#)
we have in this file @includedir /etc/sudoers.d/ read this directory

I have, and there is only one file named “ctdb” in sudoers.d with this content

  • Defaults!/etc/ctdb/statd-callout !requiretty
  • rpcuser ALL=(ALL) NOPASSWD: /etc/ctdb/statd-callout

I can’t disable the wheel line in sudoers.conf

@CyberOto @cbDejaVu @koji54 Thanks for all the tips.

I’m using kernel 5.4. After to-ing and fro-ing with various downgrades, I ultimately reverted to virtualbox version 6.1.12 and then downloaded the corresponding Oracle extensions and ran:

sudo vboxmanage extpack install --replace /usr/share/virtualbox/extensions/Oracle_VM_VirtualBox_Extension_Pack-6.1.12.vbox-extpack

Note that trying to install the extension pack using the virtualbox GUI doesn’t work because it tries to use VBoxExtPackHelperApp which has apparently been replaced with vboxmanage.

I had to re-start a couple of my guests, but otherwise it all seems to work fine now.

1 Like

Yes, you always have to download the extension pack from through Oracle. Glad you got it to work.

@philm - After this update, there have been two reports about webcam not working — this and this.

Can you please tell us which components (drivers or software) of this update might be related to this issue? I can try reverting these components. Or any other suggestion…

Thanks again for making this a brilliant OS!

I also got the same error on Kernel 5.7.14-1

And found the workaround for now on here ASUS X421IA - ArchWiki

1 Like

I just had the same issue. Reading the Fedora post, they mention it being caused by unplugging a mixer which is exactly what caused it in my case.

My problem was that apparently, the graphics driver for my UHD 620 graphics chip stopped working (although video-linux was installed …). That resulted in high CPU usage of kwin_x11 on everything I did to a window in KDE and, worst of all, the wobbly window effect was gone :open_mouth:
The solution was to update my kernel from 4.14 to 5.4.

Please see the new Stable announcements and use those to report any issues with the update.