[Stable Update] 2018-11-25 - Kernels, Firefox-KDE, Nvidia, Pamac

update
stable

#1

Hi community,

Welcome to another stable update. So what do we have with this one?

  • Most of our Kernels got updated. This also reverts the changes made for STIBP
  • Linux418 is now marked as EOL. Please move to Linux419 kernel series
  • We updated Firefox-KDE to 63.0.3
  • Nvidia driver got updated to 410.78
  • Pamac got updated to 7.3.1

We hope with all these changes Manjaro to be more efficient for you all.


The Iconic Spitfire: Now Quad-Core!

jpg%3Alarge

Visit StationX now!


Manjaro v18.0.1 RC1 released!

If you are curious about the latest Manjaro-Illyria 18.0.1 release, you now have the opportunity to download XFCE Edition with the latest 4.13 packages, aswell as our most recent styling efforts. Our KDE fans may try our KDE Edition with the latest KDE v5.14 instead. And our GNOME fans may try our Gnome Edition with the latest GNOME v3.30.


Current supported Kernels

  • linux316 3.16.61
  • linux318 3.18.126 [EOL]
  • linux44 4.4.164
  • linux49 4.9.140
  • linux414 4.14.83
  • linux417 4.17.19 [EOL]
  • linux418 4.18.20 [EOL]
  • linux419 4.19.4
  • linux414-rt 4.14.78_rt47
  • linux416-rt 4.16.18_rt11
  • linux418-rt 4.18.16_rt9

Sync Package Updates (Tue Nov 13 07:29:01 CET 2018)

  • stable community x86_64: 4 new and 4 removed package(s)
  • stable core x86_64: 15 new and 15 removed package(s)
  • stable extra x86_64: 90 new and 90 removed package(s)
  • stable multilib x86_64: 2 new and 2 removed package(s)
:: Different overlay package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE               stable              testing
-------------------------------------------------------------------------------
                firefox-kde-opensuse             63.0.1-2             63.0.3-1
                  linux414-rt-nvidia           1:410.73-2           1:410.78-1
                  linux416-rt-nvidia           1:410.73-1           1:410.78-1
                  linux418-rt-nvidia           1:410.73-2           1:410.78-1


:: Different overlay package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE               stable              testing
-------------------------------------------------------------------------------
                            linux316            3.16.59-1            3.16.61-1
                    linux316-headers            3.16.59-1            3.16.61-1
                            linux318           3.18.125-1           3.18.126-1
                    linux318-headers           3.18.125-1           3.18.126-1
                            linux414            4.14.81-1            4.14.83-1
                    linux414-headers            4.14.81-1            4.14.83-1
                            linux418            4.18.19-1            4.18.20-1
                    linux418-headers            4.18.19-1            4.18.20-1
                            linux419             4.19.2-1             4.19.4-1
                    linux419-headers             4.19.2-1             4.19.4-1
                             linux44            4.4.163-1            4.4.164-1
                     linux44-headers            4.4.163-1            4.4.164-1
                             linux49            4.9.137-1            4.9.140-1
                     linux49-headers            4.9.137-1            4.9.140-1
                         mhwd-nvidia           1:410.73-1           1:410.78-1


:: Different overlay package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE               stable              testing
-------------------------------------------------------------------------------
                  linux316-acpi_call             1.1.0-46             1.1.0-47
                   linux316-bbswitch               0.8-45               0.8-46
                linux316-broadcom-wl      6.30.223.271-25      6.30.223.271-26
                   linux316-catalyst     1:15.201.1151-34     1:15.201.1151-35
                linux316-ndiswrapper              1.61-25              1.61-26
                     linux316-nvidia           1:410.73-1           1:410.78-2
               linux316-nvidia-340xx            340.107-4            340.107-5
               linux316-nvidia-390xx             390.87-3             390.87-4
                   linux316-nvidiabl              0.88-35              0.88-36
                      linux316-r8168          8.045.08-11          8.045.08-12
                  linux316-rt3562sta        2.4.1.1_r4-25        2.4.1.1_r4-26
                        linux316-spl             0.7.11-1             0.7.11-2
                   linux316-tp_smapi              0.41-45              0.41-46
                linux316-vhba-module          20161009-25          20161009-26
   linux316-virtualbox-guest-modules             5.2.22-1             5.2.22-2
    linux316-virtualbox-host-modules             5.2.22-1             5.2.22-2
                        linux316-zfs             0.7.11-1             0.7.11-2
                     linux318-nvidia           1:410.73-2           1:410.78-1
                     linux414-nvidia           1:410.73-4           1:410.78-1
                     linux417-nvidia           1:410.73-1           1:410.78-1
                  linux418-acpi_call             1.1.0-14             1.1.0-15
                   linux418-bbswitch               0.8-14               0.8-15
                linux418-broadcom-wl      6.30.223.271-14      6.30.223.271-15
                   linux418-catalyst     1:15.201.1151-14     1:15.201.1151-15
                linux418-ndiswrapper              1.61-14              1.61-15
                     linux418-nvidia           1:410.73-5           1:410.78-2
               linux418-nvidia-340xx           340.107-14           340.107-15
               linux418-nvidia-390xx            390.87-14            390.87-15
                   linux418-nvidiabl              0.88-14              0.88-15
                      linux418-r8168          8.045.08-14          8.045.08-15
                        linux418-spl             0.7.11-7             0.7.11-8
                   linux418-tp_smapi              0.41-14              0.41-15
                linux418-vhba-module          20161009-14          20161009-15
   linux418-virtualbox-guest-modules             5.2.22-3             5.2.22-4
    linux418-virtualbox-host-modules             5.2.22-3             5.2.22-4
                        linux418-zfs             0.7.11-7             0.7.11-8
                  linux419-acpi_call              1.1.0-2              1.1.0-4
                   linux419-bbswitch                0.8-2                0.8-4
                linux419-broadcom-wl       6.30.223.271-2       6.30.223.271-4
                   linux419-catalyst      1:15.201.1151-2      1:15.201.1151-4
                linux419-ndiswrapper               1.61-2               1.61-4
                     linux419-nvidia           1:410.73-2           1:410.78-3
               linux419-nvidia-340xx            340.107-2            340.107-4
               linux419-nvidia-390xx             390.87-2             390.87-4
                   linux419-nvidiabl               0.88-2               0.88-4
                      linux419-r8168           8.045.08-2           8.045.08-4
                        linux419-spl             0.7.11-2             0.7.11-4
                   linux419-tp_smapi               0.41-2               0.41-4
                linux419-vhba-module           20161009-2           20161009-4
   linux419-virtualbox-guest-modules             5.2.22-2             5.2.22-4
    linux419-virtualbox-host-modules             5.2.22-2             5.2.22-4
                        linux419-zfs             0.7.11-2             0.7.11-4
                   linux44-acpi_call            1.1.0-115            1.1.0-116
                    linux44-bbswitch              0.8-115              0.8-116
                 linux44-broadcom-wl      6.30.223.271-85      6.30.223.271-86
                    linux44-catalyst    1:15.201.1151-115    1:15.201.1151-116
                 linux44-ndiswrapper              1.61-83              1.61-84
                      linux44-nvidia           1:410.73-2           1:410.78-2
                linux44-nvidia-340xx           340.107-20           340.107-21
                linux44-nvidia-390xx             390.87-9            390.87-10
                    linux44-nvidiabl             0.88-115             0.88-116
                       linux44-r8168          8.045.08-37          8.045.08-38
                   linux44-rt3562sta        2.4.1.1_r4-83        2.4.1.1_r4-84
                         linux44-spl             0.7.11-5             0.7.11-6
                    linux44-tp_smapi             0.41-115             0.41-116
                 linux44-vhba-module          20161009-83          20161009-84
    linux44-virtualbox-guest-modules             5.2.22-2             5.2.22-3
     linux44-virtualbox-host-modules             5.2.22-2             5.2.22-3
                         linux44-zfs             0.7.11-5             0.7.11-6
                   linux49-acpi_call            1.1.0-103            1.1.0-104
                    linux49-bbswitch              0.8-103              0.8-104
                 linux49-broadcom-wl     6.30.223.271-103     6.30.223.271-104
                    linux49-catalyst    1:15.201.1151-103    1:15.201.1151-104
                 linux49-ndiswrapper             1.61-101             1.61-102
                      linux49-nvidia           1:410.73-3           1:410.78-2
                linux49-nvidia-340xx           340.107-22           340.107-23
                linux49-nvidia-390xx            390.87-11            390.87-12
                    linux49-nvidiabl             0.88-103             0.88-104
                       linux49-r8168          8.045.08-43          8.045.08-44
                   linux49-rt3562sta       2.4.1.1_r4-101       2.4.1.1_r4-102
                         linux49-spl             0.7.11-6             0.7.11-7
                    linux49-tp_smapi             0.41-103             0.41-104
                 linux49-vhba-module         20161009-101         20161009-102
    linux49-virtualbox-guest-modules             5.2.22-3             5.2.22-4
     linux49-virtualbox-host-modules             5.2.22-3             5.2.22-4
                         linux49-zfs             0.7.11-6             0.7.11-7
                        nvidia-utils           1:410.73-1           1:410.78-1
                       opencl-nvidia           1:410.73-1           1:410.78-1
                               pamac              7.3.0-5              7.3.1-1
             pamac-tray-appindicator              7.3.0-5              7.3.1-1


:: Different overlay package(s) in repository multilib x86_64

-------------------------------------------------------------------------------
                             PACKAGE               stable              testing
-------------------------------------------------------------------------------
                  lib32-nvidia-utils           1:410.73-1           1:410.78-1
                 lib32-opencl-nvidia           1:410.73-1           1:410.78-1
  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Why nvidia 410 drivers still not pushed to the manjaro
#2

Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Stable Updates Announcements RSS feed


Items from previous update sets

i3 changed its default config path

It seems that (from version >= 4.16) i3 is looking for its configuration in ~/.config/i3/config instead of ~/.i3/config.
Copy your config to the new path and all should work as before. (reported from an i3-gaps user).


I can’t open Nemo with elevated privileges (as root)

Workaround found: Use the dbus-x11 package instead of the regular dbus package. This package is available in the official repositories and provides dbus compiled without the --without-x option.

To replace dbus with dbus-x11 package, simply install dbus-x11 with your favorite package manager: dbus will be replaced by dbus-x11.


Pamac: “Failed to commit transaction - Transaction not prepared” at the end

So far, it has only been a false alarm: updates are applied successfully.


AMD-Ucode introduction

Unless you’ve already done this previously, All users of AMD-APUs/CPUs should install this update like this:

sudo pacman -Syyu
sudo pacman -S amd-ucode
sudo pacman -R intel-ucode
sudo update-grub

Step 3 is optional.


Rebuilding fontconfig cache: failed to write cache

Please ignore this message. Upstream already works on a solution. More about the issue here.


LibreOffice has no window decoration in KDE

New line export SAL_USE_VCLPLUGIN=gtk3_kde5, once merged into existing /etc/profile.d/libreoffice-fresh.sh , fixes a moderately longterm issue. If it doesn’t work for you, you may use gtk instead of gtk3_kde5 as UI framework.


Installing glibc (2.28-4) breaks the dependency “glibc=2.27” required by lib32-glibc

Install the update either:

  • from terminal: sudo pacman -Syu or;
  • with Octopi instead of Pamac.

Something using Perl/Python/glibc broke

Rebuilds needed!

  • If it’s an AUR package, try to reinstall it from AUR. It most likely needs to be rebuilt.
  • If it’s a repo package, please report and check back regularly for updates.

I’ve lost a Thunderbird addon/feature

Thunderbird 60 disables incompatible addons by default. There’s an about:config switch should you want to force-enable the addon, but many addons simply will not work with the newer Quantum-based Thunderbird.

Read more about Thunderbird 60 here: Thunderbird 60


Firefox - WebGL not working anymore

You may try the following solution:

Open about:config and set security.sandbox.content.read_path_whitelist to /sys/.


libutf8proc>=2.1.1-3 update may require manual intervention

This should normally be automatically fixed via manjaro-system update.

The libutf8proc package prior to version 2.1.1-3 had an incorrect soname link. This has been fixed in 2.1.1-3, so the upgrade will need to overwrite the untracked soname link created by ldconfig. If you get an error

libutf8proc: /usr/lib/libutf8proc.so.2 exists in filesystem

when updating, use


pacman -Suy --overwrite usr/lib/libutf8proc.so.2

to perform the upgrade.


Pamac: “Invalid or corrupted package.”

If you receive an “Invalid or corrupted package.” error message with Pamac and if the details contains an output similar to the following:

Details
Synchronizing package databases...
Starting full system upgrade...

Preparing...
Resolving dependencies...
Checking inter-conflicts...
Downloading...
Downloading manjaro-system-20180716-1-any.pkg.tar.xz...
Checking keyring...
Checking integrity...
Loading packages files...
Checking file conflicts...
Checking available disk space...
Upgrading manjaro-system (20180702-1 -> 20180716-1)...
==> Fix libutf8proc upgrade ...
resolving dependencies...
looking for conflicting packages...

Packages (1) libutf8proc-2.1.1-4

Total Download Size:   0.05 MiB
Total Installed Size:  0.32 MiB
Net Upgrade Size:      0.00 MiB

:: Proceed with installation? [Y/n] 
:: Retrieving packages...
downloading libutf8proc-2.1.1-4-x86_64.pkg.tar.xz...
checking keyring...
checking package integrity...
loading package files...
checking for file conflicts...
checking available disk space...
:: Processing package changes...
upgrading libutf8proc...
:: Running post-transaction hooks...
(1/1) Arming ConditionNeedsUpdate...
Running post-transaction hooks...
Arming ConditionNeedsUpdate...
Warning: lock file missing /var/lib/pacman/db.lck
Starting full system upgrade...
Resolving dependencies...
Checking inter-conflicts...
Error: could not open file /var/lib/pacman/local/libutf8proc-2.1.1-2/files: No such file or directory
Warning: could not fully load metadata for package libutf8proc-2.1.1-2

Failed to prepare transaction:
invalid or corrupted package

Try the following steps: close Pamac window first, then launch it again and start the update procedure again. It should continue from where it left off.


Issues with folder view widget in KDE v5.13

KDE introduced a new setting for icon sizes. Now you’re able to define also the size for your panel. If you have a high-DPI display, you may want to increase the value. This will fix the display issue with given widget.

icon-kde-513

Pulseaudio changes

With this update we have a /etc/pulse/default.pa.pacnew. It may be necessary to merge (some lines related to “GSettings” in /etc/pulse/default.pa ) if ‘default.pa’ has been customised.

File conflict engrampa.tap

thunar-archive-plugin: /usr/lib/xfce4/thunar-archive-plugin/engrampa.tap exists in filesystem (owned by engrampa-thunar-plugin)

thunar-archive-plugin has added native support for the Engrampa archive manager. engrampa-thunar-plugin is no longer needed. Remove engrampa-thunar-plugin to continue with the update.


#3

No issues noticed. XFCE kernel 4.19. :+1:


#4

No issues :slight_smile:

Gnome 3.30.2 kernel 4.19


#5

All fine on KDE, thanks!


#6

2 posts were split to a new topic: System won’t boot after 2018-11-25 Update - /new_root: can’t find UUID


System won't boot after 2018-11-25 Update - /new_root: can't find UUID
#7

Xfce update went perfect, but needed to reboot after update for the vpn to work.


#9

Update went okay, besides the fact that every time after a kernel update the machine boots with the latest 4.19 kernel instead of the 4.14 that I have set to boot from.


#10

Updates without problems LXQT and XFCE with Kernel 4.19.


#11

Upgrade no problem Xfce:
[2018-11-25 16:36] [ALPM] upgraded mhwd-db (0.6.3-4 -> 0.6.3-6)


Konsole error
#12

XFCE, 4.19.4-1

Everything went smoothly! Thanks for all the hard work.


#13

Updates, multiple DE’s / Manjaros, all good.

I like & appreciate the videos, @philm.


#14

I think this is the normal behaviour when update-grub is run (or at least when it detects changes); it automatically defaults to the newest kernel it can find.
Other than simply not having newer kernels installed, the only solution I can think of would be to identify the file that GRUB keeps its last boot information in and running a script to restore it after a kernel update.


#15

I does not change when I run update-grub only, then it boots with the 4.14.


#16

I got weird white noize while booting after update on my laptop.

Laptop config

System: Host: T175 Kernel: 4.19.4-1-MANJARO x86_64 bits: 64 Desktop: KDE Plasma 5.14.3 Distro: Manjaro Linux
Machine: Type: Laptop System: Dell product: Latitude 5580 v: N/A serial:
Mobo: Dell model: 0DTP1F v: X02 serial: UEFI: Dell v: 1.9.3 date: 03/08/2018
Battery: ID-1: BAT0 charge: 64.1 Wh condition: 64.1/68.0 Wh (94%)
CPU: Topology: Quad Core model: Intel Core i5-7440HQ bits: 64 type: MCP L2 cache: 6144 KiB
Speed: 2310 MHz min/max: 800/3800 MHz Core speeds (MHz): 1: 2310 2: 2036 3: 2297 4: 2192
Graphics: Device-1: Intel driver: i915 v: kernel
Display: x11 server: X.Org 1.20.3 driver: intel resolution: 1920x1080~60Hz, 1920x1080~60Hz
OpenGL: renderer: Mesa DRI Intel HD Graphics 630 (Kaby Lake GT2) v: 4.5 Mesa 18.2.5
Audio: Device-1: Intel CM238 HD Audio driver: snd_hda_intel
Sound Server: ALSA v: k4.19.4-1-MANJARO

Tried to reboot twice. Didn’t help. Also I haven’t a default.pa.pacnew file in /etc/pulse directory.

Here's my GRUB_CMDLINE_LINUX_DEFAULT in /etc/default/grub:

GRUB_CMDLINE_LINUX_DEFAULT=“resume=UUID=6ece3c38-fd8d-4aef-98f9-d7cca5cc86dc intel_iommu=on sysrq_always_enabled=1 i915.enable_guc_loading=1 i915.enable_guc_submission=1 quiet loglevel=3 rd.systemd.show_status=auto rd.udev.log_priority=3 vga=current”

UPD: Go to UEFI settings (white noize still presents) -> System Configuration -> Disable audio -> apply -> reboot. White noize dissapeared, but I need a sound from laptop speakers!
Go to dell support website, downloaded latest BIOS, updated. Go to UEFI settings -> System Configuration -> Enable audio. It works now. I didn’t know what helped - check-uncheck mark or BIOS update.


#17

hi dear community … i installed the brave browser and it is a decent browser but i have a tiny issue … in launch it shows --no-sandbox and this is will affect performance and security … any tips are welcome and thank you


#18

I can’t help you. But I can give you another advice. Start a new thread for your issue and give it a good title. That way you increase your odds to get helpful answers


#19

@philiperhome and @folky - was already discussed


#20

Brave is a great mobile web browser since they can prevent ad from eating up your precious mobile data. However, uBlock origin or similar adblock can always do the same trick.
e: a comma.


#21

thank you so much my friend … it works so fine now … what a wonderful addition to manjaro’s repos … thank you again my friend