SSHFS Problem

I looked through the forum and even my own post on this issue but I cannot connect to my other Manjaro computer using.
sshfs user@x.x.x.x:-o,-c,-pnewport,-osubdir=\ /mnt/share\ / /home/flynn/Misc
I get read: Connection reset by peer error so I know it's a security issue in ssh/ssh_config or sshd_config. Which I have looked into and found no problems so I thought I may ask the forum.

Did some debugging with.
ssh -v user@x.x.x.x
OpenSSH_8.0p1, OpenSSL 1.1.1c 28 May 2019
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: Connecting to x.x.x.x [x.x.x.x] port new.
debug1: connect to address x.x.x.x port new: Connection refused
ssh: connect to host x.x.x.x port new: Connection refused
Still nothing really of value except what I suspect is a secure line in ssh_config

There could a couple of reasons for this

  1. Your ssh service is not running on the endpoint
  2. You are being blocked by a firewall

I have added the new port to iptables and restarted iptables and ssh and sshd_config. Now the other maybe. I just tried this but even with sudo I got this error.
ssh-keyscan -H x.x.x.x >> ~/.ssh/known_hosts
write (10.0.0.15): Connection refused
write (10.0.0.15): Connection refused
write (10.0.0.15): Connection refused

It could also be you mount options.

According to the Arch wiki the syntax is

sshfs [user@]host:[dir] mountpoint [options]

And yours does not exactly follow that recipe :slight_smile:

To debug your connection the first thing to ensure is

  • connect succesfully using ssh

Then you can start with sshfs

As always the archwiki excels when it comes to documenting

https://wiki.archlinux.org/index.php/OpenSSH#Checklist
https://wiki.archlinux.org/index.php/SSHFS#Troubleshooting

1 Like

[inkrypted@meninblack ~]$ sudo systemctl status ssh
[sudo] password for inkrypted:
Unit ssh.service could not be found.
[inkrypted@meninblack ~]$

Yet I have openssh installed. That service could not be found either.
Thank you for the links.

Little typo there, you're missing a d:

$ systemctl status sshd
1 Like

On the target system

systemctl list-unit-files | grep ssh

systemctl enable --now sshd

On the client system

ssh user@host

sshd.service disabled
sshd@.service static
sshdgenkeys.service static
sshd.socket disabled

ssh: connect to host x.x.x.x port x.x.x.x.x: Connection refused
sftp gives me the same error with an additional

Connection closed.
Connection closed

Well I can connect from my File Server to my client so that works but it did not use the key. However the other way still does not work. and I get the error read: Connection reset by peer. I made sure I was using the exact same verbiage.

Client and server are two different things.

Check your configs

Have you checked the wiki's page on troubleshooting ssh connections?

Yes I have but It's getting late here so I will continue to work on it tomorrow. Thank you all for your help.

I decided to use Vsftpd on a Manjaro computer and connect to it from the other Manjaro computer using Filezilla to transfer some files Now the vsftpd service comes up and gives no errors and the port I am using is in my IP Tables both client and server and I still cannot connect. If anyone has any advice on this I would love to hear it because my ideas are running out. By the way this is all internal using static IP's on both machines and I can ping both ways.

If too many factors are in play simplify and recheck.

If you are running internal - the clear all ip-table rules - as firewalls make no sense internal.

Recheck your services


In my opinion NFS is the easy and simple way - both ways if you wish.

There is not permission issues - only the ones the on IP basis and you can set that to a subnet.

https://wiki.archlinux.org/index.php/NFS

Actually I have NFS shares setup but I have a 1TB Partition and cannot figure out how to share a folder between the machines. I have it because that is how I use Kodi. I will read your link but so far this is making me crazy at one time I was a pretty good technician now not so much.

Some times I get hot in my and then I need a fresh start.

I will look at creating a guide on setting up sharing between two computers.

Your use case is a good example - I will have a look at it tomorrow as it is a frequent question.

Do you want to copy files both directions? or is one direction enough?

Actually I want to be able to go both ways so no matter where I am I can share the directory. I have a folder on my main computer that is almost 800MB so it would be perfect for storage.

Have a look at this

Guys I would love to work on this but on the main server running Gnome a hard drive went out on me I lost just the OS as my other media were on two other drives so I thought easy right I have a replacment that is when things took a turn for the worst. I could get Manjaro Gnome to install no matter what I used. Finally I tried the XFCE Edition and it got installed and I copied my shares back over and had just started to reinstall my programs when the network no longer works yup it's the Realtek and I cannot get it to function with the R8169 So I thought I would just copy the file and sudo modprobe r8168 because that is what I had to do on all of the ones I have to get them working I found where I thought they were and copied them over and then even unzipped them still no luck installing them. So I thought next I would go back into the live environment and give that a shot. I am also house cleaning today. But if anyone has suggestions please feel free. I really appreciate the support here. I just thought of something I turned on my onboard LAN and it's the same I remember both of these working one was just slower than the other. I wonder what happened?

Great I installed an r8168 driver and now I am in emergency mode. I got the 9 back in but I still have no Network So I have nothing to enable. Looks like I was able to solve most of my problems except for the Realtek driver issue. I found some threads here that brought it back but not for long. I hate to hijack my own thread but I have to get that issue resolved first then I can work on the others. Thanks everyone for the help.

Forum kindly sponsored by Bytemark