SSH wired device via WiFi

I want to ssh into my wired device using my laptop that is on the same network but connected to wifi.

sudo arp-scan --local lists some IPs but none are what im looking for, how do I find my device IP?

ip neighbour
should show you the address of your router

a few STALE, one FAILED, and one REACHABLE

Go to your “wired device” log in and check the IP. If you are in a Home Environment and have access to your Router, log in at the router and list all connected devices. It usually shows the IPs.

Or you could use a tool like nmap and scan for port 22. It is the default ssh port.

nmap -p 22 192.168.2.1/24

The 192.168.2.1/24 ip address range is an example use your real network space.

the REACHABLE one -
you should be able to use that to connect to the router’s web interface via the browser - if it has one

ip neighbour
192.168.4.1 dev wlan0 lladdr 34:81:c4:b0:2a:62 REACHABLE
fe80::3681:c4ff:feb0:2a62 dev wlan0 lladdr 34:81:c4:b0:2a:62 router STALE

ssh root@192.168.4.1 
root@192.168.4.1's password:

I do that on a regular base

arpscan is the tool

If arpscan is not listing the IP - which is very unusual - you should check your access point - for what is commonly known as client isolation.

If your accesspoint is isolating clients - e.g. creating isolated guest networks - then you won’t get any response using arpscan.


It is easy to check - usually a home router creates dhcp leases of 24h or more. Just run ip a on the device then try ssh to the ip address listed.

so i just checked router settings and the IP of my device does show on arp-scan - it just wont connect to ssh and hangs

Hanging is a completely different issue …

This an issue with the ssh configuration on the device

yep, the device is working and I can connect to the server running on it

Hung connections is often caused by updated kernel or kernel modules - either client or server - without a reboot to reload kernel/modules - so the suggestion is to restart both - then recheck the connection.

I catch myself speculating why I cannot ssh to specific device - only to realize - the client I am using is connected using VPN - and my firewall don’t allow external access - as soon as I disconnect the VPN my ssh works perfectly.