Ssh into RPi (stuck at password)


Hello all.

I think I need little bit of help. I am trying to ssh into my raspberry pi system, which is running Manjaro arm KDE.

I have been using this documentation to enable ssh on the RPi. Everything worked fine until step 5.
There I went to my laptop and did

>>> ssh RPi@192.168.x.x                                                                                    
The authenticity of host ' (' can't be established.
ECDSA key fingerprint is SHA256:Tn7+hDbNdcJe4v4nRMnRBwuPTGif0KKX3CTDOVkAkoU.
Are you sure you want to continue connecting (yes/no/[fingerprint])? yes
Warning: Permanently added '' (ECDSA) to the list of known hosts.
RPi@'s password: 
Permission denied, please try again.

At the password, I use the login password of the RPi, but always get denied.

I have also looked at this post to create ssh keys on my laptop (not sure if this step is necessary).
Trying to copy the ssh key to the RPi strands on the password (again).

I have been looking around, but all of the docs I find tell me these same steps, log into RPi@location and enter password.
IF the ssh login password is not the same as regular login, where can I reset it?

I am actually trying this ssh stuff out for the first time, so all advice would be appreciated.

Try clearing out ~/.ssh/known_hosts file then try again. Something has changed in it.

No such file or directory, I’ve probably messed this up.

No, no .ssh folder

And no known_hosts in etc/ssh

Not on the pi but on the machine you are using to ssh to it.

Döööööö :laughing:
I have removed that file.

It will create a new one.

And I get Access denied when trying again. Looking into the known_hosts file, it is just a massive sha

Deleted the file again. Did ssh-keygen tried ssh-copy-id RPi@192.168.x.x to the RPi again, and is denied on password…

This is fun

Is your username on the pi really RPi?
I don’t think it is, since usernames can’t contain capital letters.

If not, you need to change that in the command to match your username on the pi.
If you haven’t set it up yet, you need to use ssh root@<ip adress>.

no, that is the hostname, might that be the problem? I just messed this up?

This was a big fail on my account, sorry guys :smiley:

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.