SSH Client Not Workinng On New Install

Hi, first post here, loving Manjaro so far - I had installed the XFCE version a few years ago but went over to MX Linux, which is also great btw, but came back to Manjaro (Gnome Edition) because I wanted to go back to a rolling release distro, and for the AUR, which makes everything so much easier.

Anyway everything is working perfectly except for SSH - I copied over the .ssh folder from my old machine (as I have done in the past with no issues), installed Asbru Connection Manager (recommended app for multiple SSH connections) and tried to connect. It times out every time after about 3 minutes of just hanging. Tried different servers and same result.

I thought it might be a problem with Asbru but just a plain terminal ssh session also timed out with many different servers, so I thought maybe an issue with my ISP or port blocked in the router (just moved house), but I can SSH no problem on the same connection using my Android tablet using Termux.

I checked all the permissions in the .ssh folder, nothing wrong there, checked the /etc/ssh/ssh_config and it was just the default file with no mods, as it should be on a brand new install.

So I am at a bit of a loss… the verbose option shows no errors until it informs me that the connection has timed out.

If anyone can shed some light on why this might be happening I would be very grateful, thanks.

I don’t know but regarding your explanation of what you did and what you tried, I would say try to remove your .ssh folder and try a connection, see what happens?

Thanks for the quick reply!

It’s the same with no .ssh folder: “Connection timed out” :thinking:

I have had several problems with newest ssh client and older ssh-servers.

“Connection timed out” could mean:

  1. Problems with the cryptographic. There you need to set explicitly which cryptographic of your old ssh-server supports.
  2. There is no keepalive option set. Create a file in $HOME/.ssh/config and put this into it:
Host *    
    ServerAliveInterval 60
    ServerAliveCountMax 30
    TCPKeepAlive yes

Thanks, I’ve tried that with no success, it still times out.

The thing is that all SSH connections time out, even to a GreenGeeks shared hosting box which surely has the latest software installed. And I am able to connect using other devices, so that suggests the problem is within this particular Manjaro install.

I would look at the journal log on the server if possible. There are in general more information why it rejects you.

If the connection is even going to the server, indeed this is a good suggestion.

Do you have a firewall (e.g. ufw) enabled that is blocking outgoing connections on ports other than 443 and 80 or so?

Looked at the auth.log - a lot of failed connections, but none from my IP.


   sudo ufw status
    Status: inactive

I can ping the server but I don’t think it’s even trying to log in via SSH, nothing visible in the server logs.

BTW this is my SSH version:

OpenSSH_8.5p1, OpenSSL 1.1.1j 16 Feb 2021

I just tried another server that I hadn’t tried before and it DID work! So I am at a loss why it’s not working on three other servers but it does work on this one.

Maybe you have been banned from accessing the SSH port on the servers that do not work (fail2ban, crowdsec, things like that)?

Yes, you must be right! I tried connecting using a VPN and it worked. So not sure why my IP has been banned from these 3 servers, but maybe it’s a shared IP and someone else has been doing something naughty.

So that’s great, the issue is solved, thanks for the help all!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.