SSH Access SLOW - Possible Avahi mDNS Issue

Hey Guys,

As the subject states, getting super slow SSH when trying to ssh to any ‘.local’ devices on my network (raspberry pi). According to my terminal it’s takes almost 30 seconds to get the password prompt. On my MacBook Pro, things are super snappy and I can SSH to my other devices with almost no delay. Both Manjaro and MacBook are on wifi and no other major issues that I can tell.

Anyone else see similar issues? Thanks!

The .local domain is a pain.

Try using the IPv4 address of the device instead of .local - no wonder macOS works - .local is an Apple invention - at least as I remember it :slight_smile:

Or even better - setup a local DNS service and stay away from .local - the top result you will get if you own a regular internet domain of some kind - then setup a subdomain e.g. lan.domain.tld.

Anyone else have any additional thoughts? Thanks in advance, all your time and help is greatly appreciated.

Aside from my Windows box (using WSL) sometimes not able to find them, I have no lag issues using .local domains between devices a multitude of devices/machines (Manjaro, Fedora, Mac, Windows, NAS, etc).

Looking at some threads about the Pi and SSH, there’s some configuration options that might speed things up for you:

Hey @mven,

Thanks for the quick reply! I made the change, and unfortunately it did not change anything. To be clear, the slow-ness only occurs when I use “hostname.local” when trying to SSH. If I use the IP Address, the SSH session connects immediately. This is why I think it has something to do with “hostname.local” specifically taking forever on Manjaro.

Thanks in advance for all of your time and help, it is greatly appreciated!

What about this solution:


ref: Arch Linux ARM • View topic - avahi mDNS access slow