SSD says it's 100% full even though i just uninstalled a bunch of programs

so i’m new to linux. i’m currently dual booting xfce manjaro with windows for about 2 weeks now and it’s great. today i went to install a program and it gave me an error saying i have 0 free space in my ssd (i made a 31gb partition for manjaro). i just uninstalled libre office and it was supposed to free about 1gb but it still says its 100% full. i have absolutely no idea what is happening and couldn’t find a similar topic

31 GB is not too much, to be honest. I reserved 128 GB and regularly run into trouble (but i use manjaro as my main working os) and consider reorganizing the partitions.

Anyway, pacman keeps a cache of package files. You may want to clean it using

sudo pacman -Sc

this should give you some space.

i know its not much but for some reason i couldnt give it more space. i tried doing that also and it didnt work. firefox just said my password and bookmarks arent gonna work anymore for some reason and i noticed some custom icons started reverting back to the original system icons. ulauncher and steam also stopped working. thats pretty weird. i have a backup on an external hd and i also made some with timeshift but i dont know its the best thing to do. my only concern is having to reconfigure the whole thing again cause that takes some time haha

Another idea would be to find the files that are using the disk space.

du -sh *

will list the aggregated file sizes of the current dir’s subdirectory. Instead of * you may also start with /

i wish it was that simple but apparently it’s not about what is taking up space because it doesn’t matter if i uninstall something or delete tons of files - it continues to say i have zero free space which is pretty weird

Someone could probably start to help
vs just speculating
if you told what the exact message is and when you are seeing it,
what you are doing when this appears.

1 Like

nothing in particular tbh. you know when you open the home directory and it says on the bottom how much free space you have? yeah mine says its zero. and then it doesnt let me install any lrograma because i have zero free space even though i just uninstalled a lot of programa i wasnt using, cleaned the cache and deleted old files

still not much useful information to go on

df -h
lsblk -f

are good starting points

paccache -rk1
to clean the pacman cache

@a-sassermann and @freggel.doe gave useful advice

You didn’t say whether you tried what was suggested.

indid try that. i have now tried restoring from an old backup using timeshift and it fails to boot. im ataring at an “emergency mode” asking me to either give the root password or press ctrl-D to continue but none kf these do anything. well at this point i guess its best just to scratch the whole thing and reinstall. thx anyways

Well - as this install is now probably gone
in your next
do the thing @freggel.doe suggested - so that the logs don’t grow too large
or edit the config file so that they are only temporary - and never written to disk.

Also - with that limited space - tell pamac to only keep one copy of installed updates from the get go
instead of having to purge them manually with:
paccache -rk1

Then, if it comes to the same situation, use
df -h
lsblk -f
to ascertain where the space might be getting low.

… and:
don’t use snap’s or flatpacks - they use a lot of space which you don’t (or rather: might not) have …

1 Like