SSD In read only mode?

Hey All,

Just wanted to get a bit of a sanity check here before I move forwards with a replacement.

I have an SSD that I think went bad and is now somehow stuck in read-only mode??

I tried unmounting it and checking it with fsck

[user@ ~]$ sudo e2fsck /dev/sda1
[sudo] password for user: 
e2fsck 1.46.4 (18-Aug-2021)
data: recovering journal
Superblock needs_recovery flag is clear, but journal has data.
Run journal anyway<y>? no
Clear journal<y>? no
e2fsck: unable to set superblock flags on data

data: ********** WARNING: Filesystem still has errors **********

any combination of yes and no to the questions results in the same issue.
I then tried to nuke the partition and rebuild the file system using KDE Partition manager.

Failed to add partition ‘New Partition’ to device ‘/dev/sda’. 
Create new partition on device ‘/dev/sda’: Error
Create a new partition (953.86 GiB, ext4) on ‘/dev/sda’: Error

So after trying that, when I check my UUDI and PARTUUID in blkid I get the same values as what was in my fstab already suggesting it didn’t even delete the old partition.

Weirdly however the SMART test comes back as clean

Just checking if anyone has seen an SSD do this before? Is this like a fail-safe failure mode?
Do I need to manually destroy my drive before I get rid of it now I can’t do a secure erase?

@akin2silver Maybe check the kernel messages?

sudo dmesg
1 Like

Memory cells sometimes need clearing - you may gain some insight with this article from the Arch wiki

1 Like

Thanks for that, I will mark this as the solution as it will help me get it wipped at a low level.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.