SSD drive locked in read-only mode (critical error: 0x08) - won't unlock, can't reformat

Hello folks,

I am having trouble saving a moderately old nvme SSD drive - I was previously using this as a backup disk on a desktop PC, and later as a swap drive. Around the time I started using it for swap, it suddenly stopped working, and would intermittently be detected by the OS, if at all.

I took off the SSD’s heat sink, popped it into a USB adapter hub, and have started the process of trying to figure out what’s wrong. When plugged into my PC via the USB adapter, it is recognized immediately every time by Gnome Disks and Gparted, with full information about the drive being available. However, I can’t mount the old partition on it, nor can I alter the drive in any way. I can’t format it either.

I ran Smartmontools on the drive and received the following output:

Copyright (C) 2002-22, Bruce Allen, Christian Franke,

Model Number:                       PLEXTOR PX-128M8SeG
Serial Number:                      P02721136456
Firmware Version:                   1.00
PCI Vendor ID:                      0x14a4
PCI Vendor Subsystem ID:            0x1b4b
IEEE OUI Identifier:                0x002303
Total NVM Capacity:                 128,035,676,160 [128 GB]
Unallocated NVM Capacity:           0
Controller ID:                      1
NVMe Version:                       1.2
Number of Namespaces:               1
Namespace 1 Size/Capacity:          128,035,676,160 [128 GB]
Namespace 1 Formatted LBA Size:     512
Namespace 1 IEEE EUI-64:            002303 563001884a
Local Time is:                      Thu Nov  3 18:15:30 2022 +04
Firmware Updates (0x14):            2 Slots, no Reset required
Optional Admin Commands (0x001f):   Security Format Frmw_DL NS_Mngmt Self_Test
Optional NVM Commands (0x001f):     Comp Wr_Unc DS_Mngmt Wr_Zero Sav/Sel_Feat
Log Page Attributes (0x03):         S/H_per_NS Cmd_Eff_Lg
Maximum Data Transfer Size:         32 Pages
Warning  Comp. Temp. Threshold:     85 Celsius
Critical Comp. Temp. Threshold:     95 Celsius

Supported Power States
St Op     Max   Active     Idle   RL RT WL WT  Ent_Lat  Ex_Lat
 0 +     8.00W       -        -    0  0  0  0        0       0
 1 +     4.50W       -        -    1  1  1  1        5       5
 2 +     3.00W       -        -    2  2  2  2        5       5
 3 -   0.1000W       -        -    3  3  3  3     1000    8000
 4 -   0.0100W       -        -    4  4  4  4     5000   50000

Supported LBA Sizes (NSID 0x1)
Id Fmt  Data  Metadt  Rel_Perf
 0 -     512       0         0

SMART overall-health self-assessment test result: FAILED!
- media has been placed in read only mode

SMART/Health Information (NVMe Log 0x02)
**Critical Warning:                   0x08**
Temperature:                        31 Celsius
Available Spare:                    100%
Available Spare Threshold:          0%
Percentage Used:                    8%
Data Units Read:                    95,087,893 [48.6 TB]
Data Units Written:                 23,141,499 [11.8 TB]
Host Read Commands:                 1,794,339,868
Host Write Commands:                140,166,770
Controller Busy Time:               64,648
Power Cycles:                       316
Power On Hours:                     20,550
Unsafe Shutdowns:                   137
Media and Data Integrity Errors:    0
Error Information Log Entries:      0
Warning  Comp. Temperature Time:    0
Critical Comp. Temperature Time:    0
Temperature Sensor 1:               31 Celsius

Warning: NVMe Get Log truncated to 0x200 bytes, 0x200 bytes zero filled
Error Information (NVMe Log 0x01, 16 of 64 entries)
No Errors Logged

What I noticed first is that the drive is reporting a critical error: 0x08 - drive LOCKED IN READ ONLY MODE.

I then used a Windows machine’s Diskpart to try and force it out of read-only mode, which didn’t work. Taking it back to Linux, I tried wiping the drive with sudo privileges from terminal (dd, cat, mkfs, fdisk, badblocks -wsv, and more). Absolutely nothing works as it seems the drive is rejecting all attempts to write to it. I tried doing a hardware level ATA reset and that also failed.

The drive is not very old, hasn’t been used much, and SMART reports NO errors on the drive. Does anyone have recommendations on how to force-unlock this drive and salvage it? No critical data is on the drive but I’m trying to avoid throwing it away just because the controller freaked out due to a previous power loss.

Please advise, thank you!

Hi @Tbilisi.Heat, and welcome!



Along with the fact you used it as a SWAP drive, it may very well be the drive is just EOL. Especially considering flash memory, so SSD drives in general, only support so many write-cycles.


For all we know, this might have contributed as well. Just no way to be 100% sure. That I know of anyway.



If you have a copy of Parted Magic ISO, it includes a suite of tools for drive wiping, secure erase, factory reset, unfreezing locked states, etc. The GUI tools give you more options you might have missed if only using the command-line.

You might even consider the nvme tools from within Manjaro, since this is not on the SATA interface, but rather PCIe.

It can be installed with sudo pamac install nvme-cli

That’s a lot of writes. If you haven’t been using scheduled “trims”, then the stress is even greater on the SSD.

To be clear, just because a drive is “rated” to theoretically handle “X many TBW”, the real world is different. But we see that your NVMe drive has been through quite a bit of activity.


Thank you both for the replies. Manjaro’s NVME tools, like SmartCtl can read the drive but cannot make any changes to it whatsoever.

Also tore my hair out researching this error code : 0x08. It seems to mean the controller shut down the drive and locked it into read-only mode, and this is impossible to reverse with software and likely will require re-flashing the firmware and/or other highly intrusive interventions, usually from a professional data recovery specialist.

The drive is now 5 years old and is out of warranty (in fact, Plextor themselves have declared my model EOL and doesn’t even have firmware or documentation for it available on their website anymore).

I am still perturbed that the drive failed far, far below its promised TBW rating, whereas I have drives from WD, Samsung, Sandisk, and even Inland that have received far more thrashing over the years and are still working today.

Anyway, thanks for the help but I think I have to retire this SSD if we can’t fix it with software tools - thankfully, nothing critical was on it. That, and - I will never buy Plextor again, I think I’ll stay with the name brands!

For future reference, make sure you’re using a weekly fstrim timer (or daily, depends on workrate) for any SSDs. :v:

Also make sure it works on the filesystem by testing it out with:

sudo fstrim -va
1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.