Spotify won't launch

I’m running Manjaro KDE Plasma. Snap is installed and I ran sudo snap install, no issues. When trying to run Spotify from the terminal I get
Failed to load module "canberra-gtk-module"
Trace/breakpoint trap (core dumped)

And nothing happens when I run Spotify from krunner or rofi.
How can I make Spotify launch?

Make sure that libcanberra is installed: sudo pacman -Syu libcanberra.
As a workaround: have you tried the AUR version: pamac build spotify?

After doing sudo pacman -Syu libcanberra it still gives me the same message. I’ve also tried pamac build spotify but it gives me the error ERROR: One or more PGP signatures could not be verified! Error: failed to build spotify

If you want to try the AUR version, please remove the spotify version first just to be on the safe side. You need to run curl -sS | gpg --import - as per this pinned comment before you run pamac build spotify.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.