Spotify doesn’t work for me anymore

Hi there, I did the recent updates but Spotify doesn’t work for me anymore…

When I try it from CLI, it looks like this:

$ spotify
/opt/spotify/spotify: /usr/lib/libcurl-gnutls.so.4: no version information available (required by /opt/spotify/spotify)
/opt/spotify/spotify: /usr/lib/libcurl-gnutls.so.4: no version information available (required by /opt/spotify/spotify)
/opt/spotify/spotify: /usr/lib/libcurl-gnutls.so.4: no version information available (required by /opt/spotify/spotify)

I have tried reinstalling Spotify itself (AUR) but that hasn’t changed anything it seems.

I have found very old threads where people had this issue but no real solution.

What I tried next was to delete (or rather move) the spotify folder from ~/.config so it can be recreated, but since Spotify doesn’t launch, it also hasn’t helped.

I also checked if notify-send still works: it does.

I was just wondering if anyone else had this after the most recent updates.

That is an aur package and support is to be expected only from the aur package creators, not here. They have to update and fix it.
Otherwise, you can try rebuilding the package, or use spotify-launcher from the repos.

1 Like

In the announcements for updates you’ll usually see that AUR packages may need to be rebuilt. So the next time there’s an update first check the announcements, then afterwards if any AUR packages you have don’t work, you first try rebuilding them before seeking any more assistance. Also remember Stable Manjaro is behind Arch so incompatibilities may arise, using unstable Manjaro repositories is closest to Arch and incompatibilities with AUR packages are rare.

I am on unstable branch, and spotify is working wo problems. There has been a few updates in the last few week or so, but it never broke.

I use pamac to build it so my stuff is still in ~/.config/spotify

If you are to use AUR it is recomended to be on the unstable branch.

If you are not on unstable, I highly encourage you to think if you actually want to switch, the workload increases significantly.
There is also a flatpak version of spoitfy I would recomend if you want to remain on stable (if you are).

I kept trying after each update and after the latest updates, I was able to launch spotify again.

However:
launching it with the ozone params didn’t work:

spotify --enable-features=UseOzonePlatform --ozone-platform=wayland

It would open a window with their dark background color, but it wouldn’t initialize any content.

Solution:
I tried it without the ozone params and it would launch (blurry though). I had to sign in again. After having signed in, then closing the window and then trying with ozone params would now work :smile:

:v:t5:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.