Spotify can't be installed

I run manjaro 5.14.2-1 and whenever I try to download spotify, it always gives me an error. This is what it shows me when I download it. Also I don’t want to download it via flatpat/snap because I don’t want their versions


    ~  curl -sS | gpg --import -                                                        
gpg: key D1742AD60D811D58: "Spotify Public Repository Signing Key <>" not changed
gpg: Total number processed: 1
gpg:              unchanged: 1

    ~  pamac build spotify                                                                                                                                     ✔ 
Cloning spotify build files...
Checking spotify dependencies...
Resolving dependencies...
Checking inter-conflicts...

To build (1):
  spotify  1:    AUR

Edit build files : [e] 
Apply transaction ? [e/y/N] y

Building spotify...
==> Making package: spotify 1: (Wednesday, 22 September, 2021 03:02:19 PM)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Found spotify.protocol
  -> Found LICENSE
  -> Found spotify-
  -> Found spotify-
  -> Found spotify-
  -> Found spotify-
==> Validating source files with sha512sums...
    spotify.protocol ... Passed
    LICENSE ... Passed
    spotify- ... Passed
    spotify- ... Skipped
    spotify- ... Skipped
    spotify- ... Skipped
==> Verifying source file signatures with gpg...
    spotify- ... Passed
==> Removing existing $srcdir/ directory...
==> Extracting sources...
  -> Extracting spotify- with bsdtar
==> Starting prepare()...
spotify- OK
spotify- FAILED
sha512sum: WARNING: 1 computed checksum did NOT match
==> ERROR: A failure occurred in prepare().


 ~yay -G spotify                                                                                                                              
:: Querying AUR...
 -> Flagged Out Of Date AUR Packages:  spotify
:: Downloaded PKGBUILD (1/1): spotify

then it shows me a notification saying "You are not authorized to execute this file. "


sudo pacman -S spotify                                                                                                                                  ✔ 
error: target not found: spotify
warning: 'spotify' is a file, did you mean -U/--upgrade instead of -S/--sync?

What should I do?

Not a direct solution, but you could create a Web App temporarily if you don’t like Snap/Flatpak. That way you would have at least the newest web version.

You can also check on any AUR updates here: AUR (en) - spotify
Seems like you’re not alone with this issue atm.


Have you checked the pinned comments in the aur for Spotify? Looks like there’s an issue with it. Someone posted a temporary workaround until its fixed

I tried doing that it didn’t work for me

Just found out about this one. Thanks for sending the link!

Not the answer I know but Spotify is also available as a flatpak on manjaro

Spotify from the aur just got an update and built/re-installed for me so looks like they fixed the checksum error