Spell checker not working steam language PTBR

I live in Brazil and I installed Steam via pamac, the official repository, but when typing, I can’t put an accent on the words, is this an error from Steam or Manjaro?
the accent works normally if I open the “kate” application for example.

The problem is that Steam forces the local language to English on script level, even if you use a different language on the GUI. That is done for compatibility reasons.

You can overwrite it in Steam with:

LC_ALL=pt_BR.UTF-8 LANG=pt_BR.UTF-8 steam-runtime

Or if you run a Game and need the full range of UTF-8 symbols in the overlay or game, add this to the steam startup options of each game:

LC_ALL=pt_BR.UTF-8 LANG=pt_BR.UTF-8 %command%

Usually there are no problems overwriting the language, but some Games don’t like it.


I’m new to Linux and I took a look and from what I saw in that attached topic, it’s running on Steam via Lutris or Wine??? There is a printout of the Windows registry.
I always prefer to install a program via pamac and the official repository, nothing against flathub.

No, it is proton, which is wrapper for wine. So basically it is a wine prefix with additional scripts and patches to work better with games. Proton is used for Windows Games, which should run on Steam Linux.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.