Spectacle Doesn't Record Video

It goes through all the steps, but there is nothing saved. And the CPU is also on the lower scale of usage while the “recording” is running.

Checking the web, someone on Reddit said “it only works on Wayland”, but wasn’t this a thing with this recent update…?

Anyway, here’s a short report from my system, if you wan’t something else to read to be able to make a judgement of what is wrong with this, let me know the options to use. 8)

I used some other application on Mint ages ago, it worked fine. Perhaps I should try and find that? If this Wayland/X11 is a thing here.

$ inxi -G
Graphics:
  Device-1: AMD Caicos XT [Radeon HD 7470/8470 / R5 235/310 OEM]
    driver: radeon v: kernel
  Display: x11 server: X.Org v: 21.1.13 with: Xwayland v: 23.2.6 driver: X:
    loaded: radeon unloaded: modesetting dri: r600 gpu: radeon
    resolution: 1920x1080~60Hz
  API: EGL v: 1.5 drivers: kms_swrast,r600,swrast
    platforms: gbm,x11,surfaceless,device
  API: OpenGL v: 4.5 vendor: mesa v: 24.0.6-manjaro1.1 renderer: AMD CAICOS
    (DRM 2.50.0 / 6.6.30-2-MANJARO LLVM 17.0.6)
  API: Vulkan Message: No Vulkan data available.

Recording video in Spectacle is only implemented on Wayland.

It will show a warning that recording is not supported on X11 (KDE Gear 25.04)

X11 has many great tools to record video, but for Wayland it’s not the case, that’s why devs added this feature to Spectacle to make it doable recording video on Plasma Wayland.

Okay, so Reddit was right, I guess. Thanks for the info.

Got no warning though. Just that red little “button”/“icon” that led me to believe that it was recording, when it didn’t.

For those having a similar problem, I installed recordmydesktop (from extra) and that solved my problem:

$ recordmydesktop -x 420 -y 0 --width 1080 --height 1080 -o outputvideo.ogv

Even audio worked fine without doing anything special. That was a hassle on Mint, I recall, probably because of the audio hardware on that machine. Some built-in thing.

Recording tab is by default hidden on X11, but in version 24.05.0 when you press ALT+Meta+R it will show

Well, no, that’s not what I get. Here’s what I did:

  1. Locate Spectacle in the LauncherAll Applications
  2. Right-click on Spectacle and select “Record Rectangular Region”

Of course I chose that path since I didn’t see anything about recording video on the Spectacle GUI, but using my method, it does…sortta…well, not really, you know what I mean.

Result: No warning, but also no video, but it goes through all the loops of creating one, judging from that red “recording” button/icon next to the “Package Manager.”

Still does that, just checked. Hmm, perhaps I can record a video with “recordmydesktop” recording a video of Spectacle not recording a video? <8*)

A bug? It would have been better had they made it grayed-out instead of hiding it completely.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.