Source engine shadows glitchy

In source games, like Half-Life 2 and Gmod, the shadows of some objects are glitchy and disconnected. I have an NVIDIA GPU if that’s related. I’ve tried looking up my problem, but nothing related shows up. Has anyone seen anything like this or know a possible fix?

If its not a common game problem then maybe include some system info.

Here’s the Steam system information thing

Computer Information:
Model: PRIME B350-PLUS
Form Factor: Desktop
No Touch Input Detected
Processor Information:
CPU Vendor: AuthenticAMD
CPU Brand: AMD Ryzen 7 2700 Eight-Core Processor
CPU Family: 0x17
CPU Model: 0x8
CPU Stepping: 0x2
CPU Type: 0x0
Speed: 3200 MHz
16 logical processors
8 physical processors
Hyper-threading: Supported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Supported
SSE4a: Supported
SSE41: Supported
SSE42: Supported
AES: Supported
AVX: Supported
AVX2: Supported
AVX512F: Unsupported
AVX512PF: Unsupported
AVX512ER: Unsupported
AVX512CD: Unsupported
AVX512VNNI: Unsupported
SHA: Supported
CMPXCHG16B: Supported
LAHF/SAHF: Supported
PrefetchW: Unsupported
Operating System Version:
"Manjaro Linux" (64 bit)
Kernel Name: Linux
Kernel Version: 6.5.13-1-MANJARO
X Server Vendor: The X.Org Foundation
X Server Release: 12101009
X Window Manager: KWin
Steam Runtime Version: steam-runtime_0.20231024.64411
Video Card:
Driver: NVIDIA Corporation NVIDIA GeForce RTX 2060/PCIe/SSE2
Driver Version: 4.6.0 NVIDIA 545.29.06
OpenGL Version: 4.6
Desktop Color Depth: 24 bits per pixel
Monitor Refresh Rate: 144 Hz
VendorID: 0x10de
DeviceID: 0x1e89
Revision Not Detected
Number of Monitors: 2
Number of Logical Video Cards: 1
Primary Display Resolution: 1920 x 1080
Desktop Resolution: 3840 x 1080
Primary Display Size: 20.91" x 11.77" (23.98" diag), 53.1cm x 29.9cm (60.9cm diag)
Primary Bus: PCI Express 16x
Primary VRAM: 6144 MB
Supported MSAA Modes: 2x 4x 8x 16x
Sound card:
Audio device: Nvidia GPU 92 HDMI/DP
RAM: 32004 Mb
VR Hardware:
VR Headset: None detected
UI Language: English
Total Hard Disk Space Available: 593712 MB
Largest Free Hard Disk Block: 314508 MB
Number of SSDs: 2
SSD sizes: 1000G,1000G
Number of HDDs: 0
Number of removable drives: 0

I got steam from pacman.
I have tried looking through protondb and using some of the arguments listed there such as -vulkan but I didn’t find anything that fixed it.
Running in proton seems to fix it, but I’d rather use the native version as it usually has better performance.

Already told you

Attempting with it spelled correctly, shadows are still messed up.

It seems to be the worst in gmod in ttt_rooftops_2016_v1. HL2 is a lot more manageable. But for gmod, proton has a way lower fps, so I don’t think I can do that unless I can find out how to get the proton fps up.