Soundconverter stopped working on Manjaro KDE

Hi, all. I’ve been running the GTK application soundconverter on my Manjaro KDE PC for a long time, without a hitch, and a few weeks ago, it just stopped working, for no apparent reason, as other GTK apps continue to run without a problem. If I run

$soundconverter --help

at the command line, the app seems to be OK, but when I try to launch the application, I can see its icon flash briefly on the task bar, and then disappear, after which HTop does not show it running at all. Any ideas on what I can do to troubleshoot this issue? Incidentally, there’s also KDE’s soundKonverter, which runs fine, except it lacks a wonderful feature soundconverter has, which is to customize the name of your converted (output) sound files any which way you want, something immensely helpful when converting large numbers of files. Any ideas would be greatly appreciated.

Operating System: Manjaro Linux
KDE Plasma Version: 5.22.5
KDE Frameworks Version: 5.86.0
Qt Version: 5.15.2
Kernel Version: 5.13.19-2-MANJARO (64-bit)
Graphics Platform: X11
Processors: 8 × Intel® Core™ i7-4770K CPU @ 3.50GHz
Memory: 30.8 GiB of RAM
Graphics Processor: Mesa DRI Intel® HD Graphics 4600

Is there any output if you run soundconverter from the terminal?

Yes, as follows:

$ soundconverter
soundconverter 4.0.1
Traceback (most recent call last):
File “/usr/bin/soundconverter”, line 241, in
gui_main(NAME, VERSION, GLADEFILE, files)
File “/usr/lib/python3.9/site-packages/soundconverter/interface/”, line 1450, in gui_main
window = SoundConverterWindow(builder)
File “/usr/lib/python3.9/site-packages/soundconverter/interface/”, line 998, in init
self.prefs = PreferencesDialog(builder, self.widget)
File “/usr/lib/python3.9/site-packages/soundconverter/interface/”, line 545, in init
File “/usr/lib/python3.9/site-packages/soundconverter/interface/”, line 638, in set_widget_initial_values
File “/usr/lib/python3.9/site-packages/soundconverter/interface/”, line 853, in change_mime_type
File “/usr/lib/python3.9/site-packages/soundconverter/interface/”, line 739, in update_example
generator.generate_target_uri(sound_file, for_display=True)
File “/usr/lib/python3.9/site-packages/soundconverter/util/”, line 451, in generate_target_uri
filename = self._get_target_filename(sound_file)
File “/usr/lib/python3.9/site-packages/soundconverter/util/”, line 430, in _get_target_filename
self.fill_pattern(sound_file, self.basename_pattern),
File “/usr/lib/python3.9/site-packages/soundconverter/util/”, line 371, in fill_pattern
result = pattern.format(**mapping)
ValueError: Single ‘}’ encountered in format string

I do not have the skills to interpret the output.

I can’t reproduce it on GNOME and the error isn’t very helpful, unfortunately. Perhaps report it upstream.

Please do not use blockquote when pasting terminal output.

When pasting terminal output on Discourse forums, one can either…

  • Highlight it and use the Preformatted text </> toolbar button.

  • Add three backticks ` above and below the text (Markdown):


  • Use HTML:


Please edit your post accordingly.

Sorry about the formatting, I believe I have now corrected it as per your instructions.

Also, when you say to report it upstream, what exactly does that mean?

Thanks for the help.

This is where one would search for known issues and file a bug report if the issue was not already reported:

I see no related open Arch bug reports for the package, so no help there. DO NOT file a bug report there unless you can reproduce it running Arch.

Thanks. Help was greatly appreciated.

Mine works here on xfce. I prefer freac, though.

I do not believe there’s anything wrong with soundconverter itself, but rather, it appears to be an issue with the KDE version of Manjaro, as this problem showed up after a recent Manjaro update, it had worked perfectly before, for a very long time. In fact, the latest (Sept 24) update of Manjaro introduced another problem. I have Firefox, Brave and Chromium installed, and while Firefox and Brave have continued to work without a problem after this latest update, Chromium now insists on never opening maximized, I have to maximize it manually each and every time. Oh, well, such is life. Thanks.

I am glad to say I have, myself, found a solution to this frustrating problem, Flatpak. I have now regained full use of soundconverter, if only by means of installing its Flatpak version.
Thanks to all who tried to help.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.