Soundcard not found (audio not working)

I have recently dualbooted manjaro with Windows 10 as the main OS. I am currently having a problem where the soundcard in Manjaro is not being detected.
So when I run the command sudo aplay -l I get the output: aplay: device_list:274: no soundcards found...

Would anyone happen to know why this is happening? I have tried updating to the new kernel 5.8 because I had seen that it worked for some people. However for my case nothing changed.

Can you post the output of inxi -Fx ?

  Host: sebastiano-vostro5590 Kernel: 5.8.0-2-MANJARO x86_64 bits: 64 
  compiler: N/A Desktop: KDE Plasma 5.19.4 Distro: Manjaro Linux 
  Type: Laptop System: Dell product: Vostro 5590 v: N/A 
  serial: <superuser/root required> 
  Mobo: Dell model: 051P23 v: A00 serial: <superuser/root required> 
  UEFI: Dell v: 1.5.1 date: 01/14/2020 
  ID-1: BAT0 charge: 39.4 Wh condition: 39.4/42.0 Wh (94%) 
  model: BYD DELL 1VX1H05 status: Full 
  Topology: Quad Core model: Intel Core i5-10210U bits: 64 type: MT MCP 
  arch: Kaby Lake rev: C L2 cache: 6144 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 33615 
  Speed: 700 MHz min/max: 400/4200 MHz Core speeds (MHz): 1: 700 2: 700 
  3: 700 4: 700 5: 700 6: 700 7: 700 8: 700 
  Device-1: Intel UHD Graphics vendor: Dell driver: i915 v: kernel 
  bus ID: 00:02.0 
  Device-2: Realtek Integrated_Webcam_HD type: USB driver: uvcvideo 
  bus ID: 1-6:3 
  Display: x11 server: X.Org 1.20.8 driver: intel unloaded: modesetting 
  resolution: 1920x1080~60Hz 
  OpenGL: renderer: Mesa Intel UHD Graphics (CML GT2) v: 4.6 Mesa 20.1.5 
  direct render: Yes 
  Device-1: Intel vendor: Dell driver: sof-audio-pci bus ID: 00:1f.3 
  Sound Server: ALSA v: k5.8.0-2-MANJARO 
  Device-1: Intel Wireless-AC 9462 driver: iwlwifi v: kernel port: 4000 
  bus ID: 00:14.3 
  IF: wlp0s20f3 state: up mac: 9c:fc:e8:1e:40:b5 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Dell driver: r8169 v: kernel port: 3000 bus ID: 01:00.0 
  IF: enp1s0 state: down mac: 70:b5:e8:8e:22:e2 
  Local Storage: total: 476.94 GiB used: 15.11 GiB (3.2%) 
  ID-1: /dev/nvme0n1 vendor: Toshiba 
  model: KBG40ZNS512G NVMe KIOXIA 512GB size: 476.94 GiB 
  ID-1: / size: 57.42 GiB used: 15.04 GiB (26.2%) fs: ext4 
  dev: /dev/nvme0n1p7 
  Alert: No Swap data was found. 
  System Temperatures: cpu: 40.0 C mobo: N/A 
  Fan Speeds (RPM): cpu: 0 
  Processes: 235 Uptime: 37m Memory: 7.56 GiB used: 2.48 GiB (32.8%) 
  Init: systemd Compilers: gcc: 10.1.0 Packages: 1232 Shell: Bash 
  v: 5.0.18 inxi: 3.1.05 

Here it is.

You could try to go back to kernel 5.4 or 4.19 and check if works with those.

Or you could look at this old forum post about the sof-firmware package since audio device is being detected.

1 Like

Thank you so much, what I did was first I installed and updated sof-firmware, it then detected the soundcard correctly. However it still wasn’t working.
Then I downgraded to kernel 5.4 and now it is working.
So to get it working I actually had to do both.

Thanks again :smiley:

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.