Soundblaster XG-6 Mic Sounds Faint?

I have an issue where I’m using my microphone (Takstar 3.5mm) plugged into the front microphone jack (or rear, both have the same behaviour) produce a weak signal (volume wise).

I can hear myself using a loopback interface (I’m on Manjaro KDE, and am monitoring / choosing input using amixer), but no matter what I do I still sound faint.

This is not the default volume of the microphone and when I plug the 3.5mm into the back of the motherboard, I can hear myself just fine at a reasonable volume.

Is there any way to resolve this and have the mic sound at a reasonable volume?

I recorded a short video on it showing more settings:

I checked the jack connections for this device. The rear jack is for Line In and not suitable for a microphone - SoundblasterX G6 back panel
use the front jack for the microphone

I suggest you first turn off audio capture in alsamixer for S/PDIF and Line In so they do not cause problems for the External Mic
Select the controls showing CAPTURE and use Space to turn capture off --------

The External Mic control for microphone monitoring is shown as muted [MM]
use M key to unmute this control so it shows [OO]
You should be able to hear the microphone audio in headphones

and then change PCM Capture from Line In to External Mic
That should get microphone audio working correctly in PulseAudio

Use this command to save the changes to ALSA settings

sudo alsactl store
1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.