Sound through HDMI suddenly stopped working without changes

I’m using manjaro with KDE Plasma and PipeWire. The sound output through HDMI suddenly stopped working, sound through internal speakers or Bluetooth device still works. I have not changed anything and not installed an update. It just happened. Correct output device is selected in KDE and shows visual feedback when sound is played. Rebooting doesn’t solve the issue.

Any ideas what could be the cause or where I could start looking?

What is the output of:
inxi -ACG

aplay -l

❯ inxi -ACG
  Info: dual core model: Intel Core i5-5300U bits: 64 type: MT MCP cache:
    L2: 512 KiB
  Speed (MHz): avg: 2376 min/max: 500/2900 cores: 1: 2394 2: 2340 3: 2659
    4: 2111
  Device-1: Intel HD Graphics 5500 driver: i915 v: kernel
  Device-2: Bison Integrated Camera driver: uvcvideo type: USB
  Display: x11 server: X.Org v: 21.1.10 with: Xwayland v: 23.2.3 driver: X:
    loaded: modesetting dri: iris gpu: i915 resolution: 1: 1920x1080~60Hz
    2: 1680x1050~60Hz 3: N/A
  API: EGL v: 1.5 drivers: iris,swrast platforms: gbm,x11,surfaceless,device
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: intel mesa v: 23.3.3-manjaro1.1
    renderer: Mesa Intel HD Graphics 5500 (BDW GT2)
  API: Vulkan v: 1.3.274 drivers: intel surfaces: xcb,xlib
  Device-1: Intel Broadwell-U Audio driver: snd_hda_intel
  Device-2: Intel Wildcat Point-LP High Definition Audio
    driver: snd_hda_intel
  API: ALSA v: k5.15.146-1-MANJARO status: kernel-api
  Server-1: PipeWire v: 1.0.0 status: active
❯ aplay -l
**** Liste der Hardware-Geräte (PLAYBACK) ****
Karte 0: HDMI [HDA Intel HDMI], Gerät 3: HDMI 0 [HDMI 0]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0
Karte 0: HDMI [HDA Intel HDMI], Gerät 7: HDMI 1 [24MB56]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0
Karte 0: HDMI [HDA Intel HDMI], Gerät 8: HDMI 2 [HDMI 2]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0
Karte 0: HDMI [HDA Intel HDMI], Gerät 9: HDMI 3 [HDMI 3]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0
Karte 0: HDMI [HDA Intel HDMI], Gerät 10: HDMI 4 [HDMI 4]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0
Karte 1: PCH [HDA Intel PCH], Gerät 0: ALC3232 Analog [ALC3232 Analog]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0

Reboot your device/monitor connected to your HDMI port, and type:

aplay -D plughw:0,x /usr/share/sounds/alsa/Front_Center.wav

you replace x with one of 3, 7, 8, 9, 10, and check if you hear any sound.

Wow, that worked, I had to disconnect the power to the monitor though.

Before that I had tested with another computer that is also connected to the monitor via an HDMI switch, which is also the reason I connected my speakers to the monitor, but I never thought to turn off the monitor. I don’t understand why it makes a difference, but I’m just happy it’s working again.

Thank you, that was an easy solution.

I just gave you the instructions written on this Arch wiki, and the cause of your problem is:

If aplay does not output any errors, but still no sound is heard, “reboot” the receiver, monitor or tv set. Since the HDMI interface executes a handshake on connection, it might have noticed before that there was no audio stream embedded, and disabled audio decoding.

You can go further and set your HDMI as default by adding/editing config file ~/.asoundrc, but you need to revert the change when you unplug your external HDMI device/monitor.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.