Sound settings not persisting after reboot

Hello everybody,
I am new to Manjaro linux and i am encountering a strange issue:

I am using DAC trough optical and if no sound is playing on my computer it does not send a keep alive signal and the DAC will turn off after a period of time.

In order to stop this i edited the /sys/module/snd_hda_intel/parameters/power_save profile and set the default value to 0.
This works and my DAC will no longer turn off if after a period of time with no sound playing on the computer.
However after reboot or power-off the setting in that file returns to its default value of 10 and this will get the DAC to turn off if no sound is playing for 2 mins.

How do i get that setting to persist ?

Welcome to Manjaro forum @eradokir

To disable power saving mode for snd_hda_intel

echo 'options snd_hda_intel power_save=0' | sudo tee /etc/modprobe.d/alsa-power.conf

Advanced Linux Sound Architecture/Troubleshooting/Pops when starting and stopping playback - ArchWiki

It worked it persists after reboot

This was very annoying to address at each boot. :sunglasses:

Thank you!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.