Sound problems with Wine games

Good day.
I have several sound issues, that were not there before, when running certain video games. Everything was fine until a few weeks ago.
The problem is only related to programs using Wine.
I have used Lutris (Official and Flatpak) and also WineStaging directly, but the issues persist.

MIDI music does not play anymore in old games.
Some games have stuttering sound now.
Some games have delayed sound now.
Some games still run fine.

Here is my system info:

  Kernel: 5.15.114-2-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.1.1
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=7c28e640-9553-4d2b-9929-3e9fba851c0a rw quiet apparmor=1
    security=apparmor udev.log_priority=3
  Desktop: KDE Plasma v: 5.27.5 tk: Qt v: 5.15.9 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: Acer product: Aspire A315-53 v: V1.19
    serial: <superuser required>
  Mobo: KBL model: Metapod_KL v: V1.19 serial: <superuser required>
    UEFI: Insyde v: 1.19 date: 04/24/2018
  ID-1: BAT1 charge: 24.1 Wh (100.0%) condition: 24.1/37.0 Wh (65.2%)
    volts: 8.2 min: 7.7 model: PANASONIC 004A354D36315041 type: Li-ion
    serial: <filter> status: full
  Info: model: Intel Core i5-7200U bits: 64 type: MT MCP arch: Amber/Kaby Lake
    note: check gen: core 7 level: v3 note: check built: 2017 process: Intel 14nm
    family: 6 model-id: 0x8E (142) stepping: 9 microcode: 0xF2
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 3 MiB desc: 1x3 MiB
  Speed (MHz): avg: 700 min/max: 400/3100 scaling: driver: intel_pstate
    governor: powersave cores: 1: 700 2: 700 3: 700 4: 700 bogomips: 21607
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
  Type: retbleed mitigation: IBRS
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl and seccomp
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: IBRS, IBPB: conditional, STIBP: conditional,
    RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel HD Graphics 620 vendor: Acer Incorporated ALI driver: i915
    v: kernel arch: Gen-9.5 process: Intel 14nm built: 2016-20 ports:
    active: eDP-1 empty: HDMI-A-1 bus-ID: 00:02.0 chip-ID: 8086:5916
    class-ID: 0300
  Device-2: Quanta VGA WebCam driver: uvcvideo type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-7:4 chip-ID: 0408:a031
    class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.1
    compositor: kwin_x11 driver: X: loaded: modesetting alternate: fbdev,vesa
    dri: iris gpu: i915 display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1366x768 s-dpi: 97 s-size: 358x201mm (14.09x7.91")
    s-diag: 411mm (16.16")
  Monitor-1: eDP-1 model: BOE Display 0x0672 built: 2015 res: 1366x768 hz: 60
    dpi: 101 gamma: 1.2 size: 344x194mm (13.54x7.64") diag: 395mm (15.5")
    ratio: 16:9 modes: 1366x768
  API: OpenGL v: 4.6 Mesa 23.0.4 renderer: Mesa Intel HD Graphics 620 (KBL
    GT2) direct-render: Yes
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Acer Incorporated ALI
    driver: snd_hda_intel v: kernel alternate: snd_soc_skl bus-ID: 00:1f.3
    chip-ID: 8086:9d71 class-ID: 0403
  API: ALSA v: k5.15.114-2-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
  Server-2: JACK v: 1.9.22 status: off tools: N/A
  Server-3: PipeWire v: 0.3.70 status: off with: pipewire-media-session
    status: active tools: pw-cli
  Server-4: PulseAudio v: 16.1 status: active with: pulseaudio-alsa
    type: plugin tools: pacat,pactl
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Acer Incorporated ALI driver: r8169 v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: 3000 bus-ID: 01:00.1 chip-ID: 10ec:8168
    class-ID: 0200
  IF: enp1s0f1 state: up speed: 10 Mbps duplex: full mac: <filter>
  Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter
    vendor: Lite-On driver: ath10k_pci v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 bus-ID: 02:00.0 chip-ID: 168c:0042 class-ID: 0280
  IF: wlp2s0 state: up mac: <filter>
  Device-1: Lite-On Qualcomm Atheros QCA9377 Bluetooth driver: btusb v: 0.8
    type: USB rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-5:3
    chip-ID: 04ca:3015 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
  Local Storage: total: 447.13 GiB used: 242.98 GiB (54.3%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: KingMAX model: SSD 480GB
    size: 447.13 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    tech: SSD serial: <filter> fw-rev: 63 scheme: GPT
  ID-1: / raw-size: 446.83 GiB size: 438.75 GiB (98.19%)
    used: 242.98 GiB (55.4%) fs: ext4 dev: /dev/sda2 maj-min: 8:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 288 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1
  Alert: No swap data was found.
  System Temperatures: cpu: 48.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 231 Uptime: 2h 6m wakeups: 1 Memory: available: 11.57 GiB
  used: 4.66 GiB (40.3%) Init: systemd v: 253 default: graphical
  tool: systemctl Compilers: gcc: 13.1.1 clang: 15.0.7 Packages: 1944
  pm: pacman pkgs: 1921 libs: 480 tools: pamac pm: flatpak pkgs: 14 pm: snap
  pkgs: 9 Shell: Zsh v: 5.9 default: Bash v: 5.1.16 running-in: konsole
  inxi: 3.3.27

What can I do to have the sound functioning normally again?

Try older wine or proton versions.

Maybe reduce pulseaudio latency in lutris?

I tried your suggestions, but nothing seems to change.

Then give us examples…

  1. What game?
  2. What MIDI music?

I merely think there needs to be some native library, instead of the builtin one, but that has to be investigated.

Maybe something what can be tested without buying.

I switch the category to Gaming since this issue is not a general sound problem.

Concerning the MIDI music:
I run Duke 3d with Build GDX. The music used to work, but no longer does.
Also, the music for System Shock Enhanced Edition does not play.

Concerning the stuttering:
AvP 2 has some strange stuttering now. It used to run fine.
I Have No Mouth And I Must Scream’s sound also stutters severely all of a sudden when run through Wine.

Concerning the lag:
The Enhanced Editions of Baldur’s Gate, Icewind Dale and Planescape Torment all have about a .5 second lag on sound effects now, which they didn’t have.

Games with no sound:
Prey (2006) no longer has sound.

Outcast 1.1 also has issues with its music. Sometimes it plays with severe distortion, other times it doesn’t play at all. When I installed Outcast months ago, the sound and music worked fine after I installed LAVfilter for it.

Everything used to be fine, but I started noticing these issues over the past couple of weeks.
Most other games appear to be fine so far…

I am having a similar problem with System Shock: Enhanced Edition. I have been working with Timidity++ and Fluidsynth trying to make sure they work and stumbled upon your post. Does other sound in your games work? In SS:EE the sound effects and voice logs work but the music won’t play.

Yes. Everything works except music.
Same with Duke 3d and Shadow Warrior Classic

Have you tried running Fluidsynth as a Daemon? You could also try doing the same thing with Timidity++ depending on which one you have installed.

I figured out how to get Fluidsynth working properly and it fixed my sound issues with System Shock: Enhanced Edition.

Thank you I will see if that works.

The thing that just boggles me is the fact that MIDI worked fine until a month or so ago.