Sound only if headphones are half plugged in, work fine in windows

Hello guys I’ve installed Manjaro and have been having plenty of issues with the sound. I was hoping someone could help me out.

Timeline of my issues:

  • No sound whatsoever, asked for help in the discord and they tried a lot of things with me but nothing work

  • Eventually got my razer kraken to work by changing from the default channel 2 to channel 4 in alsamixer. This meant that my mic stopped working but I was fine with that screw it.

  • Installed windows (disabled fast boot) and now sound only works if I half plug-in my headset jack. Keep in mind that it works fine in windows so I’m sure it’s not the headset itself. I’ve also tried with a different kernel and that didn’t work.

I am using a razer kraken headset with a headphone mic splitter. Pavucontrol detects it and shows output when I play something. I also have an HDMI monitor, I suspect that might be the problem but I’m not sure.

void@Void~> inxi -A 19:54:18
Audio: Device-1: Intel 200 Series PCH HD Audio driver: snd_hda_intel
Device-2: NVIDIA GP106 High Definition Audio driver: snd_hda_intel
Sound Server: ALSA v: k5.9.11-3-MANJARO

void@Void~> sudo dmesg | grep snd 19:44:43
[sudo] password for void:
[ 7.974780] snd_hda_intel 0000:00:1f.3: enabling device (0000 -> 0002)
[ 7.975381] snd_hda_intel 0000:01:00.1: Disabling MSI
[ 7.975387] snd_hda_intel 0000:01:00.1: Handle vga_switcheroo audio client
[ 8.143115] snd_hda_codec_realtek hdaudioC0D1: autoconfig for ALC891: line_outs=1 (0x21/0x0/0x0/0x0/0x0) type:line
[ 8.143118] snd_hda_codec_realtek hdaudioC0D1: speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[ 8.143121] snd_hda_codec_realtek hdaudioC0D1: hp_outs=1 (0x17/0x0/0x0/0x0/0x0)
[ 8.143123] snd_hda_codec_realtek hdaudioC0D1: mono: mono_out=0x0
[ 8.143124] snd_hda_codec_realtek hdaudioC0D1: inputs:
[ 8.143126] snd_hda_codec_realtek hdaudioC0D1: Rear Mic=0x18
[ 8.143129] snd_hda_codec_realtek hdaudioC0D1: Front Mic=0x19
[ 8.143131] snd_hda_codec_realtek hdaudioC0D1: Line=0x16
[ 40.509305] snd_hda_codec_hdmi hdaudioC1D0: HDMI: invalid ELD data byte 32

void@Void~> systemctl --user status pulseaudio.service 20:00:45
● pulseaudio.service - Sound Service
Loaded: loaded (/usr/lib/systemd/user/pulseaudio.service; disabled; vendor preset: enabled)
Active: active (running) since Sat 2020-12-19 19:44:41 EET; 16min ago
TriggeredBy: ● pulseaudio.socket
Main PID: 3661 (pulseaudio)
CGroup: /user.slice/user-1000.slice/user@1000.service/pulseaudio.service
├─3661 /usr/bin/pulseaudio --daemonize=no --log-target=journal
└─3665 /usr/lib/pulse/gsettings-helper

Dec 19 19:44:40 Void systemd[837]: Starting Sound Service…
Dec 19 19:44:41 Void systemd[837]: Started Sound Service.

void@Void~> pacmd dump 20:01:19
Configuration dump generated at Sat Dec 19 20:01:22 2020
load-module module-device-restore
load-module module-stream-restore
load-module module-card-restore
load-module module-augment-properties
load-module module-switch-on-port-available
load-module module-udev-detect
load-module module-alsa-card device_id=“1” name=“pci-0000_01_00.1” card_name=“alsa_card.pci-0000_01_00.1” namereg_fail=false tsched=yes fixed_latency_range=no ignore_dB=no deferred_volume=yes use_ucm=yes avoid_resampling=no card_properties=“module-udev-detect.discovered=1”
load-module module-alsa-card device_id=“0” name=“pci-0000_00_1f.3” card_name=“alsa_card.pci-0000_00_1f.3” namereg_fail=false tsched=yes fixed_latency_range=no ignore_dB=no deferred_volume=yes use_ucm=yes avoid_resampling=no card_properties=“module-udev-detect.discovered=1”
load-module module-jackdbus-detect channels=2
load-module module-dbus-protocol
load-module module-native-protocol-unix
load-module module-gsettings
load-module module-default-device-restore
load-module module-always-sink
load-module module-intended-roles
load-module module-suspend-on-idle
load-module module-console-kit
load-module module-systemd-login
load-module module-position-event-sounds
load-module module-role-cork
load-module module-filter-heuristics
load-module module-filter-apply
load-module module-cli-protocol-unix
set-sink-volume alsa_output.pci-0000_01_00.1.hdmi-stereo-extra1 0x10000
set-sink-mute alsa_output.pci-0000_01_00.1.hdmi-stereo-extra1 no
suspend-sink alsa_output.pci-0000_01_00.1.hdmi-stereo-extra1 yes
set-sink-volume alsa_output.pci-0000_00_1f.3.analog-stereo 0x10000
set-sink-mute alsa_output.pci-0000_00_1f.3.analog-stereo no
suspend-sink alsa_output.pci-0000_00_1f.3.analog-stereo yes
set-source-volume alsa_output.pci-0000_01_00.1.hdmi-stereo-extra1.monitor 0x10000
set-source-mute alsa_output.pci-0000_01_00.1.hdmi-stereo-extra1.monitor no
suspend-source alsa_output.pci-0000_01_00.1.hdmi-stereo-extra1.monitor yes
set-source-volume alsa_output.pci-0000_00_1f.3.analog-stereo.monitor 0x10000
set-source-mute alsa_output.pci-0000_00_1f.3.analog-stereo.monitor no
suspend-source alsa_output.pci-0000_00_1f.3.analog-stereo.monitor yes
set-source-volume alsa_input.pci-0000_00_1f.3.analog-stereo 0x10004
set-source-mute alsa_input.pci-0000_00_1f.3.analog-stereo no
suspend-source alsa_input.pci-0000_00_1f.3.analog-stereo yes
set-card-profile alsa_card.pci-0000_01_00.1 output:hdmi-stereo-extra1
set-card-profile alsa_card.pci-0000_00_1f.3 output:analog-stereo+input:analog-stereo
set-default-sink alsa_output.pci-0000_00_1f.3.analog-stereo
set-default-source alsa_input.pci-0000_00_1f.3.analog-stereo

Thank you so much for your time in advance to anyone who can help me get sound and my mic working. I appreciate it.

I also have an HDMI monitor, I suspect that might be the problem but I’m not sure

pacmd dump data shows that HDMI output is turned on
set-card-profile alsa_card.pci-0000_01_00.1 output:hdmi-stereo-extra1
If your monitor does not have built-in speakers or headphone jack, or you are not using HDMI for audio playback, you should change the PulseAudio Profile for the audio device to turn it off so audio cannot be mis-directed

pacmd set-card-profile alsa_card.pci-0000_01_00.1 Off

most likely cause of this problem is that the headset splitter cable is using the wrong TRRS wiring standard
see this previous post which has a diagram to show the 2 different wiring standards
Headphone Microphone Not Detected

Your headset is probably using OMTP wiring standard, based on the small print contradiction on the Razer website

Razer Kraken - Black | Audio
The Razer Kraken is compatible with PC, Mac, Xbox One*, PS4, Nintendo Switch and mobile devices with a 3.5mm audio jack.
*Xbox One Stereo Adapter may be required, purchased separately

If an adaptor cable is needed for an Xbox One (that has a CTIA jack) the headset jack is probably using OMTP standard;, the adaptor cable is probably using CTIA standard
If the jack is partially plugged in the headphone connections can line up with the connections within the jack socket, but the microphone is always wired the wrong way round and cannot work

you could either change the CTIA adaptor cable for an OMTP cable, or get a CTIA/OMTP adaptor