Sound not working


My computer turned off for no reason yesterday and now the sound does not work at all. The default sound card on alsamixer has become “Loopback” and the only other option is Intel. Switching to Intel card doesn’t restore the sound either, I believe this is for the HDMI port. I am pretty sure I have a realtek card on my laptop but it does not show up in alsamixer.
This is my output after running

I have acer Aspire E5-771G and in my alsa-info.txt first difference is in “Sound Servers on this system” secction, i have this:

 !!Sound Servers on this system

    Installed - Yes (/usr/bin/pulseaudio)
    Running - Yes

    Installed - Yes (/usr/bin/jackd)
    Running - No

!!Soundcards recognised by ALSA

 0 [HDMI           ]: HDA-Intel - HDA Intel HDMI
                      HDA Intel HDMI at 0xb3710000 irq 49
 1 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xb3714000 irq 50

In your log seems like alsa-info not detects pulseaudio.

Loopback connections have taken default position as card 0
Onboard audio device is now card 1

**** List of PLAYBACK Hardware Devices ****

card 1: PCH [HDA Intel PCH], device 0: ALC255 Analog [ALC255 Analog]

(card 1 also has additional devices listed for HDMI audio)

Most of the the audio controls appear to be OK but the Master control is shown as muted [off]

Simple mixer control 'Master',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 87
  Mono: Playback 81 [93%] [-4.50dB] [off]

suggest you go to ALSA controls

alsamixer --card=1

if Master control is shown as muted [MM] Press M to unmute it [OO]

then exit alsamixer and save ALSA settings

sudo alsactl store

If you want to remove the ALSA Loopback connections use this

sudo modprobe -r snd-aloop
1 Like

Thank you for reply. The issue like you pointed out was that loopback became card 0 and all my applications were trying to use the default card. I tried to set the intel card as 0 and the loopback card as 1 as mentioned in this archwiki article.
That fixed it. :smiley:

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.