Sound not working after upgrade

Pulseaudio works on my system, but I have to reload it manually.

Same here.I suspect some race condition.

  • No sound devices after logging in (sddm/Plasma) in 9 out of 10 times.
  • Changed my session options in KDE to start with clean session instead of saved one. No change
  • Manually issuing ‘pulseaudio -k’ gets things to work.
  • Added a new testing user with default settings. The issue appears to happen less often (50% of the time)

As a workaround i added a sesssion startup script with ‘pulseaudio -k’ which makes things work 98% of the time, but even that fails in rare cases. I’m using preload (if that’s relevant)

1 Like

I do too, with an script added to “startup applications”:

sleep 5
pulseaudio -k
pulseaudio --start

Does fix it for a few times, but after some reboot, curiously pulseaudio stop working and does not recognize any audio chipset. I don’t know what to think.

1 Like

Facing the same issue after the latest upgrade, with MSI B450 Tomahawk, as the others mentioned. Using i3 with KDE (and sddm).

Had to restart pulseaudio, go to pavucontrol --tab 5 to enable the ‘Starship/Matisse HD Audio Controller’ and then choose it as the output device for sound to work. The extra steps were likely needed because there’s an extra audio controller from my graphics card, which got selected as main when the mobo one was not found.


@j00jitsu Another B450 Tomahawk user with this issue, very interesting. I have not had any issues with this motherboard prior to the update.

I did fresh installs of Pop!_OS, Kubuntu, and Fedora and the sound works fine on those distros with the latest updates. Pop and Kubuntu are running kernel 5.4 and Fedora was 5.7/5.8 I believe so those kernels all work fine in other distros.

I’ll be testing EndeavourOS today to see if it works.

I believe Pipwire is still working through it’s initial stages of development. Not certain what that error means.

pulseaudio -k didn’t work for me.

not sure about this MSI motherboard, but i recall that B450 motherboards had issues
and i do not think a solution found on old forum

search on bugzilla found this open bug report
Bug 195303 - AMD HD-audio controller: Sound capture is crackled / distorted

it appears that problems with this audio codec have not been resolved yet

I downgraded to kernel 4.19 and sound is working

if audio is working ok, suggest getting ALSA data with which could then be compared data from a non-working ALSA

but the ALSA data posted for kernel v5.4 is not showing any problems that i can see

suggest check for any error messages

sudo dmesg | grep snd


pacmd dump

to check pulseaudio

pulseaudio -k may appear to restart pulseaudio ok, but it will break some pulseaudio functions

  • the systemd pulseaudio.service may fail
  • some of the pulseaudio modules will not get re-loaded correctly
  • GUI controls in KDE may not work (because pulseaudio does not have module-device-manger loaded)
  • network audio device may not work (because two X11 modules are not loaded)
  • audio devices may get muted or suspended

suggest use this command to check if pulseaudio is ok

systemctl --user --full --no-pager status pulseaudio.{socket,service} 

and this to restart pulseaudio

systemctl --user restart pulseaudio

pulseaudio -k
pulseaudio --start

That’s redundant and does more bad than good.
The -k option does restart automatically. I’d try without the second line.

And BTW i have a B450 MoBo, too, so this seems chipset related

1 Like

In the “old” forum (sadly, the posts seem to have been deleted/privated), one solution would be to delete pulseaudios cache. I might need a refresher on path, but I do believe it was ~/.config/pulse/** or ~/.pulse. It had caused trouble in the past upgrade.

I had the same problem now – then I realized my headset was just unplugged because I had tripped on the cord.

1 Like

Tried deleting the cache already. No effect.

BTW, i’m new to Manjaro/Arch-based distros but babysit Redhat and Debian machines for a living. Could offer some qualified strace output or other debugging if a guinea pig is required.

I tested pulseaudio -k and it worked, but every time I turn on the PC I have to run the command, I thought it was wrong for the manjaro people to update the packages without knowing if they were without problems


Using KDE, I had the same issues after the update. Was on kernel 56 (Previously 54) updated to kernel 57. MSI Tomahawk (non-max) with latest BIOS.

My GUI audio settings were scrambled after the update and I had no sound output, I use speakers and USB headphones.

‘systemctl --user restart pulseaudio’ allowed me to change settings and recognise speakers and headphones. Fails to remember settings.

I can configure my stereo speakers to work but USB headphones appear only to work in the right ear. That might be a HW issue, so I’m to test them. I had no issues with Kernel 54/56 and associated updates previously.

I did a little distrohopping too, before more or less landing on Manjaro (Linux Mint, Solus, Ubuntu, Kubuntu probably a couple others). I used Manjaro XFCE before deciding I wanted a bit more customization that KDE offers. Never any sound issues before now. I still have to use Windows some for MS Office anyway, so I’ll just stick with that until this gets fixed.

1 Like

so there is still no solution but to run pulseaudio -k every time you restart the system?

The solution for snd-hda-intel:

Open /etc/modprobe.d/alsa-base.conf and add the following line at the end:

options snd-hda-intel dmic_detect=0

pulseaudio -k && sudo alsa force-reload

I switched to EndeavourOS yesterday and the sound works great on kernel 5.4, 5.7, and 5.8 so this is a Manjaro issue. It doesn’t look like there is a fix so I’m sticking with Endeavour for now. It’s pretty much the same as Manjaro since it’s based on Arch but updates come regularly rather than lump updates. Manjaro is still a great distro but this update didn’t go well.

1 Like

that may be due to

KDE audio controls not saving user settings in home folder databases

suggest install pavucontrol-qt to change audio settings as this is more likely to sucessfully update user preferences in databases
may only need to use it one time to force database refresh as sometimes the usual GUI controls start working again


I was affected by the same issue. My motherboard is:

Base Board Information
        Manufacturer: Micro-Star International Co., Ltd.
        Product Name: Z390-A PRO (MS-7B98)

I can confirm the above workaround works after a reboot: just install pavucontrol-qt and no additional actions needed. However, there should be a proper patch for this in the next update imo.

Thanks, @nikgnomic!

1 Like

I’m using the script previosly mentioned and that works for now. Anyway is a “patch” measure, by whyle we wait a finally fix.