Sound not working after updating

Hi, I dual booted manjaro 20.1 in my asus laptop along windows 10. After installing i updated drivers and all using package manager (it displayed 200+ updates available and i applied the changes) .
Now my sound is not working even if i connect headset to 3.5mm jack its not detected. I am able to increase/decrease volume using keyboard but ther is no sound coming from my system.

this is the output of aplay -l command

card 0: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 8: HDMI 2 [HDMI 2]
 Subdevices: 1/1
 Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 9: HDMI 3 [HDMI 3]
 Subdevices: 1/1
 Subdevice #0: subdevice #0


1 Like

Only audio devices shown is for HDMI audio
no device is shown for onboard analog audio to speakers or headphones

Please post system information

inxi -Fazy

and this to show any error messages from audio devices

sudo dmesg | grep -E 'snd|sof'
1 Like

this is the output of inxi -Fazy

  Kernel: 5.8.18-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.8-x86_64 
  root=UUID=58b69609-f67c-4b30-995e-936481c5b245 rw quiet apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: GNOME 3.38.1 tk: GTK 3.24.23 wm: gnome-shell dm: GDM 3.38.1 
  Distro: Manjaro Linux 
  Type: Laptop System: ASUSTeK product: TUF Gaming FX505GT_FX505GT v: 1.0 
  serial: <filter> 
  Mobo: ASUSTeK model: FX505GT v: 1.0 serial: <filter> 
  UEFI: American Megatrends v: FX505GT.309 date: 11/06/2020 
  ID-1: BAT0 charge: 20.5 Wh condition: 43.5/48.1 Wh (90%) volts: 10.9/11.7 
  model: Simplo SDI ICR18650 type: Li-ion serial: <filter> status: Discharging 
  cycles: 41 
  Info: Quad Core model: Intel Core i5-9300H bits: 64 type: MT MCP 
  arch: Kaby Lake family: 6 model-id: 9E (158) stepping: A (10) microcode: D6 
  L2 cache: 8192 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 38408 
  Speed: 900 MHz min/max: 800/2400 MHz Core speeds (MHz): 1: 900 2: 900 3: 900 
  4: 900 5: 900 6: 900 7: 900 8: 900 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel UHD Graphics 630 vendor: ASUSTeK driver: i915 v: kernel 
  bus ID: 00:02.0 chip ID: 8086:3e9b 
  Device-2: NVIDIA TU117M [GeForce GTX 1650 Mobile / Max-Q] vendor: ASUSTeK 
  driver: nouveau v: kernel bus ID: 01:00.0 chip ID: 10de:1f91 
  Device-3: IMC Networks USB2.0 HD UVC WebCam type: USB driver: uvcvideo 
  bus ID: 1-11:3 chip ID: 13d3:56a2 serial: <filter> 
  Display: wayland server: 1.20.9 compositor: gnome-shell 
  driver: nouveau note: display driver n/a - try sudo/root display ID: 0 
  resolution: <xdpyinfo missing> 
  OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa 20.2.1 
  direct render: Yes 
  Device-1: Intel Cannon Lake PCH cAVS vendor: ASUSTeK driver: sof-audio-pci 
  alternate: snd_hda_intel,snd_soc_skl,snd_sof_pci bus ID: 00:1f.3 
  chip ID: 8086:a348 
  Device-2: NVIDIA vendor: ASUSTeK driver: snd_hda_intel v: kernel 
  bus ID: 01:00.1 chip ID: 10de:10fa 
  Sound Server: ALSA v: k5.8.18-1-MANJARO 
  Device-1: Intel Wireless-AC 9560 [Jefferson Peak] driver: iwlwifi v: kernel 
  port: 5000 bus ID: 00:14.3 chip ID: 8086:a370 
  IF: wlo1 state: up mac: <filter> 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: ASUSTeK driver: r8169 v: kernel port: 3000 bus ID: 03:00.0 
  chip ID: 10ec:8168 
  IF: enp3s0 state: down mac: <filter> 
  Local Storage: total: 476.94 GiB used: 9.74 GiB (2.0%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/nvme0n1 vendor: Intel model: SSDPEKNW512G8 size: 476.94 GiB 
  block size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 
  serial: <filter> rev: 002C scheme: GPT 
  ID-1: / raw size: 44.54 GiB size: 43.59 GiB (97.87%) used: 9.70 GiB (22.3%) 
  fs: ext4 dev: /dev/nvme0n1p6 
  Alert: No Swap data was found. 
  System Temperatures: cpu: 46.0 C mobo: 27.8 C gpu: nouveau temp: 38.0 C 
  Fan Speeds (RPM): cpu: 2300 
  Processes: 271 Uptime: 1m Memory: 7.63 GiB used: 1.14 GiB (15.0%) 
  Init: systemd v: 246 Compilers: gcc: N/A Packages: pacman: 1243 lib: 354 
  flatpak: 0 Shell: Zsh v: 5.8 running in: gnome-terminal inxi: 3.1.08 

and output for sudo dmesg | grep -E 'snd|sof'

[    0.890551] PCI-DMA: Using software bounce buffering for IO (SWIOTLB)
[    0.890556] software IO TLB: mapped [mem 0x70dd4000-0x74dd4000] (64MB)
[    3.434590] snd_hda_intel 0000:00:1f.3: DSP detected with PCI class/subclass/prog-if info 0x040380
[    3.434596] snd_hda_intel 0000:00:1f.3: Digital mics found on Skylake+ platform, using SOF driver
[    3.434835] snd_hda_intel 0000:01:00.1: Disabling MSI
[    3.434843] snd_hda_intel 0000:01:00.1: Handle vga_switcheroo audio client
[    3.822370] snd_soc_skl 0000:00:1f.3: DSP detected with PCI class/subclass/prog-if info 0x040380
[    3.822375] snd_soc_skl 0000:00:1f.3: Digital mics found on Skylake+ platform, using SOF driver
[    3.870549] snd_hda_intel 0000:01:00.1: bound 0000:01:00.0 (ops nv50_audio_component_bind_ops [nouveau])
[    4.105319] sof-audio-pci 0000:00:1f.3: DSP detected with PCI class/subclass/prog-if info 0x040380
[    4.105329] sof-audio-pci 0000:00:1f.3: Digital mics found on Skylake+ platform, using SOF driver
[    4.106032] sof-audio-pci 0000:00:1f.3: DSP detected with PCI class/subclass/prog-if 0x040380
[    4.106427] sof-audio-pci 0000:00:1f.3: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
[    4.115146] sof-audio-pci 0000:00:1f.3: use msi interrupt mode
[    4.244679] sof-audio-pci 0000:00:1f.3: hda codecs found, mask 5
[    4.244686] sof-audio-pci 0000:00:1f.3: using HDA machine driver skl_hda_dsp_generic now
[    4.244699] sof-audio-pci 0000:00:1f.3: DMICs detected in NHLT tables: 4
[    4.244960] sof-audio-pci 0000:00:1f.3: Direct firmware load for intel/sof/sof-cfl.ri failed with error -2
[    4.244967] sof-audio-pci 0000:00:1f.3: error: request firmware intel/sof/sof-cfl.ri failed err: -2
[    4.244971] sof-audio-pci 0000:00:1f.3: error: failed to load DSP firmware -2
[    4.245971] sof-audio-pci 0000:00:1f.3: error: sof_probe_work failed err: -2

Kernel: 5.8.18 has been marked End Of Life so suggest you update to kernel v5.9

Suggest you install kernel using Manjaro Settings Manager
manjaro-settings-manager -m msm_kernel

reboot system to load the new kernel and check if audio is working without error messages

If it is still not working please get more ALSA information about audio devices --upload
1 Like


I have updated kernel to 5.9.1-1-rt19 . But still there is no change.

here is the link to ALSA information , i’m unable to post lins in comment so i’m modifying the link to not look like a link. sorry.


There are 2 previous posts on here about the same model laptop
Just installed Manjaro and no sound at all
No sound in Manjaro GNOME

The ALSA data from 2nd discussion is showing OP has the correct ALSA modules loaded to detect both HDMI and onboard audio devices recognised

!!Loaded ALSA modules

!!Soundcards recognised by ALSA

 0 [NVidia         ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xa4080000 irq 17
 1 [sofhdadsp      ]: sof-hda-dsp - sof-hda-dsp

But your latest alsa-info data is still not showing only HDMI audio device is recognised

and some of the sof-firmware modules appear to be missing from !!All Loaded Modules


I suggest you install (or reinstall) sof-firmware

pamac install sof-firmware

and check dmesg and alsa-info again if onboard audio is not being detected

1 Like

@nikgnomic it worked. Now i am getting sound in my laptop. But it is recognised as Headphones (When i adjust volume it is displaying headphones) and so the sound is very low.
There is still some driver mismatch or something happening i guess.

Anyways your answer helped thanks.


Changed sound device in settings. it is working perfectly now. Thanks for all the help… :slight_smile:

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.