Sound Not working after Update

Hello, I installed Manjaro recently on my Thinkpad X1 tablet Gen 3, and everything worked out of the box, even removable keyboard, touchscreen and tablet stuff.
Although, I updated some packages (there were 175 updates so I don’t have list sorry --’ ), and now, the sound does not work anymore (both with internal speakers and jack earphones). I’d also mention that when it was working, when I used Gnome Xorg, sound didn’t work (but it was okay with Gnome and Gnome Classique). Also, I have a another partition on my disc with Windows, and sound is working fine there even now.

I’ve searched for similar issues on the internet, found and tried these (sorry I ca’n’t include URLs):

  • Disable Pipewire to prevent conflict → It was already disabled and everything seems in order — in topic /no-sound-maybe-update-installed-new-soundcard-still-dont-work/80340
  • Verifiy Pulseaudio’s state and other associated fix described in the thread → it’s Active and running fine (audio level even shows in the pavucontrol when sound plays, and it knows when I plug or unplug my jack earphones, saying it outputs ont the proper device) — in topic /manjaro-sound-not-working-after-update/67448

So I don’t really konw what to do, I’m not really good with Linux I must say, and I’m kind of lost and confused. Thank you for your help !

  Host: SCOPNgin Kernel: 5.15.21-1-MANJARO x86_64 bits: 64
    Desktop: GNOME 41.3 Distro: Manjaro Linux
  Type: Detachable System: LENOVO product: 20KKS1L100
    v: ThinkPad X1 Tablet Gen 3 serial: <superuser required>
  Mobo: LENOVO model: 20KKS1L100 v: SDK0J40697 WIN
    serial: <superuser required> UEFI: LENOVO v: N1ZET65W(1.21 )
    date: 06/06/2018
  ID-1: BAT0 charge: 26.8 Wh (81.7%) condition: 32.8/42.0 Wh (78.0%)
    volts: 8.1 min: 7.7
  Info: quad core model: Intel Core i5-8350U bits: 64 type: MT MCP cache:
    L2: 1024 KiB
  Speed (MHz): avg: 700 min/max: 400/3600 cores: 1: 700 2: 700 3: 700
    4: 700 5: 700 6: 700 7: 700 8: 700
  Device-1: Intel UHD Graphics 620 driver: i915 v: kernel
  Device-2: Lite-On Integrated Camera type: USB driver: uvcvideo
  Display: wayland server: driver: loaded: modesetting
    resolution: <missing: xdpyinfo>
  Message: Unable to show advanced data. Required tool glxinfo missing.
  Device-1: Intel Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor Imaging
    driver: ipu3-imgu
  Device-2: Intel CSI-2 Host driver: ipu3-cio2
  Device-3: Intel Sunrise Point-LP HD Audio driver: snd_hda_intel
  Sound Server-1: ALSA v: k5.15.21-1-MANJARO running: yes
  Sound Server-2: PulseAudio v: 15.0 running: yes
  Device-1: Intel Wireless 8265 / 8275 driver: iwlwifi
  IF: wlp4s0 state: up mac: a0:a4:c5:0e:f0:42
  Device-1: Intel Bluetooth wireless interface type: USB driver: btusb
  Report: rfkill ID: hci0 state: up address: see --recommends
  Local Storage: total: 476.77 GiB used: 97.14 GiB (20.4%)
  ID-1: /dev/mmcblk0 model: SD256 size: 238.3 GiB
  ID-2: /dev/sda vendor: Samsung model: MZNLN256HAJQ-000L7 size: 238.47 GiB
  ID-1: / size: 77.48 GiB used: 18.93 GiB (24.4%) fs: ext4 dev: /dev/sda5
  ID-2: /boot/efi size: 96 MiB used: 25.6 MiB (26.6%) fs: vfat
    dev: /dev/sda1
  Alert: No swap data was found.
  System Temperatures: cpu: 32.0 C pch: 35.5 C mobo: N/A
  Fan Speeds (RPM): fan-1: 0
  Processes: 267 Uptime: 28m Memory: 7.52 GiB used: 3.7 GiB (49.2%)
  Shell: Zsh inxi: 3.3.12

I have a another partition on my disc with Windows, and sound is working fine there even now.

Check that Fast Startup in other OS is disabled
How to disable Fast Startup in Windows | Official Support | ASUS Global

I suggest you clear databases and cookie in home folder of any old settings:

rm ~/.config/pulse/*.tdb ~/.config/pulse/cookie

and reboot system

Check pulseaudio service and socket are both (active)running without errors

systemctl --user -l --no-pager status pulseaudio.*

( pulseaudio.socket and pulseaudio.service might have failed if you used pulseaudio -k as suggested in 2nd quoted post, but a reboot should restart them correctly. To restart PulseAudio without affecting systemd socket & service use systemctl --user restart pulseaudio or pactl exit )

If audio is still not working please post ALSA information

sudo --upload

The response will include a link to uploaded data that might be blocked by forum anti-spam rules for new users, but an inactive link can be posted as Preformatted text using </> in reply box or CtrlE on keyboard

1 Like

Hello, Thank you so much for your answer !
I tried all your instructions, and sond still isn’t working. I believe both service and sockets are running fine, but I put the system’s answer just to be sure

systemctl --user -l --no-pager status pulseaudio                1 ✘ 
● pulseaudio.service - Sound Service
     Loaded: loaded (/usr/lib/systemd/user/pulseaudio.service; disabled; vendor preset: enabled)
     Active: active (running) since Mon 2022-02-21 23:08:29 CET; 1min 22s ago
TriggeredBy: ● pulseaudio.socket
   Main PID: 757 (pulseaudio)
      Tasks: 7 (limit: 9215)
     Memory: 21.4M
        CPU: 899ms
     CGroup: /user.slice/user-1000.slice/user@1000.service/session.slice/pulseaudio.service
             ├─ 757 /usr/bin/pulseaudio --daemonize=no --log-target=journal
             └─1040 /usr/lib/pulse/gsettings-helper

févr. 21 23:08:28 SCOPNgin systemd[594]: Starting Sound Service...
févr. 21 23:08:29 SCOPNgin pulseaudio[757]: stat('/etc/pulse/'): Aucun fichier ou dossier de ce type
févr. 21 23:08:29 SCOPNgin systemd[594]: Started Sound Service.

Here is are the ALSA informations

Thank you again for your help, and sorry for the late answer :pensive: