Sound lost again from Dell Inspiron 15

When the sound was lost in December, a recommended update of the Dell Bios fixed it, but the sound has now gone again after the Jan 2 Manjaro update. There doesn’t appear to be another new Dell Bios, so what could be the problem now?
Here is today’s inxi read-out:

[ray@ray-dell ~]$ inxi -Fazy
  Kernel: 5.10.89-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64
    root=UUID=9c7ea2e0-9118-4a42-98d6-74ea85c32f7e rw quiet apparmor=1
    security=apparmor udev.log_priority=3
  Desktop: Xfce 4.16.0 tk: Gtk 3.24.29 info: xfce4-panel wm: xfwm 4.16.1
    vt: 7 dm: LightDM 1.30.0 Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: Dell product: Inspiron 3505 v: 1.4.7
    serial: <superuser required> Chassis: type: 10 v: 1.4.7
    serial: <superuser required>
  Mobo: Dell model: 0NMTCX v: A00 serial: <superuser required> UEFI: Dell
    v: 1.4.7 date: 05/31/2021
  ID-1: BAT1 charge: 38.9 Wh (100.0%) condition: 38.9/42.0 Wh (92.6%)
    volts: 12.3 min: 11.4 model: Simplo 0x32,0x38,0x33,0x35,0x0B,0x0A,0x000F
    type: Li-ion serial: <filter> status: Full
  Info: model: AMD Ryzen 7 3700U with Radeon Vega Mobile Gfx bits: 64
    type: MT MCP arch: Zen/Zen+ note: check family: 0x17 (23)
    model-id: 0x18 (24) stepping: 1 microcode: 0x8108109
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 384 KiB desc: d-4x32 KiB; i-4x64 KiB L2: 2 MiB desc: 4x512 KiB L3: 4 MiB
    desc: 1x4 MiB
  Speed (MHz): avg: 1221 high: 1225 min/max: 1400/2300 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 1225 2: 1219
    3: 1222 4: 1224 5: 1222 6: 1223 7: 1224 8: 1211 bogomips: 36745
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP:
    disabled, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: AMD Picasso vendor: Dell driver: amdgpu v: kernel bus-ID: 04:00.0
    chip-ID: 1002:15d8 class-ID: 0300
  Device-2: Microdia Integrated_Webcam_HD type: USB driver: uvcvideo
    bus-ID: 1-4:3 chip-ID: 0c45:671e class-ID: 0e02
  Display: x11 server: X.Org compositor: xfwm4 v: 4.16.1 driver:
    loaded: amdgpu,ati unloaded: modesetting alternate: fbdev,vesa
    display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2")
    s-diag: 582mm (22.9")
  Monitor-1: eDP res: 1920x1080 hz: 60 dpi: 142 size: 344x193mm (13.5x7.6")
    diag: 394mm (15.5")
  Message: Unable to show advanced data. Required tool glxinfo missing.
  Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio vendor: Dell
    driver: snd_hda_intel v: kernel bus-ID: 04:00.1 chip-ID: 1002:15de
    class-ID: 0403
  Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor vendor: Dell
    driver: N/A alternate: snd_pci_acp3x, snd_rn_pci_acp3x bus-ID: 04:00.5
    chip-ID: 1022:15e2 class-ID: 0480
  Device-3: AMD Family 17h HD Audio vendor: Dell driver: snd_hda_intel
    v: kernel bus-ID: 04:00.6 chip-ID: 1022:15e3 class-ID: 0403
  Sound Server-1: ALSA v: k5.10.89-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.19 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Device-1: Realtek RTL810xE PCI Express Fast Ethernet vendor: Dell
    driver: r8169 v: kernel port: 3000 bus-ID: 02:00.0 chip-ID: 10ec:8136
    class-ID: 0200
  IF: enp2s0 state: down mac: <filter>
  Device-2: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter
    driver: rtw_8821ce v: N/A modules: rtw88_8821ce port: 2000 bus-ID: 03:00.0
    chip-ID: 10ec:c821 class-ID: 0280
  IF: wlp3s0 state: up mac: <filter>
  Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8
    bus-ID: 3-2.4:3 chip-ID: 0bda:c829 class-ID: e001 serial: <filter>
  Report: rfkill ID: hci0 rfk-id: 1 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: see --recommends
  Local Storage: total: 476.94 GiB used: 74.63 GiB (15.6%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: PM991a NVMe 512GB
    size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 type: SSD serial: <filter> rev: 26302039 temp: 21.9 C scheme: GPT
  ID-1: / raw-size: 391.04 GiB size: 383.83 GiB (98.16%)
    used: 74.55 GiB (19.4%) fs: ext4 dev: /dev/nvme0n1p7 maj-min: 259:7
  ID-2: /boot/efi raw-size: 250 MiB size: 246 MiB (98.40%)
    used: 87.3 MiB (35.5%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  Alert: No swap data was found.
  System Temperatures: cpu: 73.6 C mobo: N/A gpu: amdgpu temp: 73.0 C
  Fan Speeds (RPM): fan-1: 0
  Processes: 234 Uptime: 15m wakeups: 1 Memory: 5.75 GiB
  used: 2.17 GiB (37.8%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 11.1.0 Packages: pacman: 1290 lib: 354 Shell: Bash v: 5.1.12
  running-in: xfce4-terminal inxi: 3.3.11
[ray@ray-dell ~]$ 

Any help appreciated.

see if this helps :point_down:

Thanks. Pamac showed sof-firmware already installed, but I’ve now re-installed it with Pamac and re-booted. Still total silence!

yes my mistake. you have a amd cpu so sof-firmware is irrelevant.

this is to show if any audio outputs or inputs are detected and configured correctly in PulseAudio:

pacmd dump

and this to show ALSA settings for audio devices:

amixer --card=0

also do you have manjaro-pulse installed??

Yes, manjaro-pulse is installed.

Here is the pacmd dump output:

[ray@ray-dell ~]$ pacmd dump
### Configuration dump generated at Thu Jan  6 16:39:03 2022

load-module module-device-restore
load-module module-stream-restore
load-module module-card-restore
load-module module-augment-properties
load-module module-switch-on-port-available
load-module module-udev-detect
load-module module-alsa-card device_id="0" name="pci-0000_04_00.1" card_name="alsa_card.pci-0000_04_00.1" namereg_fail=false tsched=yes fixed_latency_range=no ignore_dB=no deferred_volume=yes use_ucm=yes avoid_resampling=no card_properties="module-udev-detect.discovered=1"
load-module module-alsa-card device_id="1" name="pci-0000_04_00.6" card_name="alsa_card.pci-0000_04_00.6" namereg_fail=false tsched=yes fixed_latency_range=no ignore_dB=no deferred_volume=yes use_ucm=yes avoid_resampling=no card_properties="module-udev-detect.discovered=1"
load-module module-jackdbus-detect channels=2
load-module module-bluetooth-policy
load-module module-bluetooth-discover
load-module module-bluez5-discover
load-module module-dbus-protocol
load-module module-native-protocol-unix
load-module module-gsettings
load-module module-combine-sink 
load-module module-native-protocol-tcp 
load-module module-zeroconf-discover 
load-module module-default-device-restore
load-module module-always-sink
load-module module-intended-roles
load-module module-suspend-on-idle
load-module module-console-kit
load-module module-systemd-login
load-module module-position-event-sounds
load-module module-role-cork
load-module module-filter-heuristics
load-module module-filter-apply
load-module module-x11-publish display=:0.0 xauthority=/home/ray/.Xauthority
load-module module-x11-xsmp display=:0.0 xauthority=/home/ray/.Xauthority session_manager=local/ray-dell:@/tmp/.ICE-unix/904,unix/ray-dell:/tmp/.ICE-unix/904
load-module module-cli-protocol-unix

set-sink-volume alsa_output.pci-0000_04_00.6.analog-stereo 0x10000
set-sink-mute alsa_output.pci-0000_04_00.6.analog-stereo no
suspend-sink alsa_output.pci-0000_04_00.6.analog-stereo yes
set-sink-volume combined 0x10000
set-sink-mute combined no
suspend-sink combined yes

set-source-volume alsa_output.pci-0000_04_00.6.analog-stereo.monitor 0x10000
set-source-mute alsa_output.pci-0000_04_00.6.analog-stereo.monitor no
suspend-source alsa_output.pci-0000_04_00.6.analog-stereo.monitor yes
set-source-volume alsa_input.pci-0000_04_00.6.analog-stereo 0xd47a
set-source-mute alsa_input.pci-0000_04_00.6.analog-stereo no
suspend-source alsa_input.pci-0000_04_00.6.analog-stereo yes
set-source-volume combined.monitor 0x10000
set-source-mute combined.monitor no
suspend-source combined.monitor yes

set-card-profile alsa_card.pci-0000_04_00.1 off
set-card-profile alsa_card.pci-0000_04_00.6 output:analog-stereo+input:analog-stereo

set-default-sink alsa_output.pci-0000_04_00.6.analog-stereo
set-default-source combined.monitor

### EOF
[ray@ray-dell ~]$ 

And here is the amixer output:

[ray@ray-dell ~]$ amixer --card=0
Simple mixer control 'PCM',0
  Capabilities: pvolume
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 255
  Front Left: Playback 255 [100%] [0.00dB]
  Front Right: Playback 255 [100%] [0.00dB]
Simple mixer control 'IEC958',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
[ray@ray-dell ~]$ 

As mentioned before, the sound was working fine before the latest Manjaro update.

Previous post suggested more than BIOS update may be needed to resolve issue with Ryzen ACP driver
Sound disappeared from Dell Inspiron 15 - #5 by nikgnomic

System data shows BIOS version: (v1.4.7 date: 05/31/2021) is the same version as previous discussion
Latest BIOS v1.4.9 was released on 27 Dec 2021

Ryzen ACP device is still not loading available driver, but the drivers are detected as alternates

Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor vendor: Dell
    driver: N/A alternate: snd_pci_acp3x, snd_rn_pci_acp3x 

Kernel v5.15 should have better support for AMD acp3x drivers but support will likely be back-ported to kernel v5.10 in the future if you would prefer to wait for that

PulseAudio data shows Card for HDMI/DP output is set to profile Off and only 1 card is active for
analog audio output.
Addition of module-combine-sinks for simultaneous output to more than one sink cannot function correctly if there is only one sink available. This module might be another potential point of failure and should be removed
I suggest turning off option for Simultaneous Output in paprefs or removing module-combine-sink from PulseAudio configuration

Note that paprefs is available from the official repositories (extra). It was not part of the default xfce install here which is from 2018…

I’ve turned off the option of Simultaneous Output in paprefs and re-booted. Still total silence!
I’m out of my depth with the Bios thing - thought I’d updated it but apparently not. How can I get the latest Bios installed?

Download BIOS file from Dell. If you have Windows, execute the .exe. If you don’t have Windows, boot with a WindowsPE disk and navigate to the location of the .exe file. Execute the update. Hirens BootCD is a good example of a free, WindowsPE disk.

Or try with `fwupdmgr. See the following:

If you are not confident about updating firmware try installing kernel v5.15 first

Use Manjaro Settings Manager > Kernel GUI ( manjaro-settings-manager -m msm_kernel )


sudo mhwd-kernel --install linux515

I have to use Windows to get my Manjaro working properly???

You can try with fwupd, if you prefer. I have never used it as I prefer the WindowPE disk method.

Well, I finally fired up the dual-boot Windows OS on the laptop … first time since I got it! Reminded me why I never use Windows, BUT it had a Dell update-system facility which included the BIOS update.
So I’ve done that and come back to Manjaro … and yippee, the sound is working fine again!
Seems bizarre to have to use Windows to fix a Manjaro problem, but hey!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.