Sound Is Muted After Restart

I have a sound issue on 2 computers after I updated to Plasma 5.20.2. The sound is muted when you start the computer, and I have no notification sound either. I can manually turn the sound back on, but cannot make the notification sound to work at all. I know there was a bug in KDE but I thought that was fixed in this new update! Is there any fix for this, or I just have to wait for another update?

System:
Kernel: 5.4.74-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0
Desktop: KDE Plasma 5.20.2 Distro: Manjaro Linux
Machine:
Type: Desktop Mobo: Gigabyte model: B85M-D2V v: x.x serial:
BIOS: American Megatrends v: FC date: 06/19/2014
Graphics:
Device-1: AMD Caicos PRO [Radeon HD 7450] vendor: ASUSTeK driver: radeon
v: kernel bus ID: 01:00.0
Display: x11 server: X.Org 1.20.9 driver: radeon FAILED: ati
unloaded: modesetting resolution: 1: 1920x1080~60Hz 2: 1280x1024~60Hz
OpenGL: renderer: AMD CAICOS (DRM 2.50.0 / 5.4.74-1-MANJARO LLVM 10.0.1)
v: 3.3 Mesa 20.2.1 direct render: Yes
Audio:
Device-1: Intel 8 Series/C220 Series High Definition Audio vendor: Gigabyte
driver: snd_hda_intel v: kernel bus ID: 00:1b.0
Sound Server: ALSA v: k5.4.74-1-MANJARO

check if you have pipewire installed and enabled. If the answer is yes disable both service and socket as user systemctl --user disable ....

Yes, pipewire is already installed, but I’m not following "user systemctl… Could you give me more info, as how to do it?

in terminal execute:

systemctl --user mask pipewire.socket --now
systemctl --user disable pipewire.service --now

and restart.

1 Like

Got it working now, but I still don’t have the “Notification Sounds”.

See in systemsetings5, in audio section, notification volume.

It is on in the system setting, but no sound!

1 Like

It is on in the system setting, but still notification sound!
This is really wired. I have another computer with the exact spec, and programs installed, and no problem there at all. I only had this sound issue on 2 out of 7 machines.

try changing volume from systemsettings if fix issue ,and check in applications tab if notifications volume is’t muted.

Already done all that, but still no notification sound. I went back to Plasma 15.5 via Timeshift and everything is working like it suppose to.

@ddns
This is really wire! I just updated again from plasma 5.15 to 5.20.2, and everything is working again, including the notification sounds! :open_mouth: