Sound gone from some applications after autoremoving orphaned dependencies

I installed and then uninstalled Lutris and its dependencies.
Now, audio won’t play from some applications.
White noise in Audacity is fine, but YouTube videos in Chromium are silent.
Here’s the relevant portion of pacman.log:
I’m guessing it’s related to media codecs, but I’m not sure how to repair it.
Would someone mind telling me what to do to resolve this?
Thanks in advance.

Thats why you shouldnt automatically remove orphans :wink:

faudio looks like the most likely candidate … though it shouldnt be required for audio.
There are other semi-related ones like lib32-mpg123 … but I dont know why you would require the 32bit version.

Faudio is only for DirectX audio support; according to, it’s only required by Wine.
I reinstalled it and rebooted regardless; audio still not working in the same way as before.
What package(s) should I try next?

PS I’ve now turned off autoremoving orphans; I’m not sure why it was on initially…

Here’s a bit more testing on my part to attempt to diagnose this.
VLC or Audacity will play anything.
Discord (Chromium) won’t play static audio files (even with codecs definitely installed), but outputs audio calls (live rendering of opus frames) fine.
Does this help to find out what the issue could be?

So your issue is really discord?
Discord in chromium ? How is chromium installed ? Or if not, how is Discord installed ?

To clarify, Chromium won’t play anything. Opening Discord in Chromium is also completely silent.
Discord’s desktop app is built on top of Chromium, but the calls work fine.
I’m assuming this is because the desktop app uses native audio sending for the calls and nothing else.
If this is the case, then Chromium-originated audio is silent, but everything else is audible.
Not sure if this is suddenly uninstall-caused, but that was the last thing I did before the issue.
The log above is all the package removal from that day.
Maybe Lutris/Wine/a game changed some audio setting that would interfere.

How would I further diagnose/solve from here?

Not sure. You dont seem to have removed anything that should break audio.
Maybe we have to wait for some of the sound specialists to stop by.

Alright, thanks for your help this far.

Before anyone asks, I did uninstall/reinstall Chromium; didn’t resolve the issue.

I fixed it by going into advanced audio settings and muting/unmuting Chromium.
Some setting got tweaked and it’s fine now. I had never modified the setting yet it was changed somehow.
I guess KDE had a small audio stroke and couldn’t right itself.
This does mean that non-call Discord audio is recognised as Chromium audio by KDE/Pulse/ALSA/someone.

Alright. Well, I guess we will take it :sweat_smile:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.