Sound delayed over Display Port, all fine over headphones

Hello all.
I’ve been having weird audio issues where audio coming from Display Port would be ‘slower’ (distorted) than the audio coming from the headphones (connected to the headphone jack). I have tried this in both firefox and brave browser via youtube, and confirmed that they both suffer from the same problem.

It is a weird problem because if I boot from the live USB, audio over DP is fine. There is no lag or anything. However, since I installed manjaro onto my ssd, I have issues with sound.

I use R9 270x so I switched from radeon driver to amdgpu, but I don’t know if that is the real problem here.

I have searched for similar problems on the forum, but everything I found and tried did nothing. The sound is still lagging if played from DP but perfectly fine if played over headphones. I don’t think it has anything to do with BIOS either, as I guess it wouldn’t work on live USB then. I tried various changes to /etc/pulse/daemon.conf that I found online, but it didn’t help.

I’m on kernel 5.14.10-1 with pulseaudio v15.0. Pipewire is disabled and pulseaudio is running. I tried to boot to live USB and check the settings via the

pulseaudio --dump-conf

and then compared to the defaults on my PC and they’re the same. There is no difference. Also compared /etc/pulse/daemon.conf and /etc/pulse/, and they’re identical to the live USB settings.

I’ve been debugging this for hours and I’m becoming frustrated. I know the sound works perfectly on windows, as that’s what I’ve been using up until recently. I really like manjaro and KDE and would like to keep using them, but if I can’t get the sound to work properly, guess I’ll have to search for something else or return to windows.
Below is the output of inxi -Fxz if it is of any use:

  Kernel: 5.14.10-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
  Desktop: KDE Plasma 5.22.5 Distro: Manjaro Linux base: Arch Linux
  Type: Desktop Mobo: ASRock model: B460M Steel Legend
  serial: <filter> UEFI: American Megatrends v: P1.60
  date: 08/31/2020
  Info: 6-Core model: Intel Core i5-10400 bits: 64 type: MT MCP
  arch: Comet Lake rev: 3 cache: L2: 12 MiB
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  bogomips: 69629
  Speed: 800 MHz min/max: 800/4300 MHz Core speeds (MHz): 1: 800
  2: 800 3: 800 4: 800 5: 800 6: 800 7: 800 8: 800 9: 800 10: 800
  11: 800 12: 800
  Device-1: AMD Curacao XT / Trinidad XT [Radeon R7 370 / R9
  vendor: ASUSTeK driver: amdgpu v: kernel bus-ID: 01:00.0
  Display: x11 server: X.Org 1.20.13 driver: loaded: amdgpu,ati
  unloaded: modesetting resolution: 1920x1080
  OpenGL: renderer: AMD Radeon HD 8800 Series (PITCAIRN DRM 3.42.0
  5.14.10-1-MANJARO LLVM 12.0.1)
  v: 4.6 Mesa 21.2.3 direct render: Yes
  Device-1: Intel vendor: ASRock driver: snd_hda_intel v: kernel
  bus-ID: 00:1f.3
  Device-2: AMD Oland/Hainan/Cape Verde/Pitcairn HDMI Audio [Radeon
  HD 7000 Series]
  vendor: ASUSTeK driver: snd_hda_intel v: kernel bus-ID: 01:00.1
  Sound Server-1: ALSA v: k5.14.10-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.19 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.38 running: no
  Device-1: Realtek RTL8125 2.5GbE vendor: ASRock driver: r8169
  v: kernel port: 3000 bus-ID: 02:00.0
  IF: enp2s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Local Storage: total: 1.14 TiB used: 174.73 GiB (14.9%)
  ID-1: /dev/nvme0n1 vendor: A-Data model: SX6000LNP
  size: 238.47 GiB temp: 35.9 C
  ID-2: /dev/sda vendor: Western Digital model: WD10EZEX-75WN4A1
  size: 931.51 GiB
  ID-1: / size: 233.38 GiB used: 23.68 GiB (10.1%) fs: ext4
  dev: /dev/nvme0n1p2
  ID-2: /boot/efi size: 299.4 MiB used: 288 KiB (0.1%) fs: vfat
  dev: /dev/nvme0n1p1
  Alert: No swap data was found.
  System Temperatures: cpu: 31.0 C mobo: N/A gpu: amdgpu
  temp: 35.0 C
  Fan Speeds (RPM): N/A
  Processes: 273 Uptime: 26m Memory: 15.56 GiB
  used: 2.31 GiB (14.8%) Init: systemd Compilers: gcc: 11.1.0
  Packages: 1297 Shell: Zsh v: 5.8 inxi: 3.3.07

Any help is appreciated! If more info is needed, I’d be happy to provide it.

Okay, I figured out it has to do with the amdgpu driver. Audio works fine with radeon driver, but not with amdgpu. Does anyone know anything about this?