Sound configuration with ALSA

Hello, hopefully someone can help…
I have some problem with the sound. I have a MSI Creator TRX40 board wiht a ALC1220 sound chip. It’s recognized as a USB device. My problem is, i can’t get that device to be selected/loaded as default output and thus upon reboot i need to first configure the sound and then restart apps like Skype, which do not recoginze the sound output because it was not present on boot.

On reboot i can see the output as “USB Audio” in the sound configuration, but the profile is “Off”. I have to select “Default ALSA profile (not present)” and then the Speakers will appear in the output devices.
I can then select the “USB Audio Speakers” as default “altenate option”.

Now the sound works, but i have to restart all apps like Skype, Teams etc. to be able to select the new output.

Any advice how this can be automated, so the output is selected as default?

have you added have you in your boot kernel ( see /etc/default/grub )

is it ALC1220 or ALC1220-VB ?

can you check with

sudo pacman -S hwdetect
sudo hwdetect --show-modules

No it’s not in there

AGP      : agpgart 
BLOCK    : uvcvideo xhci-hcd xhci-pci xhci-pci-renesas typec typec_ucsi ucsi_ccg snd-usb-audio snd-usbmidi-lib 
BLUETOOTH: btbcm btintel btrtl btusb bluetooth 
CPUFREQ  : acpi-cpufreq pcc-cpufreq 
CRYPTO   : aesni-intel crc32c-intel crc32-pclmul crct10dif-pclmul ghash-clmulni-intel glue_helper cryptd crypto_simd ecc ecdh_generic ccp 
DRM      : drm_kms_helper drm 
HWMON    : amd_energy k10temp 
I2C      : i2c-algo-bit i2c-nvidia-gpu i2c-piix4 
INPUT    : evdev input-leds joydev mousedev hid-generic hid usbhid 
KVM      : kvm-amd kvm 
MEDIA    : cec videobuf2-common videobuf2-memops videobuf2-v4l2 videobuf2-vmalloc mc rc-core uvcvideo videodev 
NET      : atlantic igb fjes macsec iwlwifi bluetooth rfkill cfg80211 
SOUND    : pcspkr snd-hwdep snd snd-pcm snd-rawmidi snd-seq-device snd-timer snd-hda-core snd-intel-dspcfg snd-hda-codec-hdmi snd-hda-codec snd-hda-intel soundcore snd-usb-audio snd-usbmidi-lib 
WATCHDOG : sp5100_tco 
OTHER    : nvidia-drm nvidia nvidia-modeset rapl rng-core dca amd64_edac_mod edac_mce_amd mac_hid pinctrl-amd mxm-wmi wmi-bmof wmi fb_sys_fops syscopyarea sysfillrect sysimgblt crc16 irqbypass

pacmd list-cards lists as

name: <alsa_card.usb-Generic_USB_Audio-00>
driver: <module-alsa-card.c>
owner module: 28
	alsa.card = "2"
	alsa.card_name = "ALC1220-VB-DT"
	alsa.long_card_name = "Realtek-ALC1220-VB-Desktop"
	alsa.driver_name = "snd_usb_audio"
	device.bus_path = "pci-0000:47:00.1-usb-0:5:1.0"
	sysfs.path = "/devices/pci0000:40/0000:40:01.1/0000:41:00.0/0000:42:08.0/0000:47:00.1/usb9/9-5/9-5:1.0/sound/card2" = "usb-Generic_USB_Audio-00"
	device.bus = "usb" = "0db0" = "Micro Star International" = "0d64" = "USB Audio"
	device.serial = "Generic_USB_Audio"
	device.string = "2"
	device.description = "USB Audio"
	module-udev-detect.discovered = "1"
	device.icon_name = "audio-card-usb"
	HiFi: Default Alsa Profile (priority 8000, available: no)
	off: Aus (priority 0, available: unknown)
active profile: <HiFi>
	alsa_output.usb-Generic_USB_Audio-00.HiFi__hw_ALC1220VBDT_2__sink/#1: USB Audio S/PDIF Out
	alsa_output.usb-Generic_USB_Audio-00.HiFi__hw_ALC1220VBDT_1__sink/#2: USB Audio Front Headphones
	alsa_output.usb-Generic_USB_Audio-00.HiFi__hw_ALC1220VBDT__sink/#3: USB Audio Speakers
	alsa_output.usb-Generic_USB_Audio-00.HiFi__hw_ALC1220VBDT_2__sink.monitor/#2: Monitor of USB Audio S/PDIF Out
	alsa_output.usb-Generic_USB_Audio-00.HiFi__hw_ALC1220VBDT_1__sink.monitor/#3: Monitor of USB Audio Front Headphones
	alsa_output.usb-Generic_USB_Audio-00.HiFi__hw_ALC1220VBDT__sink.monitor/#4: Monitor of USB Audio Speakers
	alsa_input.usb-Generic_USB_Audio-00.HiFi__hw_ALC1220VBDT_2__source/#5: USB Audio Front Microphone
	alsa_input.usb-Generic_USB_Audio-00.HiFi__hw_ALC1220VBDT_1__source/#6: USB Audio Microphone
	alsa_input.usb-Generic_USB_Audio-00.HiFi__hw_ALC1220VBDT__source/#7: USB Audio Line In
	[Out] SPDIF: S/PDIF Out (priority 200, latency offset 0 usec, available: unknown)
	[Out] Headphones: Front Headphones (priority 300, latency offset 0 usec, available: no)
	[Out] Speaker: Speakers (priority 100, latency offset 0 usec, available: yes)
	[In] Mic2: Front Microphone (priority 300, latency offset 0 usec, available: no)
	[In] Mic1: Microphone (priority 200, latency offset 0 usec, available: no)
	[In] Line: Line In (priority 100, latency offset 0 usec, available: no)

have you checked with pavucontrol ?

Yes. I can select “Default ALSA profile (not present)” there. Then the output is listed under Output-Devices and i can set it as default “altenate option”.
On boot, the USB-Profile is “Off”

You can try to set it as default in your profile. Example:

[mbb@mocho-desktop ~]$ cat .config/pulse/
.include /etc/pulse/

set-card-profile alsa_card.pci-0000_00_1b.0 output:analog-stereo+input:analog-stereo
set-sink-port alsa_output.pci-0000_00_1b.0.analog-stereo analog-output-lineout