Sound coming from only left speaker on headphones

Hey all!

My headphones are only playing from the left ear but both my laptops speakers are working. I tested by headphones on a mac and both sides worked. I am using pulseaudio.

Computer: Inspiron 3785
Audio Driver: Family 17h (Models 10h-1fh) HD Audio Controller

Help would be appreciated :smiley:

Hi!

I had the same issue. I am sure there’s a more “elegant” solution, but I installed an audio manager that had a balance slider. Turned out the balance was all the way to the left as I suspected, but I couldn’t find a way to change it with the default apps.

If you are using Pulseaudio and you go to the settings of PulseAudio, you will find the section “Devices”. On the right side of your Sound Output should be the button “balance”. When you click on that one you will find a slider for left and a slider for right.

1 Like

Hey could you give me a audio manager?

I tried that in pavucontrol but it did not work

Go to Output Devices tab in pavucontrol and click the lock icon :lock: to unlock channels

I tried that but unfortunately it did not work

I used pavucontrol, but seems it didn’t work for you. I’ll let you know if I figure out something else.

If you click the padlock icon, can you see 2 audio level controls for left and right channel?

do you hear audio level change in headphones if you move one control for left or right channel ?

Do your headphones have a brand name or model number?

Yes I tried that as well but did not work. These headphones have worked before on this laptop until recently. It seems as if my laptop is sensing only one side.

Hello,

I have the same problem.

00:1b.0 Audio device [0403]: Intel Corporation C600/X79 series chipset High Definition Audio Controller [8086:1d20] (rev 06)
        Subsystem: ASUSTeK Computer Inc. Device [1043:8436]
        Kernel driver in use: snd_hda_intel

I think it’s something to do with some updates for intel. I’m using KDE, 5.10.7-3-MANJARO #1 SMP PREEMPT. I tried to balance in KDE(audio) settings but right channel is not changing at all. PAVUCONTROL did’t help as well. Help would be appreciated.

I was starting to think I was the only one with this problem. I guess I am going to sit tight a wait until intel fixes the problem.

You are not alone and the issue is not limited to Manjaro

Unfortunately, I don’t have any explanation. But running alsamixer command and browsing through menus and exiting helped me.

If someone can provide any clarification that would be great. Looks like alsamixer command did something similar as pavucontrol as described before in the post

alsamixer
F6 (select HDA Intel PCH)
Check channels
exit
1 Like

I had a same issue, but i solved it by configuring panning inside alsamixer.
FYI, you can increase (Left / both / Right) volume by pressing (Q / W / E) and decrease it with (Z / X / C).

2 Likes

thanks it worked

1 Like

Welcome to the community!

I believe that my output device is broken. I have wiped my system twice now running a different desktop environment. So I solved the issue by just getting a jack to usb adapter

1 Like

I also had this issue, in my case, unplugging and plugging the jack helped.