Sound card not recognized after clean install?

Hey guys, this is my first forum post. I tried looking around, but I couldn’t find a thread that was compatible with my problem, so if I missed something, feel free to point it out.

So I clean-installed the latest release of Manjaro (kernel version 5.13) and I can’t get the sound to work.

Here’s the output of aplay -lL:

$ aplay -lL                                                                     ✔  4s  
    Discard all samples (playback) or generate zero samples (capture)
    Rate Converter Plugin Using Samplerate Library
    Rate Converter Plugin Using Speex Resampler
    JACK Audio Connection Kit
    Open Sound System
    PipeWire Sound Server
    PulseAudio Sound Server
    Plugin using Speex DSP (resample, agc, denoise, echo, dereverb)
    Plugin for channel upmix (4,6,8)
    Plugin for channel downmix (stereo) with a simple spacialization
    Default ALSA Output (currently PulseAudio Sound Server)
aplay: device_list:274: no soundcards found...

The output of inxi -Fx:

$ inxi -Fx                                                                             ✔ 
System:    Host: lain Kernel: 5.13.19-2-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
           Desktop: KDE Plasma 5.22.5 Distro: Manjaro Linux base: Arch Linux
Machine:   Type: Laptop System: Dell product: Inspiron 7591 v: N/A serial: <superuser required>
           Mobo: Dell model: 0422G6 v: A00 serial: <superuser required> UEFI: Dell v: 1.9.0
           date: 12/14/2020
Battery:   ID-1: BAT0 charge: 8.1 Wh (27.0%) condition: 30.0/56.0 Wh (53.5%) volts: 11.0
           min: 11.4 model: BYD DELL CP6DF06 status: Discharging
CPU:       Info: Quad Core model: Intel Core i5-9300H bits: 64 type: MT MCP arch: Kaby Lake
           note: check rev: A cache: L2: 8 MiB
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 38408
           Speed: 800 MHz min/max: 800/4100 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800
           5: 800 6: 800 7: 800 8: 800
Graphics:  Device-1: Intel CoffeeLake-H GT2 [UHD Graphics 630] vendor: Dell driver: i915
           v: kernel bus-ID: 00:02.0
           Device-2: Realtek Integrated_Webcam_HD type: USB driver: uvcvideo bus-ID: 1-5:2
           Display: x11 server: X.Org 1.20.13 driver: loaded: modesetting
           resolution: 1920x1080~60Hz
           OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa 21.2.3
           direct render: Yes
Audio:     Device-1: Intel Cannon Lake PCH cAVS vendor: Dell driver: sof-audio-pci-intel-cnl
           bus-ID: 00:1f.3
           Sound Server-1: ALSA v: k5.13.19-2-MANJARO running: yes
           Sound Server-2: JACK v: 1.9.19 running: no
           Sound Server-3: PulseAudio v: 15.0 running: yes
           Sound Server-4: PipeWire v: 0.3.38 running: yes
Network:   Device-1: Intel Cannon Lake PCH CNVi WiFi driver: iwlwifi v: kernel bus-ID: 00:14.3
           IF: wlo1 state: up mac: 9c:fc:e8:f8:0e:d0
Bluetooth: Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: USB driver: btusb
           v: 0.8 bus-ID: 1-14:4
           Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends
Drives:    Local Storage: total: 476.94 GiB used: 9.36 GiB (2.0%)
           ID-1: /dev/nvme0n1 vendor: Toshiba model: KBG40ZNS512G NVMe KIOXIA 512GB
           size: 476.94 GiB temp: 43.9 C
Partition: ID-1: / size: 38.15 GiB used: 9.32 GiB (24.4%) fs: ext4 dev: /dev/nvme0n1p5
           ID-2: /boot/efi size: 96 MiB used: 48.6 MiB (50.6%) fs: vfat dev: /dev/nvme0n1p1
Swap:      Alert: No swap data was found.
Sensors:   System Temperatures: cpu: 50.0 C mobo: N/A
           Fan Speeds (RPM): cpu: 3136 fan-2: 0
Info:      Processes: 272 Uptime: 4h 3m Memory: 15.4 GiB used: 3.71 GiB (24.1%) Init: systemd
           Compilers: gcc: N/A Packages: 1203 Shell: Zsh v: 5.8 inxi: 3.3.08

Thank you in advance.

Welcome to the forum :wave:

This might be your problem, I’ve seen posts go by here where this was an issue, there can be only one of these active iirc. You might have some easy solutions in the #announcements:stable-updates threads, (2nd posts have a solition wiki added) These threads are goldmies for solutions :slight_smile:

Edit: just checked, this might not be your issue as this is the exact same verision/setting I get when running inxi, knowledgeble other user needed!

Advice: install a LTS kernel and the latest stable.

Hello @voyage1970 and wellcome to the forum.

I dont know if kernel 5.13 has the same problem as 5.6. But in the old forum it was solved by installing ‘sof-firmware’.

pamac install sof-firmware

This worked! Thank you so much!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.