Sound becoming unstable - breaks each time a new source starts SOLVED

Hi everyone (and thanks in advance for taking your time even if just reading):

I’m an old linux user (since 2001), and migrated to Manjaro (from Suse, OpenSuse, Ubuntu and Mint previously) in my new laptop just about two monthes ago. And very happy, I must say, till a couple of weeks ago…

My system was working marvellously. But suddenly one day sound started to stop when I changed from one source to another (let’s say seeing a youtube video in browser and then changing into some music on Spotify client, or starting any other application with sound).

Could be after an upgrade? Perhaps, but it was in a moment with such amount of work that I didn’t took the time to check, and I forgot the exact moment.

I’ve just discovered that I was able to touch some options on pavucontrol and alsamixer and, usually, recover sound again, at least for the moment, so I decided to continue like that provisionally. Not a concrete series os steps, but chaging things and returning to origin used to work.

But a couple of days ago, having more time, I start to investigate all of this. And I saw that really, what was happening is that sound stops in a non completely consistent way. Most of the time (but not really always) it stops working whenever sound is stoppped and then started again. Not just changing from browser to another app, for example, but also stopping a video in browser and the sarting another one, even in the same tab (chrome, BTW).
But sometimes it does not happen, and works ok for some time.
Usually, when trying to reproduce sound after booting computer or recovering from sleep, there is the same problem. I have to fiddle a bit, and then sound works… till it stops again.

What I discovered I have to do to recover sound is to open pavucontrol, go to the last tab (configuration), and set the profile for my card (integrated for intel, Tiger lake-LP… more info later) to stopped (don’t know the exact word in English, my system is in Spanish), so that sound is disabled, and turn again it to the only option in my case, “Play HiFi quality Music”.
And then I have to take headphones out and in again, if plugged, or use the mute on and off if on speakers, and sound reappears.
It’s like it would have started muted after the reinititialization (even if in alsamixer doesn’t appear as muted) and needs to change into real mute and again unmuted to properly work.

It’s just unbearable. You cannot be using continually the workaround each time you use sound, or stop it and star a new video, audio, or whatever… And I’m also musician, and use to edit sound on my laptop when doing recordings, and that’s not a possibility to be doing so… I have to use may old computer by now for this. Thanks God is still working…

Searching a lot of things (none seem to help…), I realised that even if I was using pulseaudio and jack, as always since years ago, pipewire was installed and running, for some dependencies. I could not unninstall it, so I tried to stop it or even systemctl mask it. But there was no improvement.

So, seeing that pipewire seems to be in a very usable state, I changed into it, and deleted my pulse and jack servers, to avoid mixing things, for it could create difficulties. Pipewire is working fine… when it does, exactly the same as pulseaudio before. So I guess is more an alsa or a driver question. But there is nothing that’s shown in logs related to that.

I’ve being thoughly trying to check and investigate my dmesg and jounal, but there is nothing that can give me a hint of what’s happening there.

My system is an Lenovo Ideapad Gaming, wifh following characteristics:

Type: Laptop System: LENOVO product: 82K1 v: IdeaPad Gaming 3 15IHU6

Host: nacho-Lenovo Kernel: 5.15.85-1-MANJARO arch: x86_64 bits: 64
Desktop: Xfce v: 4.18.0 Distro: Manjaro Linux

Info: quad core 11th Gen Intel Core i5-11320H [MT MCP] speed (MHz):
avg: 1213 min/max: 400/4500

Memory: 16 GiB

Device-1: Intel TigerLake-LP GT2 [Iris Xe Graphics] driver: i915 v: kernel
Device-2: NVIDIA TU117M [GeForce GTX 1650 Mobile / Max-Q] driver: nvidia
v: 525.60.11
Device-3: Syntek Integrated Camera type: USB driver: uvcvideo
Display: x11 server: X.Org v: 21.1.6 driver: X: loaded: modesetting,nvidia
dri: iris gpu: i915 resolution: 1920x1080~60Hz
API: OpenGL v: 4.6 Mesa 22.3.1 renderer: Mesa Intel Xe Graphics (TGL GT2)

Device-1: Intel Tiger Lake-LP Smart Sound Audio
driver: sof-audio-pci-intel-tgl
Sound API: ALSA v: k5.15.85-1-MANJARO running: yes
Sound Server-1: PipeWire v: 0.3.63 running: yes

The only messages I can find on journal from the moments when sound fails (but not really always) are
wireplumber[2255]: Failed to enable ucm device Headphones
wireplumber[2255]: Failed to enable ucm Mic2
wireplumber[2255]: Failed to enable ucm Mic1

But this seem not to be the problem, but a consequence of it. I’ve tried to downgrade my alsa-ucm-conf package, for it could be a bad upgrade, or an incompatibility, but there was no change.

Also, some times I get a pipewire segfault in dmesg, or some messages in journal about pipewire about "double free or corrupted (fasttop), about being failed with ‘core-dump’ and other ones in the same styke, but they, once again, seem to be consequence and not couse (it was happening axacly the same with pulse and no pipewire, and I’ve googled a lot about the messages, but found nothig that makes sens in my case).

I’m completely lost, for first time in my 20 years linux experience, I have to say.

Any help would be really welcome.

Last state would be reinstall completelly system… I would like to avoid that, i should say. For I’m not sure if it’s happening again, since I cannot identify what’s happening. If reintalling, I would probably try againg another of the distros I was using previously, for security, but I have to say that I’m enjoying Manjaro and would like to stick to it, if I’m able to manage this serious problem.


Looks to me as power saving feature which was not toggled correctly. Maybe try without?

There are options for TLP:

 sudo tlp-stat --pcie
 sudo tlp-stat --usb

Normally pipewire has a wake up function, which can be seen in the journal when running in triple -v mode.

I’ll try that, could be that!

I don’t see anything special, but, here you are:

pipewire -vvv

[E][07274.771491] mod.protocol-native | [module-protocol-:  687 init_socket_name()] server 0x55fc6ecac7d0: name pipewire-0 is not an absolute path and no runtime dir found. Set one of PIPEWIRE_RUNTIME_DIR, XDG_RUNTIME_DIR or USERPROFILE in the environment
[E][07274.771792] pw.conf      | [          conf.c:  594 load_module()] 0x55fc6ec716b0: could not load mandatory module "libpipewire-module-protocol-native": No existe el fichero o el directorio
[E][07274.772189] default      | [      pipewire.c:  125 main()] failed to create context: No existe el fichero o el directorio
[D] pw.context [pipewire.c:208 unref_handle()] clear handle 'support.cpu'
[D] pw.context [pipewire.c:208 unref_handle()] clear handle 'support.log'
[D] pw.context [pipewire.c:169 unref_plugin()] unloaded plugin:'/usr/lib/spa-0.2/support/'
[D] pw.context [pipewire.c:208 unref_handle()] clear handle 'support.log'
[D] pw.context [pipewire.c:169 unref_plugin()] unloaded plugin:'/usr/lib/spa-0.2/support/'

sudo tlp-stat --usb (it’s not usb, so nothing special there)

--- TLP 1.5.0 --------------------------------------------

+++ USB
Autosuspend       = enabled
Device allowlist  = (not configured)
Device denylist   = (not configured)
Exclude audio     = enabled
Exclude bluetooth = disabled
Exclude phones    = disabled
Exclude printers  = enabled
Exclude WWAN      = disabled

Bus 002 Device 001 ID 1d6b:0003 control = auto, autosuspend_delay_ms =    0 -- Linux Foundation 3.0 root hub (hub)
Bus 001 Device 004 ID 048d:c966 control = on,   autosuspend_delay_ms = 2000 -- Integrated Technology Express, Inc. ITE Device(8176) (usbhid)
Bus 001 Device 003 ID 174f:244c control = auto, autosuspend_delay_ms = 2000 -- Syntek Integrated Camera (uvcvideo)
Bus 001 Device 005 ID 8087:0026 control = auto, autosuspend_delay_ms = 2000 -- Intel Corp. AX201 Bluetooth (btusb)
Bus 001 Device 001 ID 1d6b:0002 control = auto, autosuspend_delay_ms =    0 -- Linux Foundation 2.0 root hub (hub)

And sudo tlp-stat --pcie

--- TLP 1.5.0 --------------------------------------------

+++ PCIe Active State Power Management
/sys/module/pcie_aspm/parameters/policy = [default] performance powersave powersupersave

+++ PCIe Runtime Power Management
Enable devices    = (disabled)
Disable devices   = (disabled)
Device denylist   = (disabled)
Driver denylist   = mei_me nouveau radeon

/sys/bus/pci/devices/0000:00:00.0/power/control = on   (0x060000, Host bridge, no driver)
/sys/bus/pci/devices/0000:00:02.0/power/control = on   (0x030000, VGA compatible controller, i915)
/sys/bus/pci/devices/0000:00:04.0/power/control = on   (0x118000, Signal processing controller, proc_thermal)
/sys/bus/pci/devices/0000:00:08.0/power/control = on   (0x088000, System peripheral, no driver)
/sys/bus/pci/devices/0000:00:0a.0/power/control = on   (0x118000, Signal processing controller, intel-pmt)
/sys/bus/pci/devices/0000:00:0e.0/power/control = on   (0x010400, RAID bus controller, vmd)
/sys/bus/pci/devices/0000:00:14.0/power/control = on   (0x0c0330, USB controller, xhci_hcd)
/sys/bus/pci/devices/0000:00:14.2/power/control = on   (0x050000, RAM memory, no driver)
/sys/bus/pci/devices/0000:00:14.3/power/control = on   (0x028000, Network controller, iwlwifi)
/sys/bus/pci/devices/0000:00:15.0/power/control = on   (0x0c8000, Serial bus controller, intel-lpss)
/sys/bus/pci/devices/0000:00:16.0/power/control = auto (0x078000, Communication controller, mei_me)
/sys/bus/pci/devices/0000:00:17.0/power/control = on   (0x088000, System peripheral, no driver)
/sys/bus/pci/devices/0000:00:1c.0/power/control = on   (0x060400, PCI bridge, pcieport)
/sys/bus/pci/devices/0000:00:1d.0/power/control = on   (0x088000, System peripheral, no driver)
/sys/bus/pci/devices/0000:00:1d.3/power/control = on   (0x060400, PCI bridge, pcieport)
/sys/bus/pci/devices/0000:00:1f.0/power/control = on   (0x060100, ISA bridge, no driver)
/sys/bus/pci/devices/0000:00:1f.3/power/control = on   (0x040100, Multimedia audio controller, sof-audio-pci-intel-tgl)
/sys/bus/pci/devices/0000:00:1f.4/power/control = on   (0x0c0500, SMBus, i801_smbus)
/sys/bus/pci/devices/0000:00:1f.5/power/control = on   (0x0c8000, Serial bus controller, intel-spi)
/sys/bus/pci/devices/0000:01:00.0/power/control = on   (0x030200, 3D controller, nvidia)
/sys/bus/pci/devices/0000:02:00.0/power/control = on   (0x020000, Ethernet controller, r8169)
/sys/bus/pci/devices/0000:10000:e0:17.0/power/control = (not available) (, SATA controller, no driver)
/sys/bus/pci/devices/0000:10000:e0:1d.0/power/control = (not available) (, PCI bridge, no driver)
/sys/bus/pci/devices/0000:10000:e1:00.0/power/control = (not available) (, Non-Volatile memory controller, no driver)

In this one appears the sof-audio-pci-intel-tgl that controls sound, of course.

So, will try that, and see if there is any improvement.


I’ve just found that, probably related:

something’s probably broken in last updates… Hope that’s averything, and it’s solved soon!

Kernel linux60 seems to work.
Origin is an important failure in last upgrade to Linux 515

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.